missing controls on toolbar of youtube videos

Bug #1326852 reported by Bill Filler on 2014-06-05
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Oxide
Critical
Chris Coulson
1.0
Critical
Chris Coulson
webbrowser-app
Invalid
Undecided
Unassigned

Bug Description

playback of youtube videos is now possible with this branch
https://code.launchpad.net/~osomon/webbrowser-app/youtube-ua-override/+merge/222015

However the embedded youtube player is missing controls on it's toolbar for play/pause and for fullscreen.

See the screenshots of oxide vs. chrome for Android to see what's missing.

Bill Filler (bfiller) wrote :

Specifically, the following is missing/broken on our version:

- no play/pause button on toolbar
- no play button overlay on video when it's paused
- the scrubber is missing a button to grab and drag so you can't scrub
- no fullscreen button on toolbar
- seems we have a volume control (the widget on the far right) that Chrome does not have. But has the same problem as scrubber above - no way to select and drag it

Bill Filler (bfiller) wrote :
Bill Filler (bfiller) wrote :
tags: added: rtm14
Changed in oxide:
milestone: none → branch-1.1
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
status: Triaged → Fix Released
Changed in webbrowser-app:
status: New → Invalid
Chris Coulson (chrisccoulson) wrote :

Would probably be good to have this in 1.0 as well

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers