re-add support for selecting text for copying

Bug #1324292 reported by Bill Filler on 2014-05-28
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Oxide
Critical
Olivier Tilloy
1.2
Critical
Olivier Tilloy
webbrowser-app
Fix Released
Critical
Olivier Tilloy
webbrowser-app (Ubuntu)
Critical
Olivier Tilloy

Bug Description

in the qtwebkit browser we had the ability to create a selection region with handles for resizing. needs to bring this back for oxide based browser.

Related branches

Bill Filler (bfiller) on 2014-05-28
Changed in webbrowser-app:
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
tags: added: rtm14
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Chris Coulson (chrisccoulson) wrote :

This is dependant on bug 1301419, and possibly bug 1326070 too IIUC

Olivier Tilloy (osomon) on 2014-06-06
Changed in webbrowser-app:
status: New → Triaged
Bill Filler (bfiller) on 2014-06-13
Changed in webbrowser-app:
milestone: none → feature-freeze
Olivier Tilloy (osomon) on 2014-06-17
Changed in webbrowser-app:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20140630-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20140630-0ubuntu1) utopic; urgency=low

  [ Olivier Tilloy ]
  * Re-enable contextual selection that had been disabled when switching
    to oxide. Packaging change: renamed the qtdeclarative5-ubuntu-ui-
    extras-browser-plugin-assets package to qtdeclarative5-ubuntu-web-
    plugin-assets. (LP: #1324292)
 -- Ubuntu daily release <email address hidden> Mon, 30 Jun 2014 08:11:47 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) on 2014-06-30
Changed in webbrowser-app:
status: In Progress → Fix Released
David Barth (dbarth) on 2014-08-05
Changed in oxide:
importance: Undecided → High
David Barth (dbarth) on 2014-09-09
tags: added: touch-2014-10-16
Victor Tuson Palau (vtuson) wrote :

if this prevents from having copy resizing area in the browser and webapps then it should be critical and target much sooner

Bill Filler (bfiller) on 2014-09-16
Changed in webbrowser-app:
status: Fix Released → Confirmed
Changed in webbrowser-app (Ubuntu):
status: Fix Released → Confirmed
tags: added: touch-2014-09-25
removed: touch-2014-10-16
Olli Ries (ories) on 2014-09-16
Changed in webbrowser-app (Ubuntu):
importance: High → Critical
Changed in webbrowser-app:
importance: High → Critical
Bill Filler (bfiller) wrote :

Our support for text selection and resizing seems to not be working very well.
Using rtm build on krillin with webbrowser-app 0.23+14.10.20140910~rtm-0ubuntu1
oxide: 1.2.0-0ubuntu1

Testing using the following web sites:
cnn.com, mobile.nytimes.com, m.espn.go.com, ubuntu.com

1) very difficult, or impossible to get the selection rectangle to show up at all. Press and hold does not seem to be triggering it. Often I just get a single word highlighted.
2) times I do get the selection rectangle to show up, I can't resize it to anything smaller than the paragraph which it seems to select by default. I can't get it to select just a single line or multiple words within the lines.

Changed in oxide:
importance: High → Critical
Olivier Tilloy (osomon) wrote :

> 2) times I do get the selection rectangle to show up, I can't resize
> it to anything smaller than the paragraph which it seems to select by
> default. I can't get it to select just a single line or multiple words
> within the lines.

The selection mechanism has never had the ability to select a single line or multiple words. It works by selecting HTML elements, so if a paragraph of text is within a <p> or <div> block, the smallest selection possible is that block.

Until we get proper text selection in oxide, I’m afraid we can’t do better than that.

Olivier Tilloy (osomon) wrote :

> 1) very difficult, or impossible to get the selection rectangle to
> show up at all. Press and hold does not seem to be triggering it.
> Often I just get a single word highlighted.

That’s oxide interferring with the custom selection mechanism (which is implemented as a user script that detects long presses). Until oxide gains the ability to handle selection properly, text selection should probably be disabled altogether to prevent such interferences.

Bill Filler (bfiller) wrote :

@olivier and chris
Please discuss with Chris and lets come up with a plan to address this somehow. This feature is pretty much unusable in it's current state. If the limitations are due to support that is needed in oxide, then we need to determine what the work items are and how much effort is involved so we can estimate a completion date for this feature.

Olivier Tilloy (osomon) wrote :

Marked the bug "in progress" for webbrowser-app. I submitted https://code.launchpad.net/~osomon/oxide/disable-touch-editing/+merge/235156 that disables touch editing in oxide, which should be a good enough stop-gap measure to make our current selection mechanism work reliably again. A better long term solution will be to implement a selection API in oxide, but that’s out of scope for RTM.

Changed in webbrowser-app:
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

The branch mentioned in the above comment was merged in lp:oxide, and in the 1.2 branch, so it should be released with oxide 1.2.2 (or 1.3 if that one comes first). Thus marking fix committed for webbrowser-app.

Changed in webbrowser-app:
status: In Progress → Fix Committed
Changed in oxide:
status: New → Fix Released
David Barth (dbarth) wrote :

The oxide part has been merged by now. It will be available in the next 1.2 release

Changed in oxide:
status: Fix Released → Fix Committed
Changed in oxide:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2014-09-23
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Fix Committed
Olivier Tilloy (osomon) wrote :

Marking "Fix Released" for webbrowser-app, as the original issue (the custom selection mechanism had not been ported to oxide) was fixed a while ago. The reason the bug was re-opened is because a long press in oxide would trigger an unwanted word selection, which would interfere with the custom selection mechanism, but that’s not a bug in webbrowser-app, and it’s been fixed in oxide.

Changed in oxide:
assignee: nobody → Olivier Tilloy (osomon)
Changed in webbrowser-app:
status: Fix Committed → Fix Released
Changed in webbrowser-app (Ubuntu):
status: Fix Committed → Fix Released
Changed in oxide:
milestone: none → branch-1.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers