No rendering happens on a dynamically instantiated webview if its 'visible' property was changed

Bug #1322622 reported by Olivier Tilloy on 2014-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson
1.0
High
Unassigned
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

Dynamically instantiating a webview in QML (using component.createObject(…)) without initially loading a URL, and ensuring it’s initially invisible then shown, and later loading a URL, results in no rendering. This can be worked around by then changing the 'visible' property to false and then true again.

I’m attaching a small example that reproduces the issue. Note that it replicates webbrowser-app’s behaviour to deal with tabs, so it’s a pretty critical issue.

Olivier Tilloy (osomon) wrote :
David Barth (dbarth) on 2014-05-26
tags: added: oxide
Chris Coulson (chrisccoulson) wrote :

I think I see what's going on here. The initial RenderWidgetHostImpl is created whilst the WebView is still hidden. When the visibility is changed, there is no RWHV yet (because nothing is loaded), and this contains plumbing to content::RenderWidgetHostImpl::WasShown().

Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: New → In Progress
Changed in oxide:
status: In Progress → Fix Released
Changed in oxide:
milestone: none → branch-1.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20140709-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20140709-0ubuntu1) utopic; urgency=low

  [ Michael Sheldon ]
  * Add support for downloads via content-hub on non-desktop devices
    when it's either not possible to render a file within the browser
    itself or when a download is explicitly requested via the Content-
    Disposition header. (LP: #1198347)

  [ Olivier Tilloy ]
  * Remove a workaround for bug #1322622 that has been properly fixed in
    oxide. (LP: #1322622)
  * Re-enable the favicon support now that oxide supports it. (LP:
    #1259216)
 -- Ubuntu daily release <email address hidden> Wed, 09 Jul 2014 16:37:04 +0000

Changed in webbrowser-app (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments