input fields get obscured by OSK

Bug #1301681 reported by Bill Filler on 2014-04-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson
1.2
High
Chris Coulson
webbrowser-app
Invalid
High
Olivier Tilloy

Bug Description

On some webpages if there is an input field near the bottom, when focusing in the field the OSK is displayed but it covers the input field. The input field should scroll into view when the OSK becomes visible.

A good site to test is Facebook. Press the "comment" button on a thread that has a few comments. Click in the comment field and the field becomes obscured when the OSK is displayed.

Bill Filler (bfiller) on 2014-04-03
Changed in webbrowser-app:
importance: Undecided → High
Bill Filler (bfiller) wrote :

We need to figure out a way to automatically scroll the input field into view so it's not obscured by the OSK. In qml apps we can use anchorToKeyboard property (see https://bugs.launchpad.net/ubuntu-keyboard/+bug/1321676). Need some equivalent way in browser or make it happen automatically.

tags: added: rtm14
Changed in webbrowser-app:
assignee: nobody → Olivier Tilloy (osomon)
Bill Filler (bfiller) on 2014-05-28
Changed in webbrowser-app:
status: New → Confirmed
Bill Filler (bfiller) on 2014-06-13
Changed in webbrowser-app:
milestone: none → beta-freeze
Changed in oxide:
milestone: none → branch-1.3
Chris Coulson (chrisccoulson) wrote :

Closing the webbrowser-app task, as we should do this entirely in Oxide

Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
milestone: branch-1.3 → branch-1.2
status: New → Triaged
Changed in webbrowser-app:
status: Confirmed → Invalid
tags: added: qa-daily-testing
Changed in oxide:
milestone: branch-1.2 → branch-1.3
David Barth (dbarth) on 2014-09-09
tags: added: touch-2014-09-25
Changed in oxide:
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

I've got a fix for this, but it interacts quite badly with the browser headerbar. It goes something like this:

1. The keyboard appears.
2. Once the view is resized, the focused editable node is scrolled automatically in to the centre of the view.
3. The browser hides the headerbar.
4. Because the view is resized again, we do another scroll to centre the focused editable node.
5. The browser shows the headerbar.

Repeat 2 - 5 ad infinitum.

Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
status: In Progress → Fix Released
Chris Coulson (chrisccoulson) wrote :

As the next upload to utopic will be from a 1.3 branch, marking this as wontfix for 1.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers