Crash on Intel GPU

Bug #1300284 reported by Pat McGowan on 2014-03-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Critical
Unassigned
oxide-qt (Ubuntu)
Critical
Unassigned

Bug Description

Crash when running webbrowser-app
Intel 2nd generation GPU

#0 0xac1644e4 in content::CommandBufferProxyImpl::GetRouteID (this=0x0)
    at ../../../../chromium/src/content/common/gpu/client/command_buffer_proxy_impl.cc:435
#1 0xac046605 in oxide::GpuUtils::CreateTextureHandle (this=0xb89d80c0)
    at ../../../../shared/browser/oxide_gpu_utils.cc:257
#2 0xac049125 in oxide::RenderWidgetHostView::RenderWidgetHostView (
    this=0xb8a0a670, host=0xb8a07d90)
    at ../../../../shared/browser/oxide_render_widget_host_view.cc:158
#3 0xac02a789 in oxide::qt::RenderWidgetHostView::RenderWidgetHostView (
    this=0xb8a0a670, render_widget_host=0xb8a07d90, delegate=0xb8a0a4f0)
    at ../../../../qt/core/browser/oxide_qt_render_widget_host_view.cc:550
#4 0xac031384 in oxide::qt::WebViewAdapterPrivate::CreateViewForWidget (
    this=0xb89d8f20, render_widget_host=0xb8a07d90)
    at ../../../../qt/core/glue/private/oxide_qt_web_view_adapter_p.cc:130
#5 0xac04d9d0 in oxide::WebContentsView::CreateViewForWidget (
    this=0xb8a08100, render_widget_host=0xb8a07d90)
    at ../../../../shared/browser/oxide_web_contents_view.cc:45
#6 0xae6f99d7 in content::WebContentsImpl::CreateRenderViewForRenderManager (
    this=0xb8a05d50, render_view_host=0xb8a07d90, opener_route_id=-2,
    frame_connector=0x0)
    at ../../../../chromium/src/content/browser/web_contents/web_contents_impl.cc:3485
#7 0xae518542 in content::RenderFrameHostManager::InitRenderView (
    this=0xb8a06368, render_view_host=0xb8a07d90, opener_route_id=-2)
    at ../../../../chromium/src/content/browser/frame_host/render_frame_host_manager.cc:1014
#8 0xae51bbfb in content::RenderFrameHostManager::Navigate (this=0xb8a06368,
    entry=...)
    at ../../../../chromium/src/content/browser/frame_host/render_frame_host_manager.cc:189
#9 0xae511aca in content::NavigatorImpl::NavigateToEntry (
    this=this@entry=0xb8a05b88, render_frame_host=render_frame_host@entry=
    0xb8a09590, entry=...,
    reload_type=reload_type@entry=content::NavigationController::NO_RELOAD)
    at ../../../../chromium/src/content/browser/frame_host/navigator_impl.cc:320
#10 0xae5124c3 in content::NavigatorImpl::NavigateToPendingEntry (
    this=this@entry=0xb8a05b88, render_frame_host=0xb8a09590,

Changed in oxide:
importance: Undecided → Critical
Changed in oxide-qt (Ubuntu):
importance: Undecided → Critical
Changed in oxide:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oxide-qt - 1.0.0~bzr452-0ubuntu1

---------------
oxide-qt (1.0.0~bzr452-0ubuntu1) trusty; urgency=medium

  * Update to r452
    - Add WebView.newViewRequested API (LP: #1240749)
    - Add WebView.navigationRequested API (LP: #1259219)
    - Turn off WebCore debug symbols on native ARM builds, because we keep
      hitting linker OOM conditions. These are also omitted from our
      Chromium builds
    - Don't ignore WebContext.cachePath (LP: #1298264)
    - Add WebContext.sessionCookieMode API
 -- Chris Coulson <email address hidden> Tue, 01 Apr 2014 13:13:51 +0100

Changed in oxide-qt (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers