[needs-packaging] Package spice-xpi

Bug #943510 reported by Philipp Gassmann
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
oVirt
New
Undecided
Unassigned
spice-xpi (Debian)
Fix Released
Unknown
spice-xpi (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Spice-XPI plugin for mozilla plugin compatible browsers. This is needed for launching the spice client from the RHEV-M / oVirt user portal. (Remote Desktop)

The package is in the Fedora and RedHat repos.

Jason Brooks already packaged it in a ppa for oneiric, the package is installable on precise.
http://blog.jebpages.com/archives/spice-spice-baby/
https://launchpad.net/~jasonbrooks/+archive/ppa/

Canonical is strategic supporter of the oVirt project. So it could be bad for the reputation if you can't even access it with ubuntu. -> Somebody should care. ;-)
http://www.ovirt.org/about/sponsors-and-supporters/

SPICE-Protocol: http://www.spice-space.org/home.html
The spice-client is in the repos

Revision history for this message
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Mark Baker (markashtonb) wrote :

Can you please submit the plugin to developer.ubuntu.com and we will take it from there.

Thanks

Revision history for this message
Philipp Gassmann (phiphi.g) wrote :

Sorry, I'm just a user. I'm not the developer or in some other way related to this package. Or how should I submit it to developer.ubuntu.com. I'm not familiar with it.

I think there should be some effort/initiative from Canonical to get this done right and supported.

Changed in debian:
status: Unknown → New
Revision history for this message
Philipp Gassmann (phiphi.g) wrote :

Why is this bug assigned to nobody?

Repeating:
Canonical is strategic supporter of the oVirt project. So it could be bad for the reputation if you can't even access it with ubuntu. -> Somebody should care. But obviously that's not the case. :-(
http://www.ovirt.org/about/sponsors-and-supporters/

Revision history for this message
Fantu (fantonifabio) wrote :

I also need spice-xpi package, are there any news about it?

Revision history for this message
Jeremy Bicha (jbicha) wrote :

In general, Ubuntu doesn't include Firefox addons in the archives. Why can't this be distributed through addons.mozilla.org?

Changed in ubuntu:
status: Confirmed → Incomplete
Revision history for this message
Jason Brooks (jasonbrooks) wrote :

I'll look into it -- that'd be preferable for sure.

Revision history for this message
Jason Brooks (jasonbrooks) wrote :

I'm not sure why, but spice-xpi built on one distro doesn't work on another. It's distributed as a package on Fedora, and as far as I can tell, this is the only xpi offered in the Fedora repos.

Changed in debian:
status: New → Fix Committed
Revision history for this message
Andres Mujica (andres.mujica) wrote :

Hi, anyone knows where can I find the deb referred in this page so I can test it?

http://ftp-master.debian.org/new/spice-xpi_2.8-2.html

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in debian:
status: Fix Committed → Fix Released
Revision history for this message
Logan Rosen (logan) wrote :

This is now in Trusty and Utopic.

affects: ubuntu → spice-xpi (Ubuntu)
affects: debian → spice-xpi (Debian)
Changed in spice-xpi (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.