[FFe] Low visibility impaired users can't easily disable overlay scrollbars

Bug #934123 reported by Christian Giordano on 2012-02-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Christian Giordano
Unity Greeter
Invalid
Undecided
Unassigned
overlay-scrollbar
Undecided
Andrea Cimitan
gnome-control-center (Ubuntu)
Low
Unassigned
gsettings-desktop-schemas (Ubuntu)
Low
Unassigned
overlay-scrollbar (Ubuntu)
Undecided
Andrea Cimitan
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Option 1:
The overlay scrollbars should be tight to the theme, so that a theme designed for users with visual impairment can easily opt out.
Best thing might be to have an opt-in policy where Ambiance and Radiance will explicitly say they want to use the overlay scrollbars.

Option 2:
Add an option in System Settings>Universal Access>Seeing to disable them.

Solution for 12.04:
Set overlay-scrollbar visibility based on theme selection in:
System Settings > Appearance > Look
If a high contrast theme is chosen, the overlay-scrollbar visibility will be set to 0, otherwise it will be set to 1.

Christian Giordano (nuthinking) wrote :

Have to check if Option 2 can be easily be modified when an accessibility profile is selected after installation.

Changed in ayatana-design:
importance: Undecided → High
Andrea Cimitan (cimi) on 2012-02-17
summary: - Low visibility impaired users can't easily disabled overlay scrollbars
+ [FFe] Low visibility impaired users can't easily disabled overlay
+ scrollbars
John Lea (johnlea) on 2012-02-17
Changed in ayatana-design:
assignee: nobody → Christian Giordano (nuthinking)
status: New → Triaged
tags: added: udp
Changed in ayatana-scrollbar:
status: New → Confirmed
description: updated
description: updated
summary: - [FFe] Low visibility impaired users can't easily disabled overlay
+ [FFe] Low visibility impaired users can't easily disable overlay
scrollbars
description: updated
description: updated
David Barth (dbarth) on 2012-03-07
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in ayatana-scrollbar:
assignee: nobody → Andrea Cimitan (cimi)
Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Andrea Cimitan (cimi) wrote :

patch for gsettings-desktop-schemas

Andrea Cimitan (cimi) wrote :

Patch for gnome-control-center

Andrea Cimitan (cimi) wrote :

Linked branch

Changed in gsettings-desktop-schemas (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Committed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → In Progress
Changed in gsettings-desktop-schemas (Ubuntu):
importance: Wishlist → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-desktop-schemas - 3.3.90-0ubuntu2

---------------
gsettings-desktop-schemas (3.3.90-0ubuntu2) precise; urgency=low

  * debian/patches/ubuntu_overlay-scrollbars.patch:
    - define "org.gnome.desktop.interface ubuntu-overlay-scrollbars" to
      let disable the overlay scrollbars, thanks Andrea Cimitan
      (lp: #934123)
  * debian/patches/ubuntu_lock-on-suspend.patch:
    - use ubuntu- prefix to avoid downstream,upstream confusion
    - the key is "org.gnome.desktop.screensaver ubuntu-lock-on-suspend"

  [ Marc Deslauriers ]
  * debian/patches/ubuntu_lock-on-suspend.patch: Add a new preference to lock
    the screen when the system suspends. (LP: #938076)
 -- Sebastien Bacher <email address hidden> Fri, 09 Mar 2012 15:42:58 +0100

Changed in gsettings-desktop-schemas (Ubuntu):
status: Fix Committed → Fix Released
Andrea Cimitan (cimi) on 2012-03-09
Changed in ayatana-scrollbar:
status: Confirmed → In Progress
Changed in overlay-scrollbar (Ubuntu):
status: New → In Progress

The attachment "add_ubuntu-overlay-scrollbars.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Andrea Cimitan (cimi) on 2012-03-09
tags: added: ubuntu-release
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.3.91-0ubuntu3

---------------
gnome-control-center (1:3.3.91-0ubuntu3) precise; urgency=low

  * debian/patches/04_new_appearance_settings.patch,
    debian/patches/63_normal_scrollbar_in_a11y.patch:
    - disable overlay scrollbars with a11y themes by setting the gsettings
      to false, thanks Andrea Cimitan (lp: #934123)

  [ Marc Deslauriers ]
  * debian/patches/99_add_lock-on-suspend.patch: Add a new preference to
    lock the screen when the system suspends. (LP: #938076)
  * debian/control.in: bump gsettings-desktop-schemas Depends
 -- Sebastien Bacher <email address hidden> Fri, 09 Mar 2012 19:41:38 +0100

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Andrea Cimitan (cimi) wrote :

A remaining bit would be setting the same gsetting in gdm, when you enable a11y from there

Changed in ayatana-scrollbar:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.16-0ubuntu1

---------------
overlay-scrollbar (0.2.16-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Always use bg[SELECTED] for the bar in Gtk+ 2.
    - nautilus crashed with SIGSEGV in show_thumb_cb (LP: #907111)
    - Low visibility impaired users can't easily disable overlay
      scrollbar (LP: #934123)
    - scroll *on* thumb not functional (LP: #951121)
 -- Ken VanDine <email address hidden> Wed, 21 Mar 2012 11:41:13 -0400

Changed in overlay-scrollbar (Ubuntu):
status: In Progress → Fix Released
affects: lightdm → unity-greeter
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Robert Ancell (robert-ancell) wrote :

Closing unity-greeter task as I can't see any scrollbars in the UI.

Changed in unity-greeter:
status: New → Invalid
Changed in unity-greeter (Ubuntu):
status: New → Incomplete
status: Incomplete → Invalid
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers