unable to edit attributes in Inkscape XML Editor (Ubuntu overlay-scrollbar issues)

Bug #884368 reported by saurabh on 2011-10-31
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith
overlay-scrollbar
Undecided
Unassigned
inkscape (Ubuntu)
Low
Unassigned
overlay-scrollbar (Ubuntu)
Medium
Unassigned

Bug Description

If I select an attribute in the XML editor, the edit box below shows the attribute name, not its value. If I change the attribute and hit 'set', a new attribute is created with this name. There is no apparent way to change an existing value. I'm using 0.48.2 from Ubuntu Oneiric.

From duplicate Bug #854545 (which had been reported earlier to 'overlay-scrollbar' than this one to 'Inkscape' and has a more precise description of the problem IMHO):
> Ideally the overlay scrollbar support could have a minimum-height sanity check.

The issue affects various widgets and dialogs in Inkscape which do not use hard-coded minimal px dimension. IMHO it would be better to address this upstream in Ubuntu's overlay code, than patching Inkscape's code in various places to insert (hard-coded) minimal dimensions (which might not adjust to individual theme settings anymore)

Follow-up reports about individual widgets/dialogs:
Bug #902054 “Some layers should be visible by default in Layers dialog”
Bug #908392 “Initial size of palette dialog on Ubuntu too small Ubuntu”
Bug #909958 “Path Effect List is hidden”
Bug #910463 “Preferences > 'System Info' window is very small”
Bug #910467 “Input Devices > Hardware > Tree of devices is hidden”
Bug #910479 “Glyphs Font styles are hidden”
Bug #911079 “Error messages from Extensions hidden”
Bug #946631 “Overlay scrollbars causing input boxes to be small”
Bug #1004856 “Font Glyphs doesn't work.”
Bug #1081001 “Initial height of symbol icon view too small (trunk, Ubuntu)”

Related branches

su_v (suv-lp) wrote :

Not reproduced with any version of Inkscape (tested on Mac OS X 10.5.8 (i386)).

Please attach a sample SVG file and illustrate with a screenshot which attribute value of which object you are trying to edit.
For basic usage, see also:
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/XML-Basic.html>

tags: added: xmleditor
Changed in inkscape:
status: New → Incomplete
saurabh (faplap) wrote :
saurabh (faplap) wrote :
su_v (suv-lp) wrote :

Compare your screenshot with the one from the manual [1]: does the value entry get visibly if you drag the resize handle between the list of attributes (upper right pane) and the attribute/value part below (lower right pane)?
It also seems that all scrollbars are broken or hidden/minimized in the screenshot… -> possibly this is an issue specific to the Ubuntu desktop/default theme?

Attaching a screenshot for comparison as seen with default Clearlooks theme (Inkscape 0.48.2).

[1] <http://tavmjong.free.fr/INKSCAPE/MANUAL/images/XMLEDIT/ellipse2_xml.png>

Changed in inkscape:
status: Incomplete → New
tags: added: ui
saurabh (faplap) wrote :

Aha, yes, you are right, this seems to be an ubuntu bug and not an inkscape one.

ScislaC (scislac) on 2011-11-02
Changed in inkscape:
status: New → Confirmed
status: Confirmed → New
Changed in ayatana-scrollbar:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
su_v (suv-lp) wrote :

Related issue:
Bug #902054 in inkscape (Ubuntu): “Some layers should be visible by default in Layers dialog”
<https://bugs.launchpad.net/ubuntu/+source/inkscape/+bug/902054>

John Smith (john-smithi) wrote :

Patch to make the attribute value visible when using Ubuntu style ayatana-scrollbars.
Other platforms should be unaffected.
Tested on Ubuntu 11.10 and Windows 7.

John Smith (john-smithi) wrote :

Patch to make the attribute value visible when using Ubuntu style ayatana-scrollbars.
Other platforms should be unaffected.
Tested on Ubuntu 11.10 and Windows 7.

tangoku (tangoku7) wrote :

Morning, which folder should I use on Ubuntu 11.10 to install it?

The attachment "884368.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Related issue:
Bug #908392 “Initial size of palette dialog on Ubuntu too small Ubuntu”
<https://bugs.launchpad.net/inkscape/+bug/908392>

Also affects:
- 'Description', 'Contributors' entry fields in 'File > Document Metadata…'
- Tree of devices in 'File > Input Devices > Hardware'
- List of font styles in 'Text > Glyphs…'
- 'Effect list' in 'Path > Path Effect Editor…'
- …

su_v (suv-lp) wrote :

Also affects (cont.):
- 'System Info' in 'File > Inkscape Preferences > Misc'

su_v (suv-lp) wrote :

Related:
Bug #909958 in Inkscape: “Path Effect List is hidden”

John Smith (john-smithi) on 2011-12-31
Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
John Smith (john-smithi) wrote :

Documented and submitted patches for the related issues:

* Bug #909958 “Path Effect List is hidden”
* Bug #910467 "Input Devices > Hardware > Tree of devices is hidden"
* Bug #910463 "Preferences > 'System Info' window is very small"
* Bug #910479 "Glyphs Font styles are hidden"

jazzynico (jazzynico) on 2012-01-02
Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.48.3
status: New → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the branch (revision 9846) and in the trunk (revision 10819).

Changed in inkscape:
status: In Progress → Fix Committed

Similar issue in ayatana-scrollbar:

Bug #910334 <Overlay scrollbars causing problem in Font Manager>

Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in inkscape (Ubuntu):
importance: Undecided → Low
summary: - unable to edit attributes in XML Editor
+ unable to edit attributes in Inkscape XML Editor
su_v (suv-lp) wrote :

Related in Inkscape:
Bug #911079 “Error messages from Extensions hidden”

su_v (suv-lp) on 2012-01-03
description: updated
summary: - unable to edit attributes in Inkscape XML Editor
+ unable to edit attributes in Inkscape XML Editor (Ubuntu overlay-
+ scrollbar issues)
su_v (suv-lp) wrote :

Also affects:
- List of filter primitives in 'Filters > Filter Editor…'

Screenshot:
<http://imgh.us/ink.png>

Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.3-0ubuntu1

---------------
inkscape (0.48.3-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #933188). Fixes several Ubuntu bugs:
    - inkscape fails to build with glib 2.31 (LP: #898538)
    - ctrl c ctrl v of text in edit mode crashes inkscape (LP: #496793)
    - Completely replace lcms1 by lcms2 in Ubuntu (LP: #885324)
    - parameters ending with '\' causes python to bomb (LP: #168417)
    - Extensions with <check> tags fail to load (LP: #668895)
    - ESC doesn't cancel move when using the Node Tool (LP: #788560)
    - unable to edit attributes in Inkscape XML Editor (LP: #884368)
    - Some layers should be visible by default in Layers dialog (LP: #902054)
    - Path Effect List is hidden (LP: #909958)
    - Input Devices > Hardware > Tree of devices is hidden (LP: #910467)
    - Glyphs Font styles are hidden (LP: #911079)
    - Error messages from Extensions hidden (LP: #911079)
    - Messages dialog doesn't work (LP: #911123)
  * Drop 02-add-shebangs-and-fix-permissions.dpatch: Applied upstream.
  * Drop build-dependency on specific libwpd/libwpg version.
 -- Alex Valavanis <email address hidden> Thu, 16 Feb 2012 14:33:40 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
su_v (suv-lp) on 2012-03-04
description: updated
su_v (suv-lp) on 2012-10-10
description: updated
su_v (suv-lp) on 2012-11-20
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions