[FFE] Switch the ayatana-scrollbar on by default

Bug #766660 reported by David Barth on 2011-04-19
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
overlay-scrollbar
Medium
Unassigned
overlay-scrollbar (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
Undecided
Unassigned
stracciatella-session (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt
Oneiric
Medium
Martin Pitt

Bug Description

Given the results of the last test campaign and the latest bug fixes, we would like to have the new scrollbar be switched on by default.

SRU INFORMATION:
----------------
The SRU part is that the stracciatella session (which should be as close to upstream GNOME as possible) uses the overlay scrollbars, but shouldn't. It also currently starts unity by default, but should run gnome-panel and metacity. This is a regression to previous releases. In Natty the gnome-session system changed quite a bit, but nobody tested the stracciatella-session so far.

David Barth (dbarth) wrote :

The reason for the change is that the fact that only whitelist'ed applications are using it by default, means that we're creating an artificial difference between applications and that creates confusion for users.

The change keeps the blacklist unchanged, and also keeps the ability to disable the new scrollbar on a per application basis.

Changed in ayatana-scrollbar:
importance: Undecided → Medium
status: New → Confirmed
Andrea Cimitan (cimi) wrote :

the series of "666" in the bugreport are a bit scary... :D

Martin Pitt (pitti) wrote :

That's what we should have done from day one of landing them, to actually get some testing on those... Now that we don't have much error margin left this makes me quite nervous to be honest.

For Natty the main result will only be that it will look differently inconsistent (Firefox, Mumble and other Qt apps), and I suppose merely removing the whitelist doesn't fix the issue that the scrollbar won't be used for all widgets yet? (Cf. the mixed scrollbars you get in xchat-gnome, as per Sebastien's report).

Can you please describe how many applications were tested, and how many problems were found with that? Are the results available publicly somewhere? I think we need some real data to look at for risk assessment at this late time.

Thanks!

Changed in overlay-scrollbar (Ubuntu):
status: New → Incomplete
Andrea Cimitan (cimi) wrote :

The QA team is doing tests for all apps, lamalex and jibel told me they are fine (no crashes) with all the apps in the CD. I dunno if they have finished their tests or if they're still in process...

Martin Pitt (pitti) wrote :

As this is our very last shot for natty, and we can't possibly have tested it with a large number of GTK apps out there in different scenarios, my personal stance for this is to keep what we have right now for natty. In retrospect we should never have had a whitelist to begin with, but too late now to correct that error.

Changed in overlay-scrollbar (Ubuntu Natty):
status: Incomplete → Won't Fix
Martin Pitt (pitti) wrote :

For oneiric we should enable it very early on and drop the whitelist, to get maximum testing and feedback.

Changed in overlay-scrollbar (Ubuntu Oneiric):
status: New → Confirmed
David Barth (dbarth) wrote :

For the record, an extensive list of applications have been re-tested prior to proposing that exception.

Application
alacarte
apport-gtk
anki
banshee
baobab
brasero
nautilus
ccsm
chromium-browser
computer-janitor-gtk
deja-dup
devhelp
d-feet
eclipse
empathy
eog
evince
evolution
exaile
file-roller
firefox
freemind
fslint-gui
gcalctool
gconf-editor
gdebi-gtk
gedit
geeqie-standard
gimp-2.6
glade-3
gnome-appearance-properties
gnome-dictionary
gnome-nettool
gnome-screensaver-preferences
gnome-search-tool
gnome-system-log
gnome-system-monitor
gnome-terminal
gnome-control-center
gpa
grisbi
gthumb
gtg
gtimelog
gtkperf
gucharmap
gvim
gwibber
homebank
inkscape
jockey-gtk
gnome-keybinding-properties
gnome-language-selector
libreoffice
liferea
lshw-gtk
midori
monodevelop
mumble
nautilus
nm-connection-editor
palimpsest
pgadmin3
pitivi
poeditor
rhythmbox
seahorse
gnome-session-properties
scite
shares-admin
shotwell
shutter
software-properties-gtk
stardict
synaptic
thunderbird
tomboy
totem
transmission-gtk
yelp
software-center
ubiquity
ubuntuone-control-panel-gtk
update-manager
usb-creator-gtk
users-admin
xchat
xchat-gnome
xpdf
gnome file dialogs (open/save)

Those tests have been performed via a joint effort between the QA Team, the DX Team's QA engineer and community testers.

In that list of applications, those have exposed serious and have been blacklisted:
"apport-gtk"
"Banshee",
"deja-dup",
"eclipse",
"inkscape",
"liferea",
"lshw-gtk",
"meld",
"synaptic",
"update-manager",
"vinagre"

In particular, to preserve the ability to update or send bug reports with apport, those critical applications have been blacklisted even if they were not exposing problems: apport-gtk, synaptic, update-manager

Some other applications were not strictly compatible, after this last round of test, but they have not been blacklisted, because the main part of the UI was consistently using the feature.

Martin Pitt (pitti) on 2011-04-21
Changed in overlay-scrollbar (Ubuntu):
status: Incomplete → Confirmed
Ken VanDine (ken-vandine) wrote :

quoting the response via email from sabdfl:

Folks, thanks for accommodating the change. The original plan was to
whitelist for only a week for performance and stability testing, then go
fully-enabled. Various requests to drop the whitelist and full-enable
were misplaced, but we have every reason to be confident in the code
itself. We retain the blacklist for occasions where bad interactions are
discovered.

I'd prefer the whitelist dropped pre-release but am happy for it to be
0-day SRU'd if the release team prefers that too.

Mark

Martin Pitt (pitti) wrote :

For the record, I think an SRU would be even less appropriate, as it changes the UI quite dramatically. So if that was a definitive override, please confirm the task and let's rather get this into natty proper.

Changed in overlay-scrollbar (Ubuntu Natty):
importance: Undecided → Medium
milestone: none → ubuntu-11.04
status: Won't Fix → New
importance: Medium → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.1.9-0ubuntu1

---------------
overlay-scrollbar (0.1.9-0ubuntu1) natty; urgency=low

  * New upstream release.
    - stop the animation *after* calling g_source_remove
    - Call the toplevel_leave_notify_event in the filter func
    - Use a blacklist instead of a whitelist (LP: #766660)
    - Add more apps to the blacklist: apport-gtk, Banshee, deja-dup eclipse,
      inkscape, liferea, lshw-gtk, meld, synaptic, and update-manager
  * os/os-utils.c
    - Always return true from the whitelist check (LP: #766660)
  * debian/overlay-scrollbar.install
    - Don't install the Xsession script
  * debian/ayatana-scrollbar.py
    - Don't add ayatana-scrollbar tag
 -- Ken VanDine <email address hidden> Thu, 21 Apr 2011 13:33:24 -0400

Changed in overlay-scrollbar (Ubuntu Natty):
status: Confirmed → Fix Released
Spike Burch (spikeb) wrote :

Why is a not even half implemented new idea on by default?

Andrea Cimitan (cimi) on 2011-04-23
Changed in ayatana-scrollbar:
status: Confirmed → Fix Released
Kate Stewart (kate.stewart) wrote :

Having this feature on by default in Natty for the Classic Session and Classic Session (No Effects) doesn't make sense to me. I think we need to look at ensuring principle of least surprises in Classic at this point, and this violates principle of least surprises.

Andrea Cimitan (cimi) wrote :

a export LIBOVERLAY_SCROLLBAR=0 to the classic sessions will disable the feature

Martin Pitt (pitti) on 2011-04-26
Changed in overlay-scrollbar (Ubuntu Oneiric):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

I don't know if UX/DX teams actually meant the overlay scrollbars to be specific to unity or applicable to everything. From my POV the classic session is not meant at all to be a "vanilla GNOME" kind of thing. It still has indicators, compiz, notify-osd, and all other Ubuntuisms, and as overlay-scrollbar does not make any attempt at all to be session specific it seems straightforward for it to apply to classic as well.

However, stracciatella-session should of course disable the overlay scrollbars. I added a task for this. This is a small and straightforward change, and thus SRUable for natty.

Changed in stracciatella-session (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Changed in stracciatella-session (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
Changed in stracciatella-session (Ubuntu Natty):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Fix uploaded to natty-proposed queue.

description: updated
Changed in stracciatella-session (Ubuntu Natty):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

We can copy natty-proposed to oneiric once it is accepted.

Changed in stracciatella-session (Ubuntu Oneiric):
status: In Progress → Fix Committed

Accepted stracciatella-session into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

SRU verification for Natty:
I have reproduced the problem with stracciatella-session 0.0.3 in natty (LIBOVERLAY_SCROLLBAR not set and overlay scrollbar enabled) and have verified that the version of stracciatella-session 0.0.4 in -proposed fixes the issue (LIBOVERLAY_SCROLLBAR=0 and no overlay scrollbar).

Marking as verification-done

tags: added: verification-done
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package stracciatella-session - 0.0.4

---------------
stracciatella-session (0.0.4) natty-proposed; urgency=low

  * gnome-stracciatella.desktop.in:
    - Run 2d-session to use metacity instead of compiz and unity.
    - Disable COMPIZ_CONFIG_PROFILE to avoid running unity in compiz.
    - Disable overlay scrollbars. (LP: #766660)
 -- Martin Pitt <email address hidden> Tue, 26 Apr 2011 18:15:05 +0200

Changed in stracciatella-session (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in stracciatella-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers