OurDelta - Builds for MySQL,MariaDB

mirror functionality not there yet

Reported by Alex Howells on 2008-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OurDelta
Medium
Arjen Lentz

Bug Description

It'd be nice if you guys had a mirror infrastructure setup, such that folks can rsync a copy of all your packages and either function as a public mirror (preferred) or an internal-only mirror. :-)

There's a strong chance we'd be interested in mirroring your MySQL builds in London.

    http://mirror.bytemark.co.uk
    ftp://mirror.bytemark.co.uk
    rsync://mirror.bytemark.co.uk

Give me a shout when things get a bit further along, it looks interesting.

I got asked to document "direct download" counting (for statistics) by Arjen. Essentially you'd want a bouncer like http://wiki.osuosl.org/display/Bouncer ...... am not sure how you'd get decent tracking of folks who mirror you (repositories) since I'm not 100% sure that apt-get supports redirects. Will investigate.

If it does then you need something like:

    deb http://mirror.ourdelta.org/debian

Then you could basically use Apache 301/302 redirects to say files for Debian Etch / Debian Lenny have temporarily/permanently moved to, perhaps, http://mirror.bytemark.co.uk/ourdelta-mysql/debian?

If you want to base off Enterprise source (also discussed with Arjen) then Proven Scaling have an excellent mirror hiding over in the following corner of the Internet --

    http://mirror.provenscaling.com

Good luck, and may the force be with you ;)

Alex Howells (howells) on 2008-10-17
description: updated
Alex Howells (howells) on 2008-10-17
description: updated
Changed in ourdelta:
assignee: nobody → iseppi
importance: Undecided → Medium
status: New → Confirmed
Changed in ourdelta:
status: Confirmed → In Progress
Arjen Lentz (arjen-lentz) wrote :

Please contact i n f o (at) o u r d e l t a (dot) o r g if you want to become a mirror.
See also http://ourdelta.org/do-you-want-to-be-an-ourdelta-mirror

Changed in ourdelta:
assignee: James Iseppi (iseppi) → Arjen Lentz (arjen-lentz)
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers