oslo.utils 1.4.1 is being used in stable/kilo

Bug #1496678 reported by Tony Breeds on 2015-09-17
This bug report is a duplicate of:  Bug #1496650: requirement conflict on Babel. Edit Remove
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
oslo.utils
Undecided
Unassigned

Bug Description

The title of this bug is terrible sorry.

oslo.utils 1.4.1 was release today to unlock several stable/juno issues. Sadly this version is also valid in stable/kilo
https://github.com/openstack/requirements/blob/stable/kilo/global-requirements.txt#L73

I apologise for not seeing that.

This has resulted in:

2015-09-17 01:21:39.403 | pkg_resources.ContextualVersionConflict: (Babel 2.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('Babel<=1.3,>=1.3'), set(['oslo.utils']))

logstash: http://logstash.openstack.org/#eyJzZWFyY2giOiJtZXNzYWdlOlwicGtnX3Jlc291cmNlcy5Db250ZXh0dWFsVmVyc2lvbkNvbmZsaWN0OiAoQmFiZWwgMi4wICgvdXNyL2xvY2FsL2xpYi9weXRob24yLjcvZGlzdC1wYWNrYWdlcyksIFJlcXVpcmVtZW50LnBhcnNlKCdCYWJlbDw9MS4zLD49MS4zJyksIHNldChbJ29zbG8udXRpbHMnXSkpXCIiLCJmaWVsZHMiOltdLCJvZmZzZXQiOjAsInRpbWVmcmFtZSI6IjQzMjAwIiwiZ3JhcGhtb2RlIjoiY291bnQiLCJ0aW1lIjp7InVzZXJfaW50ZXJ2YWwiOjB9LCJzdGFtcCI6MTQ0MjQ2MzY2ODM4MX0=

Tony Breeds (o-tony) wrote :

https://review.openstack.org/#/c/224429/ is the kilo g-r change to ban 1.4.1

That may not be the correct solution but it's the best I can think of right now.

Tony Breeds (o-tony) wrote :

Proposed revert of the G-r sync here:
https://review.openstack.org/#/c/224472/

Once that merges tag that as 1.4.2 and then get gate should be fixed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers