DeprecationWarning: Please provide `is_available()` function in your custom Eventlet hub

Bug #1849270 reported by do3meli on 2019-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.service
Undecided
Unassigned

Bug Description

Running Glance as WSGI Service creates the following DeprecationWarning:

2019-10-22T03:06:40.246+02:00 xxx glance: [Tue Oct 22 03:06:39.287498 2019] [wsgi:error] [pid 3690:tid 139834924054272] [remote 10.1.16.13:52622] /usr/lib/python3/dist-packages/eventlet/greenthread.py:31: DeprecationWarning: Please provide `is_available()` function in your custom Eventlet hub <module 'oslo_service' from '/usr/lib/python3/dist-packages/oslo_service/__init__.py'>.
2019-10-22T03:06:40.246+02:00 xxx glance: [Tue Oct 22 03:06:39.287534 2019] [wsgi:error] [pid 3690:tid 139834924054272] [remote 10.1.16.13:52622] It must return bool: whether hub supports current platform. See eventlet/hubs/{epoll,kqueue} for example.
2019-10-22T03:06:40.246+02:00 xxx glance: [Tue Oct 22 03:06:39.287541 2019] [wsgi:error] [pid 3690:tid 139834924054272] [remote 10.1.16.13:52622]
2019-10-22T03:06:40.246+02:00 xxx glance: [Tue Oct 22 03:06:39.287546 2019] [wsgi:error] [pid 3690:tid 139834924054272] [remote 10.1.16.13:52622] hub = hubs.get_hub()

OS: Ubuntu 18
Package Archive: Ubuntu Cloud Archive
Release: Stein

do3meli (d-info-e) on 2019-10-22
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers