Avoid docutils 0.15

Bug #1837741 reported by dharmendra on 2019-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.policy
High
Unassigned
tacker
Undecided
Unassigned

Bug Description

pep8 runtests: commands[1] | doc8 -e .rst doc/source/ CONTRIBUTING.rst HACKING.rst README.rst TESTING.rst
Traceback (most recent call last):
  File ".tox/pep8/bin/doc8", line 6, in <module>
    from doc8.main import main
  File "/home/ubuntu/codeup/tacker/.tox/pep8/local/lib/python2.7/site-packages/doc8/main.py", line 48, in <module>
    from doc8 import checks
  File "/home/ubuntu/codeup/tacker/.tox/pep8/local/lib/python2.7/site-packages/doc8/checks.py", line 21, in <module>
    from docutils import nodes as docutils_nodes
  File "/home/ubuntu/codeup/tacker/.tox/pep8/local/lib/python2.7/site-packages/docutils/nodes.py", line 32, in <module>
    import docutils.utils
  File "/home/ubuntu/codeup/tacker/.tox/pep8/local/lib/python2.7/site-packages/docutils/utils/__init__.py", line 20, in <module>
    from docutils import nodes
ImportError: cannot import name nodes
ERROR: InvocationError: '/home/ubuntu/codeup/tacker/.tox/pep8/bin/doc8 -e .rst doc/source/ CONTRIBUTING.rst HACKING.rst README.rst TESTING.rst'
___________________________________________________________________ summary ___________________________________________________________________
ERROR: pep8: commands failed

Ben Nemec (bnemec) wrote :

This is also blocking the oslo.policy gate.

Changed in tacker:
status: New → Confirmed
status: Confirmed → New
Changed in oslo.policy:
status: New → Triaged
importance: Undecided → High
Ben Nemec (bnemec) wrote :

Looks like g-r has moved past the broken version, so this is working again.

Changed in oslo.policy:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers