No log when SSL problem

Bug #1801011 reported by Thomas Goirand on 2018-11-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
oslo.messaging
Undecided
Ken Giusti

Bug Description

It took me a long long time to figure out that my SSL setup was wrong when trying to connect Heat to rabbitmq over SSL. Unfortunately, Oslo (or heat itself) never warn me that something was wrong, I just got nothing working, and no log at all.

I'm sure I wouldn't be the only one happy about having this type of problems being yelled out loud in the logs. Right now, it does work if I turn off SSL, though I'm still not sure what's wrong in my setup, and I'm given no clue if the issue is on rabbitmq-server or on the client side (ie: heat, in my current case).

Just a wishlist...

Ken Giusti (kgiusti) wrote :
Changed in oslo.messaging:
assignee: nobody → Ken Giusti (kgiusti)
Ken Giusti (kgiusti) on 2018-11-05
Changed in oslo.messaging:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/615649

Changed in oslo.messaging:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/615649
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=fb3ab00d1d8778ff4460ec475124585f4febe042
Submitter: Zuul
Branch: master

commit fb3ab00d1d8778ff4460ec475124585f4febe042
Author: Kenneth Giusti <email address hidden>
Date: Mon Nov 5 16:02:06 2018 -0500

    Use ensure_connection to prevent loss of connection error logs

    Change-Id: I31e3f83304c0780cfd380aa63ec2962c3c28ec78
    Closes-Bug: #1801011

Changed in oslo.messaging:
status: In Progress → Fix Released

This issue was fixed in the openstack/oslo.messaging 9.2.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers