Remove deprecated Pika driver

Bug #1744741 reported by Ken Giusti on 2018-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.messaging
Medium
Ken Giusti

Bug Description

Pika driver has been deprecated since pike:

https://git.openstack.org/cgit/openstack/oslo.messaging/tree/oslo_messaging/_drivers/impl_pika.py#n139

We can now remove it in Rocky.

Ken Giusti (kgiusti) on 2018-01-22
Changed in oslo.messaging:
importance: Undecided → Medium
assignee: nobody → Ken Giusti (kgiusti)

Fix proposed to branch: master
Review: https://review.openstack.org/536960

Changed in oslo.messaging:
status: New → In Progress

Reviewed: https://review.openstack.org/536960
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=222a939361579f73fb33a51580fd2ed4d28decb3
Submitter: Zuul
Branch: master

commit 222a939361579f73fb33a51580fd2ed4d28decb3
Author: Kenneth Giusti <email address hidden>
Date: Tue Jan 23 15:23:15 2018 -0500

    Remove the deprecated Pika driver

    It is recommended that all users of the Pika driver transition to
    using the Rabbit driver instead. Typically this is done by changing
    the prefix of the transport_url configuration option from "pika://..."
    to "rabbit://...". There are no changes required to the RabbitMQ
    server configuration.

    Change-Id: I52ea5ccb7e7c247abd95e2d8d50dac4c4ad11246
    Closes-Bug: #1744741

Changed in oslo.messaging:
status: In Progress → Fix Released

This issue was fixed in the openstack/oslo.messaging 6.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers