Prevent restart of MessageHandlingServer

Bug #1712397 reported by Ken Giusti on 2017-08-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.messaging
Medium
Ken Giusti

Bug Description

See:

http://git.openstack.org/cgit/openstack/oslo.messaging/tree/oslo_messaging/server.py#n398

Attempting to re-start a server should become a no-op (just issue a warning and return).

Changed in oslo.messaging:
assignee: nobody → sunguangning (sunguangning)
status: New → Incomplete
Ken Giusti (kgiusti) on 2018-07-03
Changed in oslo.messaging:
assignee: sunguangning (sunguangning) → Ken Giusti (kgiusti)
status: Incomplete → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/579935

Changed in oslo.messaging:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/579935
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=a84c946767af552deda29cba118f532348444ff8
Submitter: Zuul
Branch: master

commit a84c946767af552deda29cba118f532348444ff8
Author: Kenneth Giusti <email address hidden>
Date: Tue Jul 3 13:38:46 2018 -0400

    No longer allow redundant calls to server start()

    This has been deprecated since before Ocata.

    Change-Id: I659cc690c0a5d4f82349c7c4882c34c9c82e8a8a
    Closes-Bug: #1712397

Changed in oslo.messaging:
status: In Progress → Fix Released

This issue was fixed in the openstack/oslo.messaging 8.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers