UnsupportedVersion exception could be more friendly

Bug #1340277 reported by Armando Migliaccio
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.messaging
Low
Armando Migliaccio

Bug Description

If an endpoint does not support a specific RPC version, the following stacktrace can be observed on the callee side:

http://paste.openstack.org/show/85970/

However there is no stacktrace on the caller side in case of cast operations.

Granted one can look the RPC version history to get a sense of what's going on, but sometimes the code is not very educated (as in people forget to update the docstrings), and it takes one or more rounds to get to the bottom of the issue.

It would be nice if the exception captured the method in question, so that it's easier to debug what's going on.

Changed in oslo:
assignee: nobody → Armando Migliaccio (armando-migliaccio)
Changed in oslo.messaging:
assignee: nobody → Armando Migliaccio (armando-migliaccio)
status: New → Triaged
importance: Undecided → Low
no longer affects: oslo
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to oslo.messaging (master)

Fix proposed to branch: master
Review: https://review.openstack.org/107240

Changed in oslo.messaging:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to oslo.messaging (master)

Reviewed: https://review.openstack.org/107240
Committed: https://git.openstack.org/cgit/openstack/oslo.messaging/commit/?id=ed886236f6c80b4f9379c941398b589b46c6ca6d
Submitter: Jenkins
Branch: master

commit ed886236f6c80b4f9379c941398b589b46c6ca6d
Author: armando-migliaccio <email address hidden>
Date: Tue Jul 15 22:57:11 2014 -0700

    Track the attempted method when raising UnsupportedVersion

    This helps in circumstances where the only stacktrace visible
    is on the target side (e.g. due to cast or fanout operations)
    and without the method information is difficult to root cause
    what is going on.

    Change-Id: I070ecda4d56186fcda8e8bfc49bf723928998393
    Closes-bug: #1340277

Changed in oslo.messaging:
status: In Progress → Fix Committed
Mehdi Abaakouk (sileht)
Changed in oslo.messaging:
milestone: none → 1.5.0
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers