[SRU] Unintended assignment of "syslog"

Bug #1499620 reported by Masaki Matsushita
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oslo.log
High
Masaki Matsushita
Nominated for Liberty by Matt Riedemann
python-oslo.log (Ubuntu)
High
Unassigned
Wily
High
Edward Hope-Morley
Xenial
High
Unassigned

Bug Description

[Impact]

 * Fixes syslog handler issue which is causing problems with Neutron services
   in Openstack Liberty.

[Test Case]

 * Deploy neutron services with use_syslog=True in /etc/neutron/neutron.conf
   and check /var/log/neutron/neutron-server.log for errors. Also check that
   neutron logs are going to /var/log/syslog.

[Regression Potential]

 * None

Identifier "syslog" is unintendedly reassigned in _setup_logging_from_conf()
with OSSysLogHandler in oslo_log/log.py.
It causes an error in _find_facility() which expects "syslog" as module.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to oslo.log (master)

Fix proposed to branch: master
Review: https://review.openstack.org/227688

Changed in oslo.log:
assignee: nobody → Masaki Matsushita (mmasaki)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to oslo.log (master)

Reviewed: https://review.openstack.org/227688
Committed: https://git.openstack.org/cgit/openstack/oslo.log/commit/?id=ff277ae1e9b53b1844ecc220383ab9d39f954881
Submitter: Jenkins
Branch: master

commit ff277ae1e9b53b1844ecc220383ab9d39f954881
Author: Masaki Matsushita <email address hidden>
Date: Fri Sep 25 15:29:38 2015 +0900

    Fix unintended assignment of "syslog"

    Identifier "syslog" is unintendedly reassigned in _setup_logging_from_conf()
    with OSSysLogHandler.
    It causes an error in _find_facility() which expects "syslog" as module.
    This change fixes the problem.

    Change-Id: Icd8486bc008028f6f78f0306d835bf2c4fb9245b
    Closes-Bug: #1499620

Changed in oslo.log:
status: In Progress → Fix Committed
Changed in oslo.log:
milestone: none → 1.12.0
status: Fix Committed → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to oslo.log (stable/liberty)

Fix proposed to branch: stable/liberty
Review: https://review.openstack.org/235954

Revision history for this message
Matt Riedemann (mriedem) wrote : Re: Unintended assignment of "syslog"

If this crashes neutron we should get a backport into a patch version on stable/liberty.

Changed in oslo.log:
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to oslo.log (stable/kilo)

Fix proposed to branch: stable/kilo
Review: https://review.openstack.org/235980

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to oslo.log (stable/liberty)

Reviewed: https://review.openstack.org/235954
Committed: https://git.openstack.org/cgit/openstack/oslo.log/commit/?id=83dd60562fa79d31337e9b9ecec9264bc5b4d9dc
Submitter: Jenkins
Branch: stable/liberty

commit 83dd60562fa79d31337e9b9ecec9264bc5b4d9dc
Author: Masaki Matsushita <email address hidden>
Date: Fri Sep 25 15:29:38 2015 +0900

    Fix unintended assignment of "syslog"

    Identifier "syslog" is unintendedly reassigned in _setup_logging_from_conf()
    with OSSysLogHandler.
    It causes an error in _find_facility() which expects "syslog" as module.
    This change fixes the problem.

    Change-Id: Icd8486bc008028f6f78f0306d835bf2c4fb9245b
    Closes-Bug: #1499620
    (cherry picked from commit ff277ae1e9b53b1844ecc220383ab9d39f954881)

tags: added: in-stable-liberty
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to oslo.log (stable/kilo)

Reviewed: https://review.openstack.org/235980
Committed: https://git.openstack.org/cgit/openstack/oslo.log/commit/?id=b57433f8752cd47c7d3f3c04501ebb64a9cd7c3a
Submitter: Jenkins
Branch: stable/kilo

commit b57433f8752cd47c7d3f3c04501ebb64a9cd7c3a
Author: Masaki Matsushita <email address hidden>
Date: Fri Sep 25 15:29:38 2015 +0900

    Fix unintended assignment of "syslog"

    Identifier "syslog" is unintendedly reassigned in _setup_logging_from_conf()
    with OSSysLogHandler.
    It causes an error in _find_facility() which expects "syslog" as module.
    This change fixes the problem.

    Change-Id: Icd8486bc008028f6f78f0306d835bf2c4fb9245b
    Closes-Bug: #1499620
    (cherry picked from commit ff277ae1e9b53b1844ecc220383ab9d39f954881)

tags: added: in-stable-kilo
Revision history for this message
Matt Riedemann (mriedem) wrote : Re: Unintended assignment of "syslog"

Release request for stable/liberty oslo.log 1.11.1: https://review.openstack.org/#/c/240025/

James Page (james-page)
Changed in python-oslo.log (Ubuntu Wily):
importance: Undecided → High
Changed in python-oslo.log (Ubuntu Xenial):
importance: Undecided → High
status: New → Fix Committed
Changed in python-oslo.log (Ubuntu Wily):
assignee: nobody → Edward Hope-Morley (hopem)
status: New → In Progress
description: updated
summary: - Unintended assignment of "syslog"
+ [SRU] Unintended assignment of "syslog"
Revision history for this message
Edward Hope-Morley (hopem) wrote :
Chris J Arges (arges)
Changed in python-oslo.log (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Masaki, or anyone else affected,

Accepted python-oslo.log into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-oslo.log/1.11.0-1ubuntu0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-oslo.log (Ubuntu Wily):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-oslo.log - 1.11.0-1ubuntu0

---------------
python-oslo.log (1.11.0-1ubuntu0) wily; urgency=medium

  * Fix unintended assignment of "syslog" (LP: #1499620)
    - d/p/fix-unintended-assignment-of-syslog.patch

 -- Edward Hope-Morley <email address hidden> Tue, 05 Jan 2016 10:30:53 -0600

Changed in python-oslo.log (Ubuntu Wily):
status: Fix Committed → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for python-oslo.log has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: sts-sru
Louis Bouchard (louis)
tags: removed: sts-sru
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers