ad248f6 jsonutils sync breaks if simplejson < 2.2.0 (under python 2.6)

Bug #1361230 reported by Matt Riedemann on 2014-08-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Medium
Matt Riedemann
OpenStack Identity (keystone)
Medium
Brant Knudson
oslo-incubator
High
Matt Riedemann
oslo.serialization
High
Matt Riedemann
taskflow
High
Joshua Harlow

Bug Description

This keystone sync:

https://github.com/openstack/keystone/commit/94efafd6d6066f63a9226a6b943d0e86699e7edd

Pulled in this change to jsonutils:

https://review.openstack.org/#/c/113760/

That uses a flag in json.dumps which is only in simplejson >= 2.2.0. If you don't have a new enough simplejson the keystone database migrations fail.

Keystone doesn't even list simplejson as a requirement and oslo-incubator lists simplejson >= 2.0.9 as a test-requirement since it's optional in the code.

summary: - ad248f6 jsonutils sync breaks if simplejson < 2.2.0
+ ad248f6 jsonutils sync breaks if simplejson < 2.2.0 (under python 2.6)
Matt Riedemann (mriedem) wrote :

global-requirements update: https://review.openstack.org/#/c/116632/

Changed in oslo:
status: New → Triaged
assignee: nobody → Matt Riedemann (mriedem)
importance: Undecided → High
Matt Riedemann (mriedem) wrote :

Since keystone doesn't list simplejson as a requirement (since it's optional in the jsonutils code) maybe this is an invalid bug for keystone.

Changed in keystone:
status: New → Invalid
Matt Riedemann (mriedem) wrote :

oslo.serializer patch here: https://review.openstack.org/#/c/117854/

If that's merged I'll backport to oslo-incubator.

Changed in oslo-incubator:
milestone: none → juno-rc1
Changed in oslo.serialization:
assignee: nobody → Matt Riedemann (mriedem)
milestone: none → juno-rc1
status: New → Triaged
importance: Undecided → High
Matt Riedemann (mriedem) on 2014-09-04
Changed in keystone:
status: Invalid → Confirmed
Brant Knudson (blk-u) wrote :

For keystone this is going to require an oslo-incubator sync of https://review.openstack.org/#/c/119073/ once that's merged.

Thierry Carrez (ttx) on 2014-09-05
Changed in oslo.serialization:
milestone: none → next-juno
Matt Riedemann (mriedem) wrote :

The oslo-incubator cherry pick is merged so we can sync this to keystone now.

Fix proposed to branch: master
Review: https://review.openstack.org/119639

Changed in keystone:
assignee: nobody → Brant Knudson (blk-u)
status: Confirmed → In Progress
Brant Knudson (blk-u) wrote :
Changed in keystone:
milestone: none → juno-rc1
importance: Undecided → Medium
Joshua Harlow (harlowja) on 2014-09-07
Changed in taskflow:
importance: Undecided → Medium
importance: Medium → High
Joshua Harlow (harlowja) wrote :
Changed in taskflow:
assignee: nobody → Joshua Harlow (harlowja)
status: New → In Progress
milestone: none → next-juno

Reviewed: https://review.openstack.org/119632
Committed: https://git.openstack.org/cgit/openstack/taskflow/commit/?id=66839bdcafa448e48f4814e4ba0ebd008bc67c01
Submitter: Jenkins
Branch: master

commit 66839bdcafa448e48f4814e4ba0ebd008bc67c01
Author: Joshua Harlow <email address hidden>
Date: Sun Sep 7 09:53:22 2014 -0700

    Update oslo-incubator to 32e7f0b56f52742754

    Pickup a couple of changes (mainly the first one listed below)
    that are useful to have before we release and will ensure
    we are compatible with python 2.6 and RHEL due to a bug
    in jsonutils.

    d9060f69d203 - Check for namedtuple_as_object support before using it
    66142c3471fe - Make strutils.mask_password more secure

    Closes-Bug: #1361230

    Change-Id: I2c3d86184830211b3163988a4054fc45e233c9ba

Changed in taskflow:
status: In Progress → Fix Committed
Changed in oslo.serialization:
milestone: next-juno → juno-rc1
Doug Hellmann (doug-hellmann) wrote :
Changed in oslo.serialization:
status: Triaged → Fix Committed
Changed in oslo-incubator:
status: Triaged → Fix Committed
Matt Riedemann (mriedem) wrote :

Also needs to be fixed in ceilometer:

https://github.com/openstack/ceilometer/commit/341bad76c7a19d3a01a9ee97fd21c66f909e036a

I checked cinder, glance, heat, neutron and trove and they hadn't synced the original change over so they are OK.

Matt Riedemann (mriedem) on 2014-09-11
Changed in ceilometer:
assignee: nobody → Matt Riedemann (mriedem)
status: New → In Progress
Lianhao Lu (lianhao-lu) on 2014-09-12
Changed in ceilometer:
milestone: none → juno-rc1
importance: Undecided → Medium

Reviewed: https://review.openstack.org/119639
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=87386c164d332b02224d594d86b2a305a8bb1d38
Submitter: Jenkins
Branch: master

commit 87386c164d332b02224d594d86b2a305a8bb1d38
Author: Brant Knudson <email address hidden>
Date: Sun Sep 7 13:45:16 2014 -0500

    Sync jsonutils from oslo-incubator 32e7f0b5

    Syncs the jsonutils module from oslo-incubator using commit
    32e7f0b56f527427544050f251999f3de588ac93 .

    Note that since there's a feature change in oslo-incubator I'm
    switching to module syncs.

     $ ./update.sh --nodeps --base keystone --dest-dir ../keystone \
         --modules jsonutils

    This change includes the following commit
    -----------------------------------------
    d9060f6 Check for namedtuple_as_object support before using it

    Change-Id: I152faacdbb394209f87b91a699bb4ca185c2125e
    Closes-Bug: #1361230

Changed in keystone:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/120829
Committed: https://git.openstack.org/cgit/openstack/ceilometer/commit/?id=57495f934b7a6617ea0faf1856a53285175e4c5b
Submitter: Jenkins
Branch: master

commit 57495f934b7a6617ea0faf1856a53285175e4c5b
Author: Matt Riedemann <email address hidden>
Date: Thu Sep 11 08:52:04 2014 -0700

    Sync jsonutils for namedtuple_as_object fix

    This is to pull in the fix for bug 1361230 which was introduced
    with a prior sync of jsonutils.

    strutils is pulled in as a dependency but also fixes an
    unrelated bug 1345233.

    Changes:

    jsonutils
    ---------
    d9060f6 Check for namedtuple_as_object support before using it

    strutils
    --------
    66142c3 Make strutils.mask_password more secure

    Change-Id: I9bd2e5f93c2684203487627f64f70d5da7b13586
    Closes-Bug: #1361230
    Partial-Bug: #1345233

Changed in ceilometer:
status: In Progress → Fix Committed
Changed in oslo.serialization:
status: Fix Committed → Fix Released
Changed in taskflow:
milestone: next-juno → next-kilo
Changed in oslo-incubator:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-09-30
Changed in keystone:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-09-30
Changed in ceilometer:
status: Fix Committed → Fix Released
Joshua Harlow (harlowja) on 2014-10-06
Changed in taskflow:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-10-16
Changed in keystone:
milestone: juno-rc1 → 2014.2
Thierry Carrez (ttx) on 2014-10-16
Changed in ceilometer:
milestone: juno-rc1 → 2014.2
Joshua Harlow (harlowja) on 2014-11-17
Changed in taskflow:
milestone: next-kilo → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers