[SRU] upon creating a node via juju & orchestra, etckeeper hangs

Bug #872553 reported by Tom Ellis on 2011-10-11
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Orchestra
High
Andres Rodriguez
etckeeper (Ubuntu)
High
Dustin Kirkland 
Oneiric
High
Dustin Kirkland 
orchestra (Ubuntu)
High
Andres Rodriguez
Oneiric
High
Andres Rodriguez

Bug Description

## Issue

After running 'juju boostrap' a node is installed via orchestra and then hangs after boot. On inspection it appears etckeeper is having issues, presenting a dialog and causing the 'apt-get install juju' to hang'.

## Environment

ii cobbler 2.1.0+git20110602-0ubuntu26 Install server
ii cobbler-common 2.1.0+git20110602-0ubuntu26 Cobbler Install server - common files
ii cobbler-web 2.1.0+git20110602-0ubuntu26 Cobbler Install server - web interface
ii python-cobbler 2.1.0+git20110602-0ubuntu26 Install server - python libraries.
ii juju 0.5+bzr401-1juju1~oneiric1 Cloud automation and orchestration
ii ubuntu-orchestra-common 2.21-0ubuntu1 Ubuntu Orchestra common files
ii ubuntu-orchestra-logging-server 2.21-0ubuntu1 Ubuntu Orchestra Logging Server
ii ubuntu-orchestra-management-server 2.21-0ubuntu1 Ubuntu Orchestra Configuration Management Server
ii ubuntu-orchestra-monitoring-server 2.21-0ubuntu1 Ubuntu Orchestra Monitoring Server
ii ubuntu-orchestra-provisioning-server 2.21-0ubuntu1 Ubuntu Orchestra Provisioning Services suite
ii ubuntu-orchestra-server 2.21-0ubuntu1 Ubuntu Orchestra Services suite

## Workaround

* kill off the process from etckeeper that is causing the apt-get to hang
"root 3400 3392 0 17:30 ? 00:00:00 whiptail --backtitle Package configuration --title --output-fd 11 --nocancel --msgbox Commit failed??An attempt to commit /etc changes to bzr failed.??You may manually resolve the issues with the uncommitted changes before continuing. 11 88"

=============== SRU JUSTIFICATION =====================

## Inpact

This bugs affects ubuntu-orchestra-client installations when deploying with juju as it causes etckeeper to fail to commit, which causes apt-get to hang and does not allow the installation to finish successfully (done by juju)

## Fix
The fix is pretty trivial and is just the case of setting the correct lang encoding.

## Test Case
1. Deploy a machine with juju/orchestra and make sure ubuntu-orchestra-client installs etckeeper.
2. cloud-init will then try to install all the juju related stuff
3. this will fail.

## Regression potential
Minimal. This has been tested throughoutly.

Tom Ellis (tellis) wrote :

I've uploaded cloud-init.log and cloud-init-output.log files from the node that juju was bootstrapping, when this hung I ssh'ed to the node and killed off the whiptail process that was causing it to hang.

Tom Ellis (tellis) wrote :
Tom Ellis (tellis) wrote :
Tom Ellis (tellis) wrote :

my environments.yaml:

juju: environments
environments:
  orchestra:
    type: orchestra
    # Specify the orchestra server (santol's IP address)
    orchestra-server: 10.230.5.50
    # Specify storage. In this case we are using webdav installed by orchestra.
    storage-url: http://10.230.5.50/webdav
    # Specify cobbler's usr/pass
    orchestra-user: cobbler
    orchestra-pass: ubuntu
    admin-secret: fooooo
    # Branch from where we will install juju
    # juju-branch: lp:juju
    # Mangement classes
    acquired-mgmt-class: orchestra-juju-acquired
    available-mgmt-class: orchestra-juju-available
    default-series: oneiric

Tom Ellis (tellis) wrote :

On the node, if I check with bzr or etc keeper the state of /etc it seems there are uncommited changes related to zookeeper and java

Clint Byrum (clint-fewbar) wrote :

I believe this is likely an issue with etckeeper, not orchestra itself, so adding it as an affected package. When I experienced the issue, I had to stop the 'tty1' upstart job and confirm etckeeper's error that it had problems committing. I believe the issue may be related to files with names or contents that don't agree with the locale of the box.

Changed in orchestra:
status: New → Confirmed
importance: Undecided → High
Changed in orchestra (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Clint Byrum (clint-fewbar) wrote :

To be clear, it was 100% repeatable by simply deploying 11.10 with any charm using juju + orchestra.

Dave Walker (davewalker) on 2011-10-12
Changed in etckeeper (Ubuntu Oneiric):
importance: Undecided → High
Changed in orchestra:
assignee: nobody → Andres Rodriguez (andreserl)
Changed in etckeeper (Ubuntu Oneiric):
status: New → In Progress
Changed in orchestra:
status: Confirmed → In Progress
Changed in etckeeper (Ubuntu Oneiric):
assignee: nobody → Dustin Kirkland (kirkland)
Changed in orchestra (Ubuntu Oneiric):
assignee: nobody → Andres Rodriguez (andreserl)
status: Confirmed → In Progress
Dustin Kirkland  (kirkland) wrote :

I believe this is a duplicate of Bug #791839, where etckeeper is failing for similar reasons when run non-interactively from a cronjob.

Basically, bzr is failing to handle UTF8 filenames, due to an incorrect or unspecified local/language setting.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package orchestra - 2.21-0ubuntu2

---------------
orchestra (2.21-0ubuntu2) oneiric; urgency=low

  * debian/control: Drop recommends on etckeeper, which caused juju
    deployments to hang. (LP: #872553)
 -- Dave Walker (Daviey) <email address hidden> Wed, 12 Oct 2011 16:29:17 +0100

Changed in orchestra (Ubuntu Oneiric):
status: In Progress → Fix Released
Dustin Kirkland  (kirkland) wrote :

Invalid against Orchestra. Bug was in etckeeper, itself.

Changed in orchestra:
status: In Progress → Invalid
Changed in orchestra (Ubuntu Oneiric):
status: Fix Released → Invalid
summary: - upon creating a node via juju & orchestra, etckeeper hangs
+ [SRU] upon creating a node via juju & orchestra, etckeeper hangs
description: updated

Hello Tom, or anyone else affected,

Accepted etckeeper into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in etckeeper (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Tom Ellis (tellis) wrote :

Hi Martin,

I added a post script to pull in etckeeper, since the update to orchestra removed the recommends on it. I then noticed that there is no updated package of bzr or etckeeper in oneiric-proposed.

Infact, I don't see any content at all in oneiric-proposed's Packages.gz or .bz2... issue with pushing into that part of the archive at the moment?

Tom,

etckeeper 0.56ubuntu2.1 is in oneiric-proposed:
 * https://launchpad.net/ubuntu/+source/etckeeper

etckeeper (0.56ubuntu2.1) oneiric-proposed; urgency=low

  * etckeeper: LP: #872553, #791839
    - ensure that LANG is set, default to UTF8, necessary for bzr to
      function properly in non-interactive shells (eg, cron); user's
      local LANG will override if set
 -- Dustin Kirkland <email address hidden> Wed, 12 Oct 2011 12:18:25 -0500

Dustin

Tom Ellis (tellis) wrote :

Doh, brain fail at that time in the morning... I was adding backports.. testing shortly.

Tom Ellis (tellis) wrote :

I added proposed in post and made sure it was installed before juju and the problem is fixed.

ubuntu@ch02b12:~$ apt-cache policy etckeeper
etckeeper:
  Installed: 0.56ubuntu2.1
  Candidate: 0.56ubuntu2.1
  Version table:
 *** 0.56ubuntu2.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.56ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

Could we now add etckeeper back to be a recommends of orchestra-client?

Thanks all!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package etckeeper - 0.56ubuntu2.1

---------------
etckeeper (0.56ubuntu2.1) oneiric-proposed; urgency=low

  * etckeeper: LP: #872553, #791839
    - ensure that LANG is set, default to UTF8, necessary for bzr to
      function properly in non-interactive shells (eg, cron); user's
      local LANG will override if set
 -- Dustin Kirkland <email address hidden> Wed, 12 Oct 2011 12:18:25 -0500

Changed in etckeeper (Ubuntu):
status: Fix Committed → Fix Released
Changed in etckeeper (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers