Automate cobbler setup

Bug #766146 reported by Tom Ellis on 2011-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Orchestra
Undecided
Marc Cluet

Bug Description

After we have cobbler installed it would be nice to have a helper-script in orchestra to bootstrap the basic cobbler configuration.

- import a mini iso
 * run a script from cron to pull down the mini isos for the supported distro series?
- write out a seed file for that distro
- setup cobbler profile (automatic if using the main server iso, but not for mini.iso)
- modify the cobbler settings file to point to the local ip address
- cobbler sync

Tom Ellis (tellis) wrote :

FYI, this is "wishlist" item.

Tom Ellis (tellis) wrote :

Ideas for the helper:

* Add IP to /etc/cobbler/settings
 - next_server: for dhcp (if used)
 - server:
* Download the mini.iso
wget -c http://archive.ubuntu.com/ubuntu/dists/natty/main/installer-amd64/current/images/netboot/mini.iso
* Loopback mount iso
mount -o loop mini.iso /mnt
* Import iso
cobbler import --name=natty-x86-64 --path=/mnt --breed=ubuntu --os-version=natty
* Add distro and profile (because of lp #765224)
cobbler distro add --name=natty --kernel=/var/www/cobbler/ks_mirror/natty-x86-64/linux --initrd=/var/www/cobbler/ks_mirror/natty-x86-64/initrd.gz --arch=x86_64 --breed=ubuntu --os-version=natty
cobbler profile add --name=natty-server-install --distro=natty-x86-64 --kickstart=/var/lib/cobbler/kickstarts/ubuntu-natty-server.seed --kopts="priority=critical locale=en_US"
* Add a seed file to /var/lib/cobbler/kickstarts/ubuntu-natty-server.seed
* If squid-deb-proxy is used, point seed file to proxy address
* Run 'cobbler sync' to sync profiles

Marc Cluet (lynxman) on 2011-04-19
Changed in orchestra:
assignee: nobody → Marc Cluet (lynxman)
status: New → Confirmed
Marc Cluet (lynxman) wrote :

Helper written by Kirkland and Tellis

Changed in orchestra:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers