DieselConsumptionTab does not accept gal/h or l/h asa UoM

Bug #1745490 reported by Gerald Storey on 2018-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Undecided
Unassigned

Bug Description

As specified in the manual the default UoM for the DieselConsumptionTab, found in the ORTSDieselEngines block, is gal/kwh. That may be the technically correct term for a diesel engine running a electrical generating plant, however, it is an unfriendly term for most users.
I have tried other UoM, gal/h for instance -- the OR log shows the following warnings:
"Warning: Found a suffix 'gal/h' which could not be parsed as a Any unit in F:\2TSF\ShermanHill\trains\trainset\SLI_UNION_PACIFIC\openrails\UP_SD70ACE_8367.eng:line 25

Warning: Found a suffix 'gal/h' which could not be parsed as a Any unit in F:\2TSF\ShermanHill\trains\trainset\DWupSD70M\openrails\UP5013.eng:line 28" ***see attached log

All the engine files I've run across (NorthAmerican) list fuel consumption in gal/h, the metric equivalent being l/h.

To make OR more user friendly (specifically the ORTSDieselEngine block) the DieselConsumptionTab should accept gal/h and l/h as optional UoM.

Any conversion to gal/kwh should be done by OR, not the user.
My hope is that this presents no undue problems to change in the code.
Thank You, Gerry Storey

Gerald Storey (gerry-s-u) wrote :

The actual UoM is l/rpm. So it is suggested that use of gal/h or l/h is not appropriate.

It appears that the manual has the incorrect UoM in it. Manual Corrected

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers