System.IO.InvalidDataException at Orts.Simulation.Timetables.TimetableInfo.GetPlayerTrain (1.2.3766, Custom Timetable, Player train crash)

Bug #1722022 reported by Michael Brettle on 2017-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Undecided
Unassigned

Bug Description

Hi,

I have created a custom timetable using the Timetable Editor in OR but I receive the error:

"System.IO.InvalidDataException: Player train : C:\Program Files (x86)\Microsoft Games\Train Simulator\ROUTES\AUeppingline\ACTIVITIES\OPENRAILS\timetable 1 - Copy.timetable_or:Player1 not found in timetables"

when trying to load the timetable. Have I possibly named something incorrectly in the timetable? Any help would be appreciated.

Michael Brettle (mike91) wrote :
James Ross (twpol) on 2017-10-10
summary: - Custom Timetable System.IO.InvalidDataException: Player train crash
+ System.IO.InvalidDataException at
+ Orts.Simulation.Timetables.TimetableInfo.GetPlayerTrain (1.2.3766,
+ Custom Timetable, Player train crash)
r.roeterdink (r-roeterdink) wrote :

How did you start this session?
The fourth parameter, defining the train, is completely wrong - it should just be the train and timetable reference, not the file path.
See example below.

Version = <none>
Build = 0.0.6496.26512 (2017-10-14 14:43:44Z)
Logfile = C:\Users\Roeterdink\Desktop\OpenRailsLog.txt
Executable = RunActivity.exe
Argument = -start
Argument = -timetable
Argument = D:\TrainSim\Org\ROUTES\Newfoundland\ACTIVITIES\OPENRAILS\NF2017.timetablelist_or
Argument = 2017_WSU_BUC_down:0614_WSU_DLK_SAY
Argument = 0
Argument = 1
Argument = 0

Michael Brettle (mike91) wrote :

Sorry for the late reply, I have finally had a chance to do some testing.

Your post got me thinking so I decided to create a new timetable using the Timetable Editor in Open Rails, the same way I did with the initial timetable.

The old timetable displays the full file path of the timetable, where as the new timetable appears as just the timetable name (see screenshot). Not sure how this has occurred, but I am fairly sure I created the timetables in exactly the same way.

Michael Brettle (mike91) wrote :

Just for completion, I have tested the new timetable and it does load correctly

James Ross (twpol) on 2017-10-29
tags: added: content crash
James Ross (twpol) on 2017-10-29
tags: added: timetable
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers