Original MSTS Engine Acela HHP-8 has no brakeforce after 15s

Bug #1629635 reported by Rippstein on 2016-10-02
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Carlo Santucci

Bug Description

If I start the Acela HHP-8 with original file acelahhl.eng in a activity or in explorer-mode,
the Engine will by create with the trainbrake applied at 60%, as usual.
After 15 seconds the brake-cylinders loose here pressure.
The brake-lever stay in the same position 60% applied, with no pressure in the brake-cylinders.

Update 4.Dez 2016:
This is because the blending Function is blending the TrainBrake by the DynamicBrake.
In the *.eng-File is defined:
DynamicBrakesCutInSpeed( 8 )
This function should only by activated over 8 km/h and not at an standing engine.

If I release the trainbrake, and drive the engine, then apply the trainbrake again, it shows the same behavior, after 15 seconds, loose of pressure and NO BRAKE-FORCE. No possibility to brake the Engine with the trainbrake.

This behavior exist since X3407 a release produced by "disc".

show also here:

show also here:

Rippstein (ch-signale) on 2016-10-03
description: updated
Rippstein (ch-signale) wrote :
Rippstein (ch-signale) on 2016-12-04
description: updated
Carlo Santucci (carlosanit1) wrote :

A partial bug fix has been uploaded in x.3934, accordingly to http://www.elvastower.com/forums/index.php?/topic/29082-trainbrake-problem-with-acela-hhp-8/page__view__findpost__p__224482 .
What remains to be solved is that on single-pipe locos, in the decelerating phase where the dynamic brake does no more intervene enough because of fadeoff, the airbrake does not resume operation.

To temporarily overcome this, the player has to slightly increase brake percentage.

Changed in or:
assignee: nobody → Carlo Santucci (carlosanit1)
status: New → In Progress
Carlo Santucci (carlosanit1) wrote :

Moreover DynamicBrakeBlendingForceMatch has now set true as default, as this provides smoother and more effective braking.

Changed in or:
assignee: Carlo Santucci (carlosanit1) → nobody
James Ross (twpol) on 2018-06-27
Changed in or:
status: In Progress → Triaged
Rippstein (ch-signale) wrote :

I have tested the Acela HHP-8 with X4155.
I can't find no more Problems with the blended dynamic brake.

If the option "Questionable brake Parameters" is set, the blended dynamic brake will not be activated, as it was by MSTS. If it is not set, the dynamic brake is blending the trainbrake. The only Problem: The dynamic brakeforce is low. But this is not a case of this bugreport. It is perhaps a Problem in the *.eng-file.

So I have found, that this Bug is solved now.


Changed in or:
assignee: nobody → Carlo Santucci (carlosanit1)
status: Triaged → Fix Committed
James Ross (twpol) on 2018-07-07
Changed in or:
importance: Undecided → Medium
milestone: none → 1.3
James Ross (twpol) on 2018-11-30
Changed in or:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments