Doppler effect reversed while in a rear cab

Bug #1455963 reported by Ben Dragon on 2015-05-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Undecided
Carlo Santucci

Bug Description

The Doppler effect is reversed when you change into the rear cab of a locomotive which has been equipped with 2 cabs.

This bug does not depend on consist heading or whether the locomotive is flipped or not, it only matters which locomotive cab that you're in.

It also doesn't matter which direction the rear cab is facing.

This bus has been existing since X3053 as far as I know.

Ben Dragon (ben2337) on 2015-05-17
summary: - Doppler effect reversed when in rear facing cab
+ Doppler effect reversed while in rear facing cab
summary: - Doppler effect reversed while in rear facing cab
+ Doppler effect reversed while in a rear facing cab
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
summary: - Doppler effect reversed while in a rear facing cab
+ Doppler effect reversed while in a rear cab
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
description: updated
description: updated
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
description: updated
Ben Dragon (ben2337) on 2015-05-17
description: updated
description: updated
Carlo Santucci (carlosanit1) wrote :

Two questions:
1) What is reversed? Sound frequency (higher frequency vs. lower frequency), or position of sound (left/right)?
2) How did you notice that? I ask this second question to try to reproduce the problem.

Ben Dragon (ben2337) wrote :

The sound frequency is reversed (The sound frequency goes from low to high compared to high to low) while within the rear locomotive cab.

You need to have a locomotive with an _rv Cab view file to replicate this as you need to change cabs into the rear cab.

I noticed this after enabling the default MSTS class 50 with a "class50_rv.cvf" cab view file, then in the consist "class 50, 8 carriages.con" I run round the train, thereby forcing me to look out of the rear cab and shortly after proceeding on my return journey, I've been noticing the frequencies of stationary sound sources (including level crossings and vehicle sounds) getting reversed.

I do realise not many MSTS vehicles (including third party) have the _rv.cvf file within the CABVIEW folder so I don't think many people would have spotted it.

Carlo Santucci (carlosanit1) wrote :

I have checked this and in fact the problem is present.

Changed in or:
status: New → Confirmed
Carlo Santucci (carlosanit1) wrote :

Fixed in x.3089. Also the inverse problem occurred: when a loco using rear cab passed near to a trackside camera, the Doppler effect for the loco sounds was reversed.

Changed in or:
assignee: nobody → Carlo Santucci (carlosanit1)
status: Confirmed → Fix Committed
James Ross (twpol) on 2015-05-18
Changed in or:
milestone: none → 1.0
James Ross (twpol) on 2015-05-25
Changed in or:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers