Incorrect brake settings after changing cab

Bug #1448791 reported by r.roeterdink on 2015-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Medium
Unassigned

Bug Description

Brake settings are lost when changing from Driving Trailer to Engine or vv on push-pull sets.
The values of the various brake parameters no longer match, and the brakes cannot be worked anymore through the usual means.
A full brake initiation (using shift-/) is necessary to reasses control of the brakes.

In particular, the settings of the triple valve state go complete haywire - in this case from "release" on the driving trailer to "emergency" on the engine.

r.roeterdink (r-roeterdink) wrote :

Picture 1 : brake settings in Driving Trailer.

r.roeterdink (r-roeterdink) wrote :

Picture 2 : brake settings in Engine after cab change (Control-E).

James Ross (twpol) wrote :

I'd like to see this fixed for 1.0 if we can do so simply and cleanly; but since cab changing is a bit of an extended feature, if this is not easy to fix we'll go without it.

Changed in or:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 1.0
Carlo Santucci (carlosanit1) wrote :

I don't have this experience. I tried both with electric and diesel compositions: pressing Ctrl-E brake values remain unaltered, both with autopilot flag on and off. The couple of pictures for the diesel composition is attached. Maybe in your case the braking parameter values of the consist elements are incompatible?

Carlo Santucci (carlosanit1) wrote :
James Ross (twpol) on 2015-05-18
Changed in or:
milestone: 1.0 → 1.1
James Ross (twpol) on 2016-03-24
Changed in or:
milestone: 1.1 → 1.2
James Ross (twpol) on 2017-01-21
Changed in or:
milestone: 1.2 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers