Winter + night-time on Severn Valley Railway cripples rendering

Bug #1266210 reported by David Martin Lewis on 2014-01-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Rails
Low
Unassigned

Bug Description

When running activity "A Winter Evening Run" on the route "Severn Valley Railway" the sim becomes almost solidly frozen at the outset of the activity. Keyboard presses take a minute or so to action. The obvious clue to what may be wrong is the fact that the player train is at the wrong place, not alongside the station platform where it should be, but one track removed from it.

Dave

r.roeterdink (r-roeterdink) wrote :

Not sure how the wrong path could influence the frame rate.
But as for the wrong path : this is a known problem for which there is no fix at present. If possible, you could check the path definition and see if it starts very near to a switch. If so, move the starting point further away from that switch, that usually sorts the problem.

James Ross (twpol) wrote :

Can you make it to the DEBUG page of the HUD (F5) display? Press Shift-F5 a few times until you get there and take a screenshot. That'd be really useful, thanks.

I have tried several times to reach the debug page (it should be 6 x shift_F5 as far as I can see from a working activity), however all I can manage to get up is the basic F5 display followed by consist and then locomotive info. Further presses of shift_F5 generate nothing. It appears that the wait between keystrokes and effect becomes more lengthy with each keystroke. I have tried solidly for about 20minutes without success to reach the Debug page with this activity and it appears to be impossible.

I have taken screenshots of the 3 screens I did manage to reach, they are attached below.

Will keep trying and if successful, will post again.

Dave

James Ross (twpol) wrote :

Thanks for putting in the effort! I believe that you need to have the key held down for 1-2 frames for it to be detected, which obviously means holding it down for quite a while in this case. Don't worry if it's proving too hard - I'm sure we'll figure this out.

Is the route Severn Valley Railway freely available? Is the activity A Winter Evening Run included? If yes to both, we'll be able to get a developer to try reproducing the problem.

Hi James,

The Severn Valley Railway is a commercially produced route, available from Just Trains or used on Amazon.co.uk.
The link is:

http://www.amazon.co.uk/Severn-Valley-Railway-Train-Sim/dp/B0000DZ93Z/ref=sr_1_1?ie=UTF8&qid=1389890317&sr=8-1&keywords=severn+valley+railway+msts

It also appears to be on eBay.co.uk

http://www.ebay.co.uk/itm/SEVERN-VALLEY-RAILWAY-MICROSOFT-TRAIN-SIMULATOR-ADD-ON-RARE-EXPANSION-PACK-/261373039804?pt=UK_PC_Video_Games_Video_Games_JS&hash=item3cdb0c14bc

The Activity "A Winters Evening Run" is included as a standard activity in the package.

I tried holding the shift and F4 keys down for a couple of minutes or so (I am not sure how frequently the display is updated with this problem occurring) but I still can't get past the locomotive parameter display however many times I do this.

Dave

r.roeterdink (r-roeterdink) wrote :

Hello Dave, James,

it so happens I have that route, and there are some other problems reported on it (not graphics related) so I have to look into it anyway.
However, I am very busy at the moment with some other changes, so it may be a week or so before I get down to it.

One more point : I noticed that the frame-rate took a real dive when looking at the train from the front.
Could you perhaps try and see what happens if you select another engine, e.g. a small diesel engine?
For instance, select "explorer mode", and than select a diesel engine from the engine list.

It could be that this steam engine is very 'heavy' for the graphics on your PC.

Regards,
Rob Roeterdink

Hello Rob,

I could only select one consist in explore mode (not a stand alone loco) to start at Kidderminster, I attach screenshots of the train. While stationary, the frame rate on my PC is 80, under way the rate drops to 72. I have a top end PC (intel i7 quad core at 3.33GHz, 12GB of ram, 10,000 rpm system disk, Nvidia GeForce GTX295 graphics card) and raildriver.

Hope this helps.

Dave

r.roeterdink (r-roeterdink) wrote :

Admittedly, I am not a hardware expert.
But do I understand correctly that you could run this train in explorer mode?

If so, next step is to select winter, and then a later time (so it is evening).
Perhaps there is something in a specific winter or night texture that is causing the problem.

Regards,
Rob Roeterdink

I have run the same consist as in "A Winters Evening Run" in Explore Mode,

Summer at 12:00noon: all is ok (see attached screenshot)

Winter at 12:00noon: all is ok (see attached screenshot)

Summer at 21:00night: all is ok (see attached screenshot)

BUT,

Winter at 21:00 or 18:00night: system crash - graphics turns off (no signal) and I have to power down my computer to recover.

So Winter/Night appears to be the problem with this route/activity.

Dave

I have had a small success, finally got the debug page to show, screenshot attached.

Hope this helps.

Dave

This is a picture of the back of the train in MSTS, showing its proximity to the runround points.

James Ross (twpol) on 2014-03-04
summary: - OR freezes (almost) when running activity
+ Winter + night-time on Severn Valley Railway cripples rendering
tags: added: content performance
Changed in or:
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.