Broken import in base_report_creator module

Bug #1025923 reported by Don Kirkby on 2012-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenUpgrade Addons
Medium
Unassigned

Bug Description

When I try to upgrade from 5.0.16 to 6.0, I get the following error (slightly edited):

  File "base_report_creator/migrations/6.0.1.0/pre-migration.py", line 22, in <module>
ImportError: No module named openerp.openupgrade

Steps to reproduce:
1. Create a new database in 5.0 with no sample data and the manufacturing industry profile.
2. Set the view mode to Extended Interface.
3. Leave the default values for all the other setup steps, and set the chart of accounts to "None".
4. From the Administration menu, choose Modules Management: Modules.
5. Open the base_report_creator module and install it.
6. Run the migration using the options, "--update all --stop-after-init". The error occurs as listed above.

The full command line I use for the migration is as follows:
python openerp-server.py --database migrationtest --update all --stop-after-init --addons ~/upgrade-addons-6.0 --config ~/openerp-server.config

Related branches

Hi Don,

many thanks, your fix has been merged. I guess I owe you an apology for my rough code cleaning at the time.

Best regards,
Stefan.

Changed in openupgrade-addons:
status: New → Fix Released
importance: Undecided → Medium
Don Kirkby (donkirkby) wrote :

Don't worry about it, Stefan. I owe you way more for giving me such a huge head start on this migration task. I'm just trying to pay it forward to the next team that tackle migration.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers