types and settings should have unique names

Bug #809241 reported by Marten de Vries
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenTeacher
Medium
OpenTeacher Maintainers

Bug Description

consider:

settings.value("fade_duration")
settings.value("org.openteacher.repeatAnswer.fadeDuration")

for type their names it's the same:

mods(type="list")
mods(type="org.openteacher.lessons.list" #or something like that

it makes sure modules can't claim generic names.

Changed in openteacher:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
milestone: none → 3.0
importance: High → Medium
Revision history for this message
Marten de Vries (marten-de-vries) wrote :

This is already done for large amounts of settings.

Revision history for this message
Marten de Vries (marten-de-vries) wrote :

The settings already use this approach. I think we should make a distinction between our OT mods and 3rd party ones for the type part of the bug. OT mods then wouldn't use prefixes (like now), and 3rd party modules would. This way, we prevent name collisions, but at the same time keep the most used mods easily accessable. And that's an advantage for both OT and 3rd party devs.

Changed in openteacher:
status: Triaged → Won't Fix
status: Won't Fix → In Progress
assignee: nobody → OpenTeacher Maintainers (openteachermaintainers)
Changed in openteacher:
status: In Progress → Fix Committed
Changed in openteacher:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints