Rollback incorrect "ipparam" manipulation from upstream since version 1.2.8 (Oneiric and Precise)

Bug #947404 reported by Julian Alarcon on 2012-03-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Openswan
Undecided
Unassigned
xl2tpd (Debian)
Fix Released
Unknown
xl2tpd (Ubuntu)
Undecided
Unassigned

Bug Description

The is a bad manipulation introduced in xl2tpd version 1.2.8 of ipparam.

This affetcs Oneiric (1.2.8+dfsg-1) and Precise (1.3.1+dfsg-1).

This bug is know by many people, there is even a Workaround (install Natty version of xl2tpd prior to 1.2.8).
http://packages.ubuntu.com/natty/xl2tpd

There is more info of this bug:
Tutorial of installation of l2tp-ipsec-vpn (with workaround): http://strongvpn.com/setup_ubuntu_11.10_l2tp.shtml
Question in l2tp-ipsec-vpn: https://answers.launchpad.net/l2tp-ipsec-vpn/+question/175914

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xl2tpd 1.3.1+dfsg-1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Mon Mar 5 14:23:06 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
ProcEnviron:
 LANGUAGE=es_CO:es
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
SourcePackage: xl2tpd
UpgradeStatus: Upgraded to precise on 2012-02-17 (16 days ago)

Julian Alarcon (julian-alarcon) wrote :
Julian Alarcon (julian-alarcon) wrote :

Openl2tp (other implementation of l2tp) have a report about this
http://forums.openl2tp.org/viewtopic.php?f=4&t=64
https://bugs.gentoo.org/show_bug.cgi?id=195461

Patch to openl2tp: https://195461.bugs.gentoo.org/attachment.cgi?id=275845

Here is a bug report in xl2tpd about this problem:
https://gsoc.xelerance.com/issues/1078

Changed in xl2tpd (Debian):
status: Unknown → Confirmed
Julian Alarcon (julian-alarcon) wrote :

Maybe is posible to apply to a Freeze Exception in Precise:

https://wiki.ubuntu.com/FreezeExceptionProcess

Ma Hsiao-chun (mahsiaochun) wrote :

Is this resolved in recent 1.3.2 upstream release?

Changed in xl2tpd (Debian):
status: Confirmed → Fix Committed
Changed in xl2tpd (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xl2tpd (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.