openSUSE

pcmanfm cut&paste a folder to a destination folder withouth write permission causes data loss

Reported by Luca Borrione on 2011-08-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libfm (Ubuntu)
Undecided
Unassigned
pcmanfm (openSUSE)
Fix Released
Critical

Bug Description

1. create a folder on your desktop
for example ~/Desktop/test/

2. mount an external usb on which there's a folder on which you don't have write permission
for example /media/usbdisk/nowrite/ root:root 755

3. cut your folder on the desktop & paste it on the usb folder using the gui,
which simply means:
- right-click on the folder "test" on your desktop and choose "cut"
- use pcmanfm to go to the usb folder and right-click on it and choose "past"

4. A window with the progress bar will open with an error on it saying "test: Error creating directory: permission denied"

After that the original folder "test" on the desktop disappears, and of course there's no copy on the target folder.
As a consequence you loose your original folder and all data in it.

The original folder is removed while the error window is shown, the removing process doesn't wait for the user to press the close button on that window.

Tested with:
- pcmanfm 0.9.7 on lubuntu 10.10
- pcmanfm 0.9.9 on lubuntu 11.04
- pcmanfm 0.9.9 on ubuntu 11.04

here's the discussion on ubuntuforums:
http://ubuntuforums.org/showthread.php?t=1817738

Related branches

Luca Borrione (luca.borrione) wrote :

Extra comments:

A)
This happens only when trying to cut folders (files work fine).

B)
This happens only when trying to paste them on a destination folder without write permission on an external usb drive (local target folders work fine).

NB:
When I say "it works fine" I mean that, after receiving the message "permission denied" on cut&past as described, the original copy is just kept as expected.

Phill Whiteside (phillw) on 2011-08-05
Changed in pcmanfm (Ubuntu):
status: New → Confirmed

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

This bug is a link to launchpad one:

https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/820865

the bug can be reproduced in opensuse as well. the bug has been fixed upstream and the patch in into X11:lxde/libfm package.

asking for a swamp ID to push the fix in openSUSE 11.3 an 11.4

this bug causes data loss and i believe it's critical.

Reproducible: Always

PCMan (pcman-tw) wrote :

It's fixed upstream. Please test the code in git repo.

patch looks ok. +1

the patch in libfm seems to fix that for me

Changed in pcmanfm (openSUSE):
importance: Unknown → Critical
status: Unknown → Incomplete

The SWAMPID for this issue is 42564.
This issue was rated as important.
Please submit fixed packages until 2011-08-16.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/42564

Yes, it is important. Update started.

Changed in pcmanfm (openSUSE):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 0.1.16-0ubuntu1

---------------
libfm (0.1.16-0ubuntu1) oneiric; urgency=low

  * New upstream release.
   - Fix cut & paste on devices without write permission (LP: #820865)
  * debian/patches:
   - 03_disable_deprecated_gio_module.patch: Refresh.
   - 04_recreate_doc_Makefile.patch: Recreate missing Makefile.am, and adding gtk-doc.make.
   - 04_fix_docs_linker.patch: Refresh.
  * debian/control:
   - Bump package name with soname bump.
   - Create new libfm-data and libgtk-data packages for non library files.
   - Add Conflics & Replaces between *-data and lib*0 packages.
   - Add necessary depends on libfm1 and libfm-gtk1.
  * debian/*.install
   - Bump soname package name.
   - Move non library files to data binary.
   - Don't install documentation, not currently build.
  * debian/*.symbols
   - Rename to follow soname bump.
   - Remove old missing symbols.
   - Update with new symbols.
  * debian/rules:
   - Bump soname of the dbg package.
   - Install apport hook in libfm-data binary.
   - Don't build documentation, currently broken.
 -- Julien Lavergne <email address hidden> Thu, 11 Aug 2011 01:41:00 +0200

Changed in libfm (Ubuntu):
status: New → Fix Released

all has been pushed in update:test and have been accepted

update released

Update released for: libfm, libfm-debuginfo, libfm-debugsource, libfm-devel, libfm-doc, libfm-gtk0, libfm-gtk0-debuginfo, libfm-gtk1, libfm-gtk1-debuginfo, libfm0, libfm0-debuginfo, libfm1, libfm1-debuginfo, pcmanfm, pcmanfm-debuginfo, pcmanfm-debugsource, pcmanfm-lang
Products:
openSUSE 11.4 (debug, i586, x86_64)

Update released for: libfm, libfm-debuginfo, libfm-debugsource, libfm-devel, libfm-doc, libfm-gtk0, libfm-gtk0-debuginfo, libfm-gtk1, libfm-gtk1-debuginfo, libfm0, libfm0-debuginfo, libfm1, libfm1-debuginfo, pcmanfm, pcmanfm-debuginfo, pcmanfm-debugsource, pcmanfm-lang
Products:
openSUSE 11.3 (debug, i586, x86_64)

Changed in pcmanfm (openSUSE):
status: Confirmed → Fix Released
Luca Borrione (luca.borrione) wrote :

this bug is fixed in pcmanfm 0.9.10 on lubuntu 12.04 kernel 3.2.0-24

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libfm (Ubuntu Maverick):
status: New → Confirmed
Changed in libfm (Ubuntu Natty):
status: New → Confirmed
Changed in pcmanfm (Ubuntu Maverick):
status: New → Confirmed
Changed in pcmanfm (Ubuntu Natty):
status: New → Confirmed
karl anliot (kanliot) wrote :

I've read above comment, i promise you it's not fixed.

karl anliot (kanliot) wrote :

sorry allow me to clarify. My bug, which was marked as a duplicate of this bug, is surely not fixed.
https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/1003753

no longer affects: libfm (Ubuntu Maverick)
no longer affects: libfm (Ubuntu Natty)
no longer affects: pcmanfm (Ubuntu Maverick)
no longer affects: pcmanfm (Ubuntu Natty)
no longer affects: pcmanfm (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.