Intel Wireless 5300 AGN: iwlagn: No space for Tx

Bug #352228 reported by Andy Whitcroft on 2009-03-31
392
This bug affects 67 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Christophe
Karmic
Medium
Unassigned
linux (openSUSE)
New
Undecided
Unassigned

Bug Description

I am seeing total wireless failure about once per day. Symptoms are that network manager suddenly drops out and cannot reassociate. I have a number of warnings in dmesg and then the driver keeps reporting 'No space for Tx'. Logs attached.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
MachineType: Dell Inc. Studio 1537
Package: linux-image-2.6.28-11-generic 2.6.28-11.38
ProcCmdLine: root=UUID=cf503727-25f2-4ecd-b0f3-2b894523bcba ro quiet splash crashkernel=384M-2G:64M@16M,2G-:128M@16M
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.37-generic
SourcePackage: linux

Andy Whitcroft (apw) wrote :

Thank you for reporting this issue, it helps make Ubuntu better. Confirmed.

Changed in linux:
status: New → Confirmed

Hi Andy,

The following lkml thread seems related:

http://lkml.org/lkml/2008/12/12/128

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Download full text (14.8 KiB)

Adding some additional info...
This bug is making wireless completely unusable on my laptop. It drops out every 10 minute or often times more frequent., I have to enable the kill switch, wait 5 seconds... most often this doesn't work and I have to repeate the procedure 2-3 times.
It doesn't seem like there has been any more discussions on the linux kernel list ( http://lkml.org/lkml/2008/12/10/143 ), and in .30 it even seems that iwlagn completely stopped working ( http://lkml.org/lkml/2009/4/26/239 ).
Is there any chance of a backport of older kernels' iwlagn driver, where it seems to work better? 8.10 was fine for me.

[23428.560028] iwlagn: index 0 not used in uCode key table.
[23443.867246] iwlagn: Read index for DMA queue txq_id (2) index 165 is out of range [0-256] 188 185
[23449.181688] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23449.680528] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23449.680534] iwlagn: Error setting new RXON (-110)
[23450.180541] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23450.180546] iwlagn: Error setting new RXON (-110)
[23450.680517] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23450.680522] iwlagn: Error setting new RXON (-110)
[23459.680525] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23460.180042] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23460.180046] iwlagn: Error setting new RXON (-110)
[23464.984310] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23464.984315] iwlagn: Error setting new RXON (-110)
[23465.491161] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23465.988518] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23465.988523] iwlagn: Error setting new RXON (-110)
[23466.488527] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23466.988716] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23466.988721] iwlagn: Error setting new RXON (-110)
[23470.992557] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23471.499935] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23471.499944] iwlagn: Error setting new RXON (-110)
[23476.492558] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23476.992531] iwlagn: Error sending REPLY_RXON: time out after 500ms.
[23476.992541] iwlagn: Error setting new RXON (-110)
[23481.992037] iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
[23481.992067] iwlagn: No space for Tx
[23481.992072] iwlagn: Error sending REPLY_RXON: enqueue_hcmd failed: -28
[23481.992077] iwlagn: Error setting new RXON (-28)
[23481.992087] iwlagn: No space for Tx
[23481.992092] iwlagn: Error sending REPLY_TX_POWER_DBM_CMD: enqueue_hcmd failed: -28
[23486.993386] iwlagn: No space for Tx
[23486.993397] iwlagn: Error sending REPLY_SCAN_CMD: enqueue_hcmd failed: -28
[23486.993416] iwlagn: No space for Tx
[23486.993421] iwlagn: Error sending REPLY_RXON: enqueue_hcmd failed: -28
[23486.993426] iwlagn: Error setting new RXON (-28)
[23486.993433] iwlagn: No space for Tx
[23486.993438] iwlagn: Error sending REPLY_TX_POWER_DBM_CMD: enqueue_hcmd failed: -28
[23491.994775] iwlagn: No space for Tx
[23491.994786] iwlagn: Error send...

I've had a couple of similar wireless issues since upgrading to Jaunty. The other day it start refusing to connect to wireless-n at 5GHz but would connect fine to wireless-g at 2.4GHz. I tried a bunch of time. Wireless-g always worked, but Wireless-n failed (just the one green dot on the NM spinner). Similar log entries to yours attached. After a full reboot it starting working fine with wireless-n again.

Jaunty 9.04 with 2.6.28-11 amd64 on a Lenovo X301 (2776).

Been using wireless-n with 8.10 with no similar problems.

tor-henning (tor-henning) wrote :

I experience the same bug on Lenovo X301, but the quick fix except reboot is to disable wireless, then enable it again through the network manager (GUI)

Hopefully a fix for it will apear soon.. :)

Huaxu (huaxu-wan) wrote :

Does anyone could tell me some steps or certain scenarios to reproduce this bug? For example, transmit a bigfile(> 1G) through wifi while copy files from or to USB disk.

I tried everything I can do, but still failed.

JustMe (baselzinga) wrote :

It happens to me when I close the lid on my laptop. The power management settings are set to blank the screen but I guess something more is happening.

Kabe2007 (kabe2007) wrote :

Same for me. I'm using 2.6.28-11-generic.

I never had an issue with Ubuntu 8.10, so if someone can roll back the driver, I'll be happy to try it.

My computer is a Gateway p-7811fx (intel 5100 wireless card). Please let me know if you need more information.

Kabe2007 (kabe2007) wrote :
JustMe (baselzinga) wrote :

I enabled Pre-released updates in the software sources application. Then I installed the package linux-backports- modules-jaunty. The wifi problem seems to have been solved. And I haven't experienced any side effects. I have now disabled the Pre-released updates and hope that all goes well. Maybe this will help others. But I'm just a user trying some stuff and no linux expert so this is all at your own risk.
This also solved another unrelated wifi issue my parents were experiencing.

Kabe2007 (kabe2007) wrote :

SOLVED (FOR ME!!)

I think I solved the bug and I confirm it was related to the wireless card.

I spent some time looking for help and I found that the bug was somewhat common, but difficult to identify given it does not impact wireless directly but gave random errors.

I installed the linux wireless drivers (latest, May 30rd) from

http://wireless.kernel.org/en/users/Download

And the problem was solved!! (so far)

Thanks everybody for the help.

Robbie Williamson (robbiew) wrote :

Seeing this issue on my Lenovo x301 in Karmic Alpha 4 w/latest updates as of 08-26. I end up turning of wireless in Network Manager, doing a 'modprobe -r iwlagn', followed by a 'modprobe iwlagn', and turning wireless back on to resolve it.

Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robbiew 5944 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0620000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211f,00100000'
   Controls : 15
   Simple ctrls : 8
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=e5078b9d-33a9-49ee-b6c2-3a5c3e9096cd
MachineType: LENOVO 2777CTO
Package: linux (not installed)
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-7-generic root=UUID=185050f9-b1be-4215-889f-803f2bacff21 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
RelatedPackageVersions: linux-firmware 1.16
Uname: Linux 2.6.31-7-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 05/15/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6EET41WW (3.01 )
dmi.board.name: 2777CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6EET41WW(3.01):bd05/15/2009:svnLENOVO:pn2777CTO:pvrThinkPadX301:rvnLENOVO:rn2777CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2777CTO
dmi.product.version: ThinkPad X301
dmi.sys.vendor: LENOVO

Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
Robbie Williamson (robbiew) wrote :
tags: added: apport-collected
Cold (maartenlameris) wrote :

Here on a Dell M4400 notebook with the same wireless card and Karmic the same problems

giorgio130 (gm89) wrote :

same problem here. I'm not even able to connect to 5ghz at all, and gat the same droppiness...

Paul Ortyl (ortylp) wrote :

Same here

Thinkpad T500

uname -a
Linux top 2.6.31-10-generic #34-Ubuntu SMP Wed Sep 16 01:09:15 UTC 2009 x86_64 GNU/Linux

iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
iwlagn: Copyright(c) 2003-2009 Intel Corporation
iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:03:00.0: setting latency timer to 64
iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5300AGN REV=0x24
...
iwlagn 0000:03:00.0: Error sending REPLY_TX_POWER_DBM_CMD: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: No space for Tx
iwlagn 0000:03:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: Error setting new RXON (-28)
iwlagn 0000:03:00.0: No space for Tx
iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: No space for Tx
iwlagn 0000:03:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: Error setting new RXON (-28)
iwlagn 0000:03:00.0: No space for Tx
iwlagn 0000:03:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: Error setting new RXON (-28)
iwlagn 0000:03:00.0: No space for Tx
iwlagn 0000:03:00.0: Error sending REPLY_TX_POWER_DBM_CMD: enqueue_hcmd failed: -28
iwlagn 0000:03:00.0: No space for Tx
.... it goes on repeating futher ...

I had the same problem with ubuntu 9.04 (but sligtly different error messages) and then rmmod+modprobe had helped, it did not help this time :(
I confirm also, that 8.10 did not have this problem.

And... it is really annoying.

Kal McFate (kmcfate) wrote :

Also affected on Dell Latitude E6500, kill switch does nothing. Wlan LED continually blinks. Must rmmod/modprobe to fix.

[70890.404939] wlan0: authenticate with AP 00:1c:df:20:3e:b1
[70890.406256] wlan0: authenticated
[70890.406263] wlan0: associate with AP 00:1c:df:20:3e:b1
[70890.407661] wlan0: RX AssocResp from 00:1c:df:20:3e:b1 (capab=0x411 status=0 aid=4)
[70890.407669] wlan0: associated
[70890.413264] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[70901.268255] wlan0: no IPv6 routers present
[70904.540114] iwlagn 0000:0c:00.0: Error sending REPLY_SCAN_ABORT_CMD: time out after 500ms.

Tharrrk (tharrrk) wrote :

Problems with iwlagn on Lenovo R61 too.

2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64 GNU/Linux

[130616.730577] iwlagn 0000:03:00.0: Microcode SW error detected. Restarting 0x82000000.
[130616.754101] iwlagn 0000:03:00.0: No space for Tx
[130616.754111] iwlagn 0000:03:00.0: Error sending SENSITIVITY_CMD: enqueue_hcmd failed: -28
[130616.754117] iwlagn 0000:03:00.0: SENSITIVITY_CMD failed
[130616.960685] Registered led device: iwl-phy0::radio
[130616.960782] Registered led device: iwl-phy0::assoc
[130616.960875] Registered led device: iwl-phy0::RX
[130616.960965] Registered led device: iwl-phy0::TX
[131036.161075] iwlagn 0000:03:00.0: Error sending REPLY_CARD_STATE_CMD: time out after 500ms.
[131037.282270] Registered led device: iwl-phy0::radio
[131037.282369] Registered led device: iwl-phy0::assoc
[131037.282458] Registered led device: iwl-phy0::RX
[131037.282541] Registered led device: iwl-phy0::TX
[131037.913068] iwlagn 0000:03:00.0: Error sending REPLY_CARD_STATE_CMD: time out after 500ms.
[131056.194392] iwlagn 0000:03:00.0: Radio disabled by SW RF Kill switch
[131056.430586] Registered led device: iwl-phy0::radio
[131056.430678] Registered led device: iwl-phy0::assoc
[131056.430766] Registered led device: iwl-phy0::RX
[131056.430851] Registered led device: iwl-phy0::TX
[131057.056534] Registered led device: iwl-phy0::radio
[131057.056579] Registered led device: iwl-phy0::assoc
[131057.056624] Registered led device: iwl-phy0::RX
[131057.056663] Registered led device: iwl-phy0::TX
[131085.701057] iwlagn 0000:03:00.0: Error sending REPLY_CARD_STATE_CMD: time out after 500ms.
[131088.204456] Registered led device: iwl-phy0::radio
[131088.204545] Registered led device: iwl-phy0::assoc
[131088.204632] Registered led device: iwl-phy0::RX
[131088.204716] Registered led device: iwl-phy0::TX

Andy Whitcroft (apw) wrote :

Ok. So this bug is very old and originally reported against Jaunty kernels. As submitter I am no longer seeing these and am happy that the issue seems fixed in the latest karmic kernels. If you are able to reproduce this bug still on the latest Karmic kernels (2.6.31-12.39 or later) please comment here and reopen the linux task. If you are able to reproduce this on the latest Jaunty kernel please also comment here. In all cases please report the exact kernel version and associated dmesg output for the error.

@Tharrrk -- the error messages yo uare seeing do quite seem the same as the original report, so I suspect its a different issue so I recommend a new bug for that.

Changed in linux (Ubuntu Karmic):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Kal McFate (kmcfate) wrote :

Definitely still broken in 2.6.31-12.39
34398.529274] iwlagn 0000:0c:00.0: No space for Tx
[34398.529279] iwlagn 0000:0c:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -28
[34398.529285] iwlagn 0000:0c:00.0: Error setting new RXON (-28)
[34398.529295] iwlagn 0000:0c:00.0: No space for Tx
[34398.529301] iwlagn 0000:0c:00.0: Error sending REPLY_TX_POWER_DBM_CMD: enqueue_hcmd failed: -28
kmcfate@lt001:~$ uname -a
Linux lt001 2.6.31-12-generic #39-Ubuntu SMP Mon Oct 5 21:48:10 UTC 2009 x86_64 GNU/Linux

Paul Ortyl (ortylp) wrote :
Download full text (5.0 KiB)

Still broken on:
Linux top 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:06:40 UTC 2009 x86_64 GNU/Linux
Manufacturer: LENOVO
Product Name: 20827SG
Version: ThinkPad T500

Linux version 2.6.31-11-generic (buildd@yellow) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu4) ) #38-Ubuntu SMP Fri Oct 2
11:06:40 UTC 2009 (Ubuntu 2.6.31-11.38-generic)

[15238.240142] wlan0: no probe response from AP 00:0f:cb:b5:e8:3d - disassociating
[15238.850130] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15238.850140] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15239.351364] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[15239.850130] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15239.850141] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15240.350132] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15240.350143] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15244.850096] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15244.850101] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15245.351302] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[15245.850080] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15245.850092] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15246.350176] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15246.350186] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15250.860143] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15250.860153] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15251.360127] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[15251.860121] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15251.860127] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15252.360149] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15252.360159] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15256.861378] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15256.861389] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15257.360172] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[15257.860155] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15257.860166] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15258.360151] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15258.360162] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15262.860151] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15262.860162] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15263.361405] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
[15263.861378] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15263.861390] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15264.361373] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
[15264.361385] iwlagn 0000:03:00.0: Error setting new RXON (-110)
[15264.361401] iwlagn 0000:03:00.0: No space for Tx
[15264.361407] iwlagn 0000:03:00.0:...

Read more...

Tharrrk (tharrrk) wrote :

Hi there,
  which version of driver and firmware do you have really loaded?
My problems seem to disappear since I clean up /lib/firmware stuff and put the newest firmware into /lib/firmware/`uname -r`
But it's too soon to say it works, it's less then a week.

$ dmesg|grep iwlagn
[ 11.792885] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
[ 11.792888] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[ 11.793038] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 11.793071] iwlagn 0000:03:00.0: setting latency timer to 64
[ 11.793139] iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
[ 11.833299] iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
[ 11.833403] iwlagn 0000:03:00.0: irq 2295 for MSI/MSI-X
[ 40.959931] iwlagn 0000:03:00.0: firmware: requesting lbm-iwlwifi-4965-2.ucode
[ 41.104084] iwlagn 0000:03:00.0: loaded firmware version 228.61.2.24

My card is
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Bem Jones-Bey (ajani) on 2009-10-28
Changed in linux (Ubuntu Karmic):
status: Fix Released → Confirmed
zigi (ziegleka) on 2010-04-25
tags: added: iwlagn kernel-lucid lucid networking
53 comments hidden view all 133 comments
zigi (ziegleka) wrote :
Download full text (26.5 KiB)

Lucid 10.04 beta (RC) - 03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection:

- modprobe -r iwlagn && modprobe iwlagn helps

- /var/log/kern.log:

Apr 18 08:15:01 sweetie kernel: [49026.468672] cfg80211: Found new beacon on frequency: 2467 MHz (Ch 12) on phy0
Apr 18 10:07:09 sweetie kernel: [55754.430065] No probe response from AP 00:13:f7:44:4c:b7 after 500ms, disconnecting.
Apr 18 10:07:10 sweetie kernel: [55755.100122] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:10 sweetie kernel: [55755.100132] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:10 sweetie kernel: [55755.601348] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
Apr 18 10:07:11 sweetie kernel: [55756.100883] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:11 sweetie kernel: [55756.100894] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:11 sweetie kernel: [55756.601307] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:11 sweetie kernel: [55756.601318] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:12 sweetie kernel: [55757.100054] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:12 sweetie kernel: [55757.100064] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:12 sweetie kernel: [55757.601348] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:12 sweetie kernel: [55757.601359] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:12 sweetie kernel: [55757.601368] wlan0: direct probe to AP 00:13:f7:44:4c:b7 (try 1)
Apr 18 10:07:13 sweetie kernel: [55757.800116] wlan0: direct probe to AP 00:13:f7:44:4c:b7 (try 2)
Apr 18 10:07:13 sweetie kernel: [55758.000116] wlan0: direct probe to AP 00:13:f7:44:4c:b7 (try 3)
Apr 18 10:07:13 sweetie kernel: [55758.200132] wlan0: direct probe to AP 00:13:f7:44:4c:b7 timed out
Apr 18 10:07:14 sweetie kernel: [55758.700129] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:14 sweetie kernel: [55758.700139] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:23 sweetie kernel: [55767.610063] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:23 sweetie kernel: [55767.610074] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:23 sweetie kernel: [55768.111309] iwlagn 0000:03:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
Apr 18 10:07:24 sweetie kernel: [55768.611310] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:24 sweetie kernel: [55768.611320] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:24 sweetie kernel: [55769.111309] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:24 sweetie kernel: [55769.111319] iwlagn 0000:03:00.0: Error setting new RXON (-110)
Apr 18 10:07:29 sweetie kernel: [55773.610067] iwlagn 0000:03:00.0: Error sending REPLY_RXON: time out after 500ms.
Apr 18 10:07:29 sweetie kernel: [55773.610077] iwlagn 0000:03:00.0: Error setting new RXON (-110)...

zigi (ziegleka) wrote :

I forgot:

- 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux
- linux-image-2.6.32-21-generic 2.6.32-21.32

Mark M. (earlmagnus) wrote :

Started getting this exact problem on Lucid after migrating to a Thinkpad W500.

tuneable (mjzeeman) wrote :

Update: I have had _no_ issues with WIFI dropouts ever since I followed the advise in post #57, now more than two months ago. Except after each installed update of the linux kernel, but a simple recompilation of the bleeding edge driver set (including a 'make clean') solves it again. Tested on Ubuntu Karmic, using Networkmanager (standard), Intel 5300AGN, Thinkpad x200.

Perhaps this workaround works on other WIFI hardware with similar dropout issues?

Zaphod (vilppu777) wrote :

I just installed the bleeding edge drivers like in #57 all looks good so far. is there a way to tell which version of which driver I am running I would like to see if we can't get someone to include it in time for 10.04

Mark M. (earlmagnus) wrote :

It would seem there is a fix for this more-than-year-old problem. Perhaps it is time for some code to be promoted?

Catscrash (catscrash) wrote :

compiling and using bleeding edge seems to make it even worse for me on R61 with 4965

tuneable (mjzeeman) wrote :

I had hoped these wifi issues would be confined to the Karmic kernels. Now time is pressing to see a sollution for the next LTS release. Please, devs, give this a moment of your time and try to prevent it to be a show-stopper for the LTS. From the Remote bug watches links on this page (particulary https://bugzilla.redhat.com/show_bug.cgi?id=493018#c35) it seems there have been fixes applied to kernels in other distros.

@Zaphod / post #98
The only version info I found is the 'master-tag' file in the 'compat-wireless' bleeding edge package, as 'dmesg | grep iwlagn' only shows 'in tree' as version for the driver. The master-tag on my system contains the text 'next-20100201'.

Robby (robypomper) wrote :

Hi all,
i've the same problem about the connection. I can connect to my network (WPA) but before 5 minutes (or less) it disconnect and dmesg give me the error: "No probe response from AP 00:22:3f:55:ff:fa after 500ms, disconnecting." Now I'm trying to connect without encryption and in the last 20 minutes everything seems good.

My computer is a VAIO-VPCF11V5E whit "Intel WiFi Link 6000 Series (rev 35)" and using the iwlagn drivers.

If need more data, I'm here (if my connection don't go down...).

Thanks for all the support (not only for this bug)!!!

Sorry for my English ( :-) )

Same issue in lucid release. Had this with jaunty, was a major pain and took a long while to rectify. Very sad to see this has not been dealt with in time for Lucid.

timurek (webmaster-timurova) wrote :

The very same problem appeared to me after !!changing my wireless router!! from dlink di-624 (supports b/g) to zyxel NBG417n (b/g/n).
My machine is Lenovo Thinkpad T60, wireless card is reported by lspci as Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02). This card supports only b/g.

Maybe the problem is caused by using b/g card with b/g/n router?

On May 6, 2010, at 13:51, timurek wrote:

> Maybe the problem is caused by using b/g card with b/g/n router?

I have a b/g router and I see the problem regularly, so it's not that. However, it might have something to do with certain router models. I have a Netgear WGR614v8 (WGR614L).

Barış (penguen) wrote :

Not sure if this is the same problem but 5300 is an ultimate-N card
and depending on router software there might be issues in
implementing.

When I changed my router's encryption algorithm from TKIP to AES,
problem I was experiencing --sporadic disconnections from the router--
is resolved.

There is some related information here regarding N and TKIP
http://www.intel.com/support/wireless/wlan/4965agn/sb/CS-025643.htm

On Fri, May 7, 2010 at 1:33 AM, Bem Jones-Bey <email address hidden> wrote:
>
> On May 6, 2010, at 13:51, timurek wrote:
>
>> Maybe the problem is caused by using b/g card with b/g/n router?
>
> I have a b/g router and I see the problem regularly, so it's not that.
> However, it might have something to do with certain router models. I
> have a Netgear WGR614v8 (WGR614L).
>
> --
> Intel Wireless 5300 AGN: iwlagn: No space for Tx
> https://bugs.launchpad.net/bugs/352228
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

narnie (signupnarnie) wrote :

This is by no means a fix, but for me it is a work-around.

When I first wrote this scripts, it wouldn't get the internet up and running when the net went down. I would need to reboot. I just ran it yesterday just to see, and low and behold, my net comes back up without a reboot.

Hope it might help you, too.

#! /bin/bash
#
pkill nm-app
sudo modprobe -v -r iwlagn
sudo modprobe -v iwlagn
nm-applet &

Save that (I called mine reset_wireless). Make it excecutable with chmod +x reset_wireless (or whatever you called it). Then either put it in an executable path found by typing echo $PATH or just run it with ./reset_wireless (or, again, whatever you called it).

Yours,
Narnie

ps, if you don't want to get nm-applet output in your terminal, change it to:

#! /bin/bash
#
pkill nm-app
sudo modprobe -v -r iwlagn
sudo modprobe -v iwlagn
nm-applet &> /dev/null &

Bem Jones-Bey (ajani) wrote :

I changed my settings from TKIP to AES, and while it seems like it has reduced the incidence of the problem, it has happened once since.

On May 7, 2010, at 6:48, Barış wrote:

> Not sure if this is the same problem but 5300 is an ultimate-N card
> and depending on router software there might be issues in
> implementing.
>
> When I changed my router's encryption algorithm from TKIP to AES,
> problem I was experiencing --sporadic disconnections from the router--
> is resolved.
>
> There is some related information here regarding N and TKIP
> http://www.intel.com/support/wireless/wlan/4965agn/sb/CS-025643.htm
>
> On Fri, May 7, 2010 at 1:33 AM, Bem Jones-Bey <email address hidden> wrote:
>>
>> On May 6, 2010, at 13:51, timurek wrote:
>>
>>> Maybe the problem is caused by using b/g card with b/g/n router?
>>
>> I have a b/g router and I see the problem regularly, so it's not that.
>> However, it might have something to do with certain router models. I
>> have a Netgear WGR614v8 (WGR614L).
>>
>> --
>> Intel Wireless 5300 AGN: iwlagn: No space for Tx
>> https://bugs.launchpad.net/bugs/352228
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>>
>
> --
> Intel Wireless 5300 AGN: iwlagn: No space for Tx
> https://bugs.launchpad.net/bugs/352228
> You received this bug notification because you are a direct subscriber
> of the bug.
>

tags: added: kernel-net
removed: kernel-lucid networking
narnie (signupnarnie) wrote :

Well, scratch the above in my last post.

It worked for a few days, then I was back to having to reboot.

Decided to do a little more messing around after it did it last night and this morning, too (sure wish I could figure out what triggers it!).

This script brought it back when the other one I posted above didn't.

Here ya go.

#! /bin/bash
#
pkill nm-app
sudo modprobe -v -r iwlagn
sudo /etc/init.d/network-manager stop
sudo /etc/init.d/network-interface stop
sudo /etc/init.d/networking stop
sudo /etc/init.d/networking start
sudo /etc/init.d/network-interface start
sudo /etc/init.d/network-manager start
sudo modprobe -v iwlagn
nm-applet &

just save it (I called my reset_wireless).

run

chmod +x reset_wireless

Then put it in one of the dirs found by

echo $PATH

and you should be good to go. You have to have admin privies for it to work.

Cherio,
Narnie

narnie (signupnarnie) wrote :

Reset wireless script to prevent having to reboot you machine.

Krzysztof Janowicz (janowicz) wrote :

any solution? i have this bug since such a long time and since 10.04 even on both notebooks :(. it was fixed already like 2 or 3 years ago (as far as i remember in a backport fix for 8.04). i am working with a similar script as narnie but that is a ugly solution because you still lose the connection and hence e.g. a skype connection during a call...

narnie (signupnarnie) wrote :

I'm not very hopefull this will get fixed. I've been watching another thread (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/348204) that is much more devastating than this one from another piece of hardware I owned. Ubuntu hasn't fixed that one either even tho most will classify it as critical as no large data can be moved without breaking it. Ubuntu seems to have "better things to do" than fix our wireless problems (even tho they may even be the ones introducing them as the other threads problem doesn't exist upstream in Debian. It is a "patch" that Ubuntu applied to the kernel that broke it.

I agree though, my script is no good as a fix, esp when lost during a needed connection (skype, download, etc).

Narnie

Krzysztof Janowicz (janowicz) wrote :

@narnie: imho, the ubuntu team is doing a wonderful job. as we cannot fix this on our own, our job is to assist them in finding the bug and showing that it affects many people on many notebooks (especially dells (?)).

bnight (bnight) wrote :

After install this http://linuxwireless.org/en/users/Download#Where_to_download_bleeding_edge

It`s seem that this issue is gone.

But this is not a great solution after all.

Hope that someone will fix this.

This is what I wrote a long time ago and after that i don`t have any problems with Wifi at all. Works pretty great I am surprised that this driver is not included in Ubuntu 10.04. Because i am still with Ubuntu 9.10 and works great. Hope it will work for you too.

narnie (signupnarnie) wrote :

I agree with Krzysztof Janowicz that Ubuntu is doing incredible work, and those of us who benefit from it are greatful. They have given so much FREELY!!! I'm not ungrateful. I just want Ubuntu to continue to succeed.

That said . . .

Laptops/netbooks are the fasting growing segment now in computers. Wireless capability is one of the big reasons for this so people don't have to be tied down. And netbooks are just that for the NET!!! When they can't connect, people will go to other distros that DO work or will just turn back to WIndows, which is sad !!!

It seems that Ubuntu has moved on to other things and is forgetting the basics. Who cares about Eucalyptus, virtualization, etc, if you can't get a reliable internet connection?

Here is Ubuntu's track record for me:

1)Acer Aspire 5610 with essentially completely broken wireless since 9.04 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/348204)

narnie (signupnarnie) wrote :

rats, hehe

2) Toshiba Satellite A505-S6965 that we are dealing with in this bug report. It is working better than the 3945 chipset, but is still broken even though there is a fix.
3) I have 4 Aspire Ones. The first three use broadcom b43 drivers that read these netbooks wrong even with Ubuntu Netbook Remix 9.10 and Ubuntu Netbook Edition 10.04. This is one of the most popular netbooks around, yet they won't even boot without doing a lot of rooting around to fix it (ok with me, but most people who are newbies wouldn't be able to do it). Here is a forum on where I helped get a guy going with this (http://ubuntuforums.org/showthread.php?t=1477490). The newer Aspire One has an atheros chipset. It DID work fine "out of the box."

So, here is my wireless track record over the last 2 years with Ubuntu.

1/6 laptops/netbooks working (really to be fair, 1/4 because 3 were the same).

That is terrible statistics for Ubuntu. I am a solid linux user and have been for 12 years (I started back in the days of Caldera). For the past few years, I'm 98% Linux only (when these Ipods break, I'll buy linux-capable units from now on and I'll be 100% except for homeschooling things that I can't get working with wine). I will do whatever it takes to get my boxes working with Ubuntu/Mint whenever possible, but I'm dedicated. Newbies won't be. They will just go back to Windows, which is sad.

Ubuntu needs to get wireless right. That should be a priority, esp with the netbook edition.

Narnie

Jonathan Lange (jml) wrote :

I think I'm getting this bug (although I'm told that kernel bugs with similar symptoms are often very different). http://static.mumak.net/syslog-from-disconnect.log has the syslog.

As another poster commented, https://bugzilla.redhat.com/show_bug.cgi?id=493018 looks similar, and claims to be fixed.

If someone's willing to do a little bit of hand-holding, I'd be happy to test this on my laptop.

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Changed in linux (Ubuntu Karmic):
assignee: Andy Whitcroft (apw) → nobody
Phil Ayres (ayres-phil) wrote :

I've just experienced this bug for what I believe is the first time. The syslog from the first entry that shows a problem is included below. I have the cheaper and nastier Intel 5100 card and had previously fixed most of my wifi problems by disabling ipv6 at boot (see my response to bug https://bugs.launchpad.net/debian/+bug/548992 ). Unfortunately this bug seems to occur when I make a Skype call for any length of time - not high bandwidth (5kbps), just extended constant activity.

To get stuff started again, I right click on the Network Manager icon, disable networking, then re-enable.

My details:
Kernel 2.6.32-22-generic
Ubuntu 10.04
arch: i686
modinfo iwlagn |grep version
version: 1.3.27k
srcversion: 9B8B8B62434B92B6793FD7A
vermagic: 2.6.32-22-generic SMP mod_unload modversions 586

Jun 29 13:13:45 consected-sv1-001 kernel: [521435.940078] iwlagn 0000:02:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
Jun 29 13:13:47 consected-sv1-001 kernel: [521438.436578] No probe response from AP 00:14:6c:1b:93:2e after 500ms, disconnecting.
Jun 29 13:13:47 consected-sv1-001 wpa_supplicant[1154]: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Jun 29 13:13:48 consected-sv1-001 NetworkManager: <info> (wlan0): supplicant connection state: completed -> disconnected
Jun 29 13:13:48 consected-sv1-001 NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning
Jun 29 13:13:48 consected-sv1-001 kernel: [521439.052126] iwlagn 0000:02:00.0: Error sending REPLY_RXON: time out after 500ms.
Jun 29 13:13:48 consected-sv1-001 kernel: [521439.052137] iwlagn 0000:02:00.0: Error setting new RXON (-110)
Jun 29 13:13:49 consected-sv1-001 wpa_supplicant[1154]: Trying to associate with 00:14:6c:1b:93:2e (SSID='homeoffice2a' freq=2462 MHz)
Jun 29 13:13:49 consected-sv1-001 NetworkManager: <info> (wlan0): supplicant connection state: scanning -> associating
Jun 29 13:13:49 consected-sv1-001 kernel: [521439.548029] iwlagn 0000:02:00.0: Error sending REPLY_SCAN_CMD: time out after 500ms.
Jun 29 13:13:49 consected-sv1-001 kernel: [521440.049587] iwlagn 0000:02:00.0: Error sending REPLY_RXON: time out after 500ms.
Jun 29 13:13:49 consected-sv1-001 kernel: [521440.049598] iwlagn 0000:02:00.0: Error setting new RXON (-110)
Jun 29 13:13:50 consected-sv1-001 kernel: [521440.548104] iwlagn 0000:02:00.0: Error sending REPLY_RXON: time out after 500ms.
Jun 29 13:13:50 consected-sv1-001 kernel: [521440.548119] iwlagn 0000:02:00.0: Error setting new RXON (-110)
Jun 29 13:13:50 consected-sv1-001 kernel: [521441.052103] iwlagn 0000:02:00.0: Error sending REPLY_RXON: time out after 500ms.
Jun 29 13:13:50 consected-sv1-001 kernel: [521441.052116] iwlagn 0000:02:00.0: Error setting new RXON (-110)

Phil Ayres (ayres-phil) wrote :

I just saw something odd happen that may be related. I was using Skype and it started to see lost incoming packets, which is normally a sign for me that I'm about to lose the wireless connection. Today it held on by its fingernails and suddenly kicked back in. dmesg showed:

[ 5182.259875] iwlagn 0000:02:00.0: Microcode SW error detected. Restarting 0x2000000.
[ 5182.308719] Registered led device: iwl-phy0::radio
[ 5182.308784] Registered led device: iwl-phy0::assoc
[ 5182.308840] Registered led device: iwl-phy0::RX
[ 5182.308899] Registered led device: iwl-phy0::TX

This looks nasty, although I'm impressed that I didn't lose the connection completely. I'll keep monitoring.

David Roberts (david.roberts) wrote :

I've been experiencing the same issue intermittently on a Lenovo ThinkPad R500, and the frequency seems to have increased to approximately once a day since upgrading to Ubuntu 10.04. Stopping and starting the network-manager service (service network-manager stop && sleep && service network-manager start) seems to fix the problem. Relevant lspci output is below, and dmesg output attached.

03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
 Subsystem: Intel Corporation Device 1211
 Flags: bus master, fast devsel, latency 0, IRQ 30
 Memory at f4300000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: <access denied>
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

sl0n (momonth) wrote :

Looks like I've just encountered the bug for the first time. I have dell latitude E4300 for about 3 months now and never experienced smth like that.

I'm using D-Link DIR-635 at home and this morning I've changed wireless settings: "Cipher Type" from "TKIP & AES" to "TKIP" only. I believe this action has triggered the bug. I read the thread and found some users mentioned "TKIP/AES" problem, I changed it back to "TKIP & AES" and it's working ok for a about an hour now.

Details:

# uname -a
Linux dell 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

# lspci -v -s 0c:00.0
0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
 Subsystem: Intel Corporation Device 1321
 Flags: bus master, fast devsel, latency 0, IRQ 30
 Memory at f69fe000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: [c8] Power Management version 3
 Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
 Capabilities: [e0] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 38-20-95-ff-ff-d6-24-00
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

# modinfo iwlagn
filename: /lib/modules/2.6.32-24-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
alias: iwl4965
license: GPL
author: Copyright(c) 2003-2009 Intel Corporation <email address hidden>
version: 1.3.27k
description: Intel(R) Wireless WiFi Link AGN driver for Linux
firmware: iwlwifi-4965-2.ucode
firmware: iwlwifi-5150-2.ucode
firmware: iwlwifi-5000-2.ucode
firmware: iwlwifi-6050-4.ucode
firmware: iwlwifi-6000-4.ucode
...

Bem Jones-Bey (ajani) wrote :

I can confirm that for me, using TKIP causes the problem. Sadly, I had to switch back to TKIP from AES, since my router's performance with AES is abysmal.

On Jul 31, 2010 11:11, sl0n &lt;<email address hidden>&gt; wrote:

Looks like I've just encountered the bug for the first time. I have dell

latitude E4300 for about 3 months now and never experienced smth like

that.

I'm using D-Link DIR-635 at home and this morning I've changed wireless

settings: "Cipher Type" from "TKIP &amp; AES" to "TKIP" only. I believe this

action has triggered the bug. I read the thread and found some users

mentioned "TKIP/AES" problem, I changed it back to "TKIP &amp; AES" and it's

working ok for a about an hour now.

Details:

# uname -a

Linux dell 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

# lsb_release -a

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 10.04.1 LTS

Release: 10.04

Codename: lucid

# lspci -v -s 0c:00.0

0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100

 Subsystem: Intel Corporation Device 1321

 Flags: bus master, fast devsel, latency 0, IRQ 30

 Memory at f69fe000 (64-bit, non-prefetchable) [size=8K]

 Capabilities: [c8] Power Management version 3

 Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+

 Capabilities: [e0] Express Endpoint, MSI 00

 Capabilities: [100] Advanced Error Reporting &lt;?&gt;

 Capabilities: [140] Device Serial Number 38-20-95-ff-ff-d6-24-00

 Kernel driver in use: iwlagn

 Kernel modules: iwlagn

# modinfo iwlagn

filename: /lib/modules/2.6.32-24-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko

alias: iwl4965

license: GPL

author: Copyright(c) 2003-2009 Intel Corporation &lt;<email address hidden>&gt;

version: 1.3.27k

description: Intel(R) Wireless WiFi Link AGN driver for Linux

firmware: iwlwifi-4965-2.ucode

firmware: iwlwifi-5150-2.ucode

firmware: iwlwifi-5000-2.ucode

firmware: iwlwifi-6050-4.ucode

firmware: iwlwifi-6000-4.ucode

...

--

Intel Wireless 5300 AGN: iwlagn: No space for Tx

https://bugs.launchpad.net/bugs/352228

You received this bug notification because you are a direct subscriber

of the bug.

rick beldin (rick-beldin) wrote :

Seeing this on a HP Elitebook 6930p with 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010 i686 GNU/Linux.

If I had to guess, this has something to do with suspend/resume activity. I've never seen it at first boot.

Zaphod (vilppu777) wrote :

This has been pretty much solved for me but I am running the latest bleeding edge drivers from intel.

I'm experiencing the same problem.

I have a Dell Precision M4400 from about 1 year, lspci displays this info about my wifi card:

0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100

I never experienced this type of errors till yesterday when I've changed the wifi router.
Now I have a LINKSYS WRT160N-EZ. Before this one I've used a DLINK DSL 624 GT and a Sitecom WL 127.
The difference betwen the Linksys and the other ones is that the linksys support the N protocol. I have disabled it in the wireless config and as wrote here http://ubuntuforums.org/showthread.php?t=1239871:

options iwlagn 11n_disable=1 11n_disable50=1
in /etc/modprobe.d/options.conf

Now I'm waiting for see if it is a valid solution.

Download full text (139.5 KiB)

Also having this problem on my two laptops.

Router used in this configuration: Dlink DIR-655 with updated firmware. Any mode will allow the problem to be reproduced (WPA / WEP / None, B/G/N or only B/G).

HP (Pavilion) HDX-18, with Intel 5100 or 5300 WiFi card - Usually happens when the computer is getting hot. Had to install Win 7 in a dualboot to fix the problem, but that is not an permanent solution. Ubuntu Linux 10.04 LTS and Maverick Beta is having the issue.

HP nc6400 - with 3945 Intel WiFi card. Same story, but this beeing a smaller computer does not have the same heat issues. Currently trying Linux Mint 9 on this one to see if it makes a difference, but this is from the 6400:

Sep 7 18:30:10 gameboy rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="950" x-info="http://www.rsyslog.com"] rsyslogd was HUPed, type 'lightweight'.
Sep 7 18:30:16 gameboy anacron[1323]: Job `cron.daily' terminated
Sep 7 18:30:16 gameboy anacron[1323]: Normal exit (1 job run)
Sep 7 18:33:30 gameboy sudo: pam_sm_authenticate: Called
Sep 7 18:33:30 gameboy sudo: pam_sm_authenticate: username = [melfacion]
Sep 7 19:17:01 gameboy CRON[2748]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 7 19:31:03 gameboy gnome-screensaver-dialog: pam_sm_authenticate: Called
Sep 7 19:31:03 gameboy gnome-screensaver-dialog: pam_sm_authenticate: username = [melfacion]
Sep 7 19:40:03 gameboy pulseaudio[1752]: ratelimit.c: 2 events suppressed
Sep 7 19:42:12 gameboy kernel: [ 5309.358183] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Sep 7 20:17:01 gameboy CRON[3054]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 7 20:39:45 gameboy gnome-screensaver-dialog: pam_sm_authenticate: Called
Sep 7 20:39:45 gameboy gnome-screensaver-dialog: pam_sm_authenticate: username = [melfacion]
Sep 7 21:17:01 gameboy CRON[3291]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 7 21:26:31 gameboy gnome-screensaver-dialog: pam_sm_authenticate: Called
Sep 7 21:26:31 gameboy gnome-screensaver-dialog: pam_sm_authenticate: username = [melfacion]
Sep 7 22:17:01 gameboy CRON[3535]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 7 23:04:20 gameboy anacron[4006]: Anacron 2.3 started on 2010-09-07
Sep 7 23:04:20 gameboy anacron[4006]: Normal exit (0 jobs run)
Sep 7 23:17:01 gameboy CRON[4085]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 8 00:17:01 gameboy CRON[4602]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Sep 8 00:56:39 gameboy sudo: pam_sm_authenticate: Called
Sep 8 00:56:39 gameboy sudo: pam_sm_authenticate: username = [melfacion]
Sep 8 01:08:31 gameboy kernel: [24888.500073] No probe response from AP 00:22:b0:b4:00:1e after 500ms, disconnecting.
Sep 8 01:08:31 gameboy wpa_supplicant[988]: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Sep 8 01:08:31 gameboy NetworkManager: <info> (wlan0): supplicant connection state: completed -> disconnected
Sep 8 01:08:31 gameboy NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning
Sep 8 01:08:32 gameboy kernel: [24889.121034] iwl3945 00...

The changes about modprobe options and on the router config i wrote yesterday didn't help.

I've tried to compile the latest compat-wireless drivers taken from here http://linuxwireless.org/en/users/Download#Where_to_download_bleeding_edge, but when I try to load the new compiled module:

[29674.709301] iwlagn 0000:0c:00.0: PCI INT A disabled
[29686.978111] cfg80211: Calling CRDA to update world regulatory domain
[29687.118162] cfg80211: World regulatory domain updated:
[29687.118170] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[29687.118178] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[29687.118185] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[29687.118192] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[29687.118199] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[29687.118205] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[29687.119911] iwlcore: disagrees about version of symbol ieee80211_start_tx_ba_cb_irqsafe
[29687.119919] iwlcore: Unknown symbol ieee80211_start_tx_ba_cb_irqsafe
[29687.120808] iwlcore: disagrees about version of symbol ieee80211_alloc_hw
[29687.120814] iwlcore: Unknown symbol ieee80211_alloc_hw
[29687.121045] iwlcore: disagrees about version of symbol ieee80211_register_hw
[29687.121051] iwlcore: Unknown symbol ieee80211_register_hw
[29687.121676] iwlcore: disagrees about version of symbol __ieee80211_get_radio_led_name

I'm a little bit desperate :-(

dvhart (darren-dvhart) wrote :

I had similar problems with a 5300 in a ThinkPad T400 on Lucid. After trying the latest linuxwireless backports and then a 2.6.36-rc4+compat-wireless, I would see errors like:

[34400.190021] iwlagn 0000:03:00.0: Failing on timeout while stopping DMA channel 1 [0xa5a5a5a0]
[34400.190021] iwlagn 0000:03:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x080003D8
[34400.190021] iwlagn 0000:03:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0x080003D8

After talking with the Intel wireless developers and trying everything possible with module parameters and bios settings, this turned out to be a hardware problem. I tried my harddrive in an identical T400 and it worked. Consider calling Lenovo.

Krzysztof Janowicz (janowicz) wrote :

the reconnect bug is there again. every time I change from one wireless network to another there is a big chance that I will have to reboot my machine before it will connect....

Wojtek (wojtek-fedorko) wrote :

Hi,
I have this problem in debian squeeze.
I tried the the two versions of the firmware available - the same. modprobe -r iwlagn; modprobe iwlagn sometimes works - sometimes hangs the machine entirely.
How do I get the bleeding edge driver mentioned in posts above?
Thanks,
w

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix

This bug was nominated against a series that is no longer supported, ie karmic. The bug task representing the karmic nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Karmic):
status: Confirmed → Won't Fix
Displaying first 40 and last 40 comments. View all 133 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.