guestmount installation not mentioned

Bug #1028365 reported by Marco CONSONNI on 2012-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Book
Undecided
koolhead17
devstack
Undecided
Unassigned
openstack-manuals
Medium
Tom Fifield

Bug Description

I was playing with my openstack installation I made following this manual http://docs.openstack.org/essex/openstack-compute/starter/content/.

When I tried to launch an instance with a keypair I found out that nova-compute complains because it can't run module "guestmount".

As this module is not automatically installed by Ubuntu 12.04 LTS, I think you need to install that manually with command:

$ apt-get install guestmount

These instructions should be reported on any manual regarding installation on Ubuntu (don't know if RH and Fedora suffer the same problem).

BTW: also devStack installation has this problem. Do you think I should report the problem to those guys? If yes, where is their lanchpad?

Anne Gentle (annegentle) wrote :

Hi Marco -
Thanks for reporting. I have added it to openstackbook (the bug tracking for the Starter Guide) and the devstack project on Launchpad (it's devstack).

Anne

koolhead17 (koolhead17) wrote :

@Marco

Can you tell me more about your installation envirnment setup.

Changed in openstackbook:
assignee: nobody → koolhead17 (koolhead17)
Marco CONSONNI (marco-consonni) wrote :

This is the configuration.

Two nodes running under VirtualBox therefore they use qemu, not KVM.

FlatDHCP is the networking configuration.

One node plays two roles: controller and compute node.
It runs the following daemons:

- glance-registry
- glance-api
- keystone-all
- mysqld
- rabbitmq (all the daemons)
- nova (all the daemons)

The other node plays compute role running the following daemons:

- nova-api
- nova-network
- nova-compute
- nova-volume

Both the nodes use 3 NICs (they are virtual because the nodes run under VirtualBox, as I said at the very beginning).

- eth0 is used for fixed IP addresses
- eth1 is used for floating IP adresses
- eth2 is used for administration / control purposes (daemons communicate using this eth)

Do you need more info?
Let me know.

More information.

I personally installed Ubuntu 12.04 and used devstack for installing OpenStack.
I noticed that neither devstack nor the documentation mention that you need guestmount but when I tried to launch an image with key injection, I found out that it failed.
I looked into the log file and noticed an error saying that guestmount couldn't be run.
So I tried the same command manually and found out that guestmount was not installed.

At that point I installed guestmount manually, restarted the image with key injection and I faced another minor problem (I didn't mentioned that because I was thinking was not important).

The problem was related to nbd that need to be loaded. I found out that you can do that by calling command "sudo modprobe nbd" and you have to do that whenever you reboot the network node.

koolhead17 (koolhead17) wrote :

@Marco

I don`t see this as a potential bug.
Our documentation clearly uses KVM, in that case one will not require guestmount.
But i will add a line in the document adding you need to have guestmount if you want to try it on qemu.

Hope my explaination solves the issue. I am marking it as invalid.

Cheers!!

Changed in openstackbook:
status: New → Invalid
koolhead17 (koolhead17) wrote :

Also just poked Zul he suggested " if nbd fails, it will try using guestmount and if libguestfs is not installed then it will just fail"

Marco CONSONNI (marco-consonni) wrote :

Fine!
I agree, thanks!

Tom Fifield (fifieldt) wrote :

apt-get install guestmount
yum install guestmount (check this is the correct package name for RHEL/Centos/Fedora)

could be added to:

http://docs.openstack.org/essex/openstack-compute/admin/content/qemu.html

http://docs.openstack.org/essex/openstack-compute/install/apt/content/qemu.html

Changed in openstack-manuals:
status: New → Triaged
importance: Undecided → Medium
Tom Fifield (fifieldt) wrote :

fedora <= 16 : libguestfs-mount
fedora >= 16: libguestfs-tools

--http://rpmfind.net/linux/rpm2html/search.php?query=%2Fusr%2Fbin%2Fguestmount

Tom Fifield (fifieldt) on 2012-07-28
Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/10456
Committed: http://github.com/openstack/openstack-manuals/commit/0b863983ae0566213f32d662b3835fa3c4308c0f
Submitter: Jenkins
Branch: master

commit 0b863983ae0566213f32d662b3835fa3c4308c0f
Author: Tom Fifield <email address hidden>
Date: Sat Jul 28 22:01:40 2012 +0800

    Adds instructions to install guestmount for QEMU

    fixes bug 1028365

    QEMU requires guestmount to perform some operations. This patch adds
    installation instructions for the package under ubuntu at fedora etc

    Change-Id: Iecaaca6b373e7e9c70ddcff8749e62d488df7494

Changed in openstack-manuals:
status: In Progress → Fix Released
Tom Fifield (fifieldt) on 2012-09-29
Changed in devstack:
status: New → Confirmed
Dean Troyer (dtroyer) on 2014-09-19
Changed in devstack:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers