OpenStack Book for Ubuntu

Swift testing fails in opencompute starter guide

Reported by Sebastien on 2012-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Book
High
Yogesh Girikumar

Bug Description

After executing installation steps of the starter guide down to "testing swift" http://docs.openstack.org/essex/openstack-compute/starter/content/Testing_Swift-d2s762.html it seems to have a configuration issue with swift and/or the proxy-server component.

In the webpage comments, at least 6 people (including myself) reported having zero containers or zero objects listed when running the command "swift -v -V 2.0 -A http://127.0.0.1:5000/v2.0/ -U service:swift -K swift stat", while one is expected.

It's also impossible to create containers through the Dashboard.

If it can help, I'm available to conduct guided investigations next week (Monday and Tuesday at GMT+2) on the infrastructure I'm using to deploy OpenStack.

Tom Fifield (fifieldt) on 2012-06-22
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → High
Anne Gentle (annegentle) wrote :

Hi Tom, Thanks for logging. I'm moving this bug to the openstackbook project, where the source resides, and I've talked to Atul Jha, who is going to check with the owner of this content.

Hi Atul - here's a good description of the doc bug I mentioned related to Swift configuration.

affects: openstack-manuals → openstackbook
Sebastien (tuzisan) on 2012-06-23
description: updated
Changed in openstackbook:
assignee: nobody → Eternal Tyro (eternaltyro)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers