ERROR: Package 'oslo.i18n' requirement does not match number of lines (3) in openstack/requirements

Bug #1880265 reported by Takashi Natsume on 2020-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Global Requirements
New
Undecided
Takashi Natsume
python-novaclient
Undecided
Takashi Natsume

Bug Description

https://728fadb40dcd00d381dd-595cfa47540877e41ce912cd21563e42.ssl.cf5.rackcdn.com/723139/4/check/requirements-check/e57ea83/job-output.txt

2020-05-23 02:46:37.035400 | TASK [Run requirements check script]
2020-05-23 02:46:37.981250 | ubuntu-bionic | sys.version_info(major=3, minor=6, micro=9, releaselevel='final', serial=0)
2020-05-23 02:46:37.981346 | ubuntu-bionic | selecting default requirements directory for normal mode
2020-05-23 02:46:37.981367 | ubuntu-bionic | Branch: master
2020-05-23 02:46:37.981382 | ubuntu-bionic | Source: src/opendev.org/openstack/python-novaclient
2020-05-23 02:46:37.981399 | ubuntu-bionic | Requirements: /home/zuul/src/opendev.org/openstack/requirements
2020-05-23 02:46:37.981434 | ubuntu-bionic | git log -n 1 --format=%H
2020-05-23 02:46:37.981461 | ubuntu-bionic | Patch under test: f2823eb2e7e19a1e3a6722c9978a1bab7edce23b
2020-05-23 02:46:37.981478 | ubuntu-bionic | Checking f2823eb2e7e19a1e3a6722c9978a1bab7edce23b
2020-05-23 02:46:37.981492 | ubuntu-bionic | Processing requirements.txt
2020-05-23 02:46:37.981505 | ubuntu-bionic | Processing test-requirements.txt
2020-05-23 02:46:37.981518 | ubuntu-bionic | Processing doc/requirements.txt
2020-05-23 02:46:37.981531 | ubuntu-bionic | Validating requirements.txt
2020-05-23 02:46:37.981544 | ubuntu-bionic | WARNING: possible mismatch found for package "oslo.i18n"
2020-05-23 02:46:37.981556 | ubuntu-bionic | Attribute "markers" does not match
2020-05-23 02:46:37.981569 | ubuntu-bionic | "" does not match "python_version<'3.6'"
2020-05-23 02:46:37.981583 | ubuntu-bionic | Requirement(package='oslo.i18n', location='', specifiers='>=3.15.3', markers='', comment='# Apache-2.0', extras=frozenset())
2020-05-23 02:46:37.981600 | ubuntu-bionic | Requirement(package='oslo.i18n', location='', specifiers='<4.0.0', markers="python_version<'3.6'", comment='# Apache-2.0', extras=frozenset())
2020-05-23 02:46:37.981621 | ubuntu-bionic | ERROR: Package 'oslo.i18n' requirement does not match number of lines (3) in openstack/requirements
2020-05-23 02:46:37.981636 | ubuntu-bionic | WARNING (probably OK for Ussuri and later): Package 'oslo.utils' is only tracking python 3 requirements
2020-05-23 02:46:37.981649 | ubuntu-bionic | Validating test-requirements.txt
2020-05-23 02:46:37.981661 | ubuntu-bionic | Validating doc/requirements.txt
2020-05-23 02:46:37.981674 | ubuntu-bionic | WARNING (probably OK for Ussuri and later): Package 'reno' is only tracking python 3 requirements
2020-05-23 02:46:37.981688 | ubuntu-bionic | Validating lower constraints of requirements.txt
2020-05-23 02:46:37.981701 | ubuntu-bionic | Validating lower constraints of test-requirements.txt
2020-05-23 02:46:37.981713 | ubuntu-bionic | *** Incompatible requirement found!
2020-05-23 02:46:37.981727 | ubuntu-bionic | *** See https://docs.openstack.org/requirements/latest/
2020-05-23 02:46:38.137201 | ubuntu-bionic | ERROR

The following change causes this error.

https://review.opendev.org/#/c/730148/

Changed in openstack-requirements:
assignee: nobody → Takashi Natsume (natsume-takashi)
Changed in python-novaclient:
status: New → Won't Fix

This bug should be fixed in openstack/requirements project.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers