PBR 2.0.0 will break projects not using constraints

Bug #1668848 reported by Tony Breeds on 2017-03-01
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
OpenStack Global Requirements
Fix Released
High
Unassigned
castellan
Undecided
Jeremy Liu
cloudkitty
Undecided
Jeremy Liu
python-barbicanclient
Fix Released
Undecided
Jeremy Liu
tacker
High
yong sheng gong

Bug Description

Any project not using constraints will see ContextualVersionConflict: (pbr 2.0.0.*) errors if they also use any library that has a defensive cap on pbr. So far that list is:

 sqlalchemy-migrate, yaql, requestsexceptions, pypowervm and jsonpath-rw-ext

but there may be others.

Tony Breeds (o-tony) on 2017-03-01
Changed in openstack-requirements:
status: New → Confirmed
importance: Undecided → High
Changed in tacker:
assignee: nobody → yong sheng gong (gongysh)
importance: Undecided → High
milestone: none → pike-1

Fix proposed to branch: master
Review: https://review.openstack.org/441572

Changed in tacker:
status: New → In Progress
Jeremy Liu (liujiong) on 2017-03-04
Changed in cloudkitty:
assignee: nobody → Jeremy Liu (liujiong)
status: New → In Progress
Changed in python-barbicanclient:
assignee: nobody → Jeremy Liu (liujiong)
status: New → In Progress
Changed in castellan:
assignee: nobody → Jeremy Liu (liujiong)
status: New → In Progress

Reviewed: https://review.openstack.org/441572
Committed: https://git.openstack.org/cgit/openstack/tacker/commit/?id=13f4ff41d1d185509e33f74cd7fa8b2e41d72b82
Submitter: Jenkins
Branch: master

commit 13f4ff41d1d185509e33f74cd7fa8b2e41d72b82
Author: gong yong sheng <gong.yongsheng@99cloud.net>
Date: Sat Mar 4 13:14:38 2017 +0800

    Sync test-requirements with global requirements

    In this patch, a tool is provided for team to do the sync to avoid
    any gaps with global requirements.

    Change-Id: Ie960eae7a2756aa0f267c8ad37ea60f5effe6742
    Partial-bug: 1668848

Change abandoned by Rico Lin (<email address hidden>) on branch: master
Review: https://review.openstack.org/440470

Change abandoned by Rico Lin (<email address hidden>) on branch: master
Review: https://review.openstack.org/440472

Changed in tacker:
status: In Progress → Fix Committed
Jeremy Liu (liujiong) on 2017-03-08
Changed in cloudkitty:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/440231
Committed: https://git.openstack.org/cgit/openstack/castellan/commit/?id=a076657518b70deda12ec8c7e82504629d7e0c48
Submitter: Jenkins
Branch: master

commit a076657518b70deda12ec8c7e82504629d7e0c48
Author: Jeremy Liu <email address hidden>
Date: Thu Mar 2 17:04:26 2017 +0800

    Fix gate failure on pep8

    update test-requirements to match global requirements.

    Change-Id: Ic0d551db6235f4f27fece011132dbf5f1ead44e8
    Partial-Bug: #1668848

Reviewed: https://review.openstack.org/440234
Committed: https://git.openstack.org/cgit/openstack/python-barbicanclient/commit/?id=4ad8cfcd83383c5f59eeac4687c765d6d9b01690
Submitter: Jenkins
Branch: master

commit 4ad8cfcd83383c5f59eeac4687c765d6d9b01690
Author: Jeremy Liu <email address hidden>
Date: Thu Mar 2 17:07:10 2017 +0800

    Fix gate failure on pep8

    update test-requirements to match global requirements.

    Change-Id: I2b6c6dfc4ca5cf614319524bc1dad30b6b0a052c
    Partial-Bug: #1668848

Jeremy Liu (liujiong) on 2017-03-10
Changed in python-barbicanclient:
status: In Progress → Fix Committed
Changed in castellan:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/440586
Committed: https://git.openstack.org/cgit/openstack/cloudkitty/commit/?id=45e2ccfdfdc6650fe2b13be6dd6d10273be4580d
Submitter: Jenkins
Branch: master

commit 45e2ccfdfdc6650fe2b13be6dd6d10273be4580d
Author: ricolin <email address hidden>
Date: Thu Mar 2 22:18:58 2017 +0800

    [Fix gate]Update test requirement

    Since pbr already landed and the old version of hacking seems not
    work very well with pbr>=2, we should update it to match global
    requirement.
    Partial-Bug: #1668848

    Change-Id: I1db16aa57df507352986f199260e2ba9e92e4605

Jeremy Liu (liujiong) on 2017-05-18
Changed in castellan:
status: Fix Committed → Fix Released
Matthew Thode (prometheanfire) wrote :

I think this is fixed in most places, just waiting on a couple of projects to make pike releases.

Changed in openstack-requirements:
status: Confirmed → Fix Released
Jeremy Liu (liujiong) on 2017-08-11
Changed in python-barbicanclient:
status: Fix Committed → Fix Released
Changed in tacker:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers