get_instance_type don't handle exception.InstanceTypeNotFound

Reported by Nachi Ueno on 2011-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Maru Newby
OpenStack Quality Assurance
Fix Released
Medium
Unassigned

Bug Description

get_instance_type and get_default_instance_type in instance_types.py don't handle exception.InstanceTypeNotFound.
This exception must be handled and then this class should produce APIError.

Thierry Carrez (ttx) on 2011-10-13
Changed in nova:
importance: Undecided → Low
status: New → Confirmed
Nachi Ueno (nati-ueno) on 2011-10-20
Changed in nova:
assignee: nobody → Nachi Ueno (nati-ueno)
Changed in openstack-qa:
assignee: nobody → Nachi Ueno (nati-ueno)
status: New → In Progress
importance: Undecided → Medium
Changed in nova:
status: Confirmed → In Progress
Nachi Ueno (nati-ueno) on 2011-11-17
Changed in nova:
assignee: Nachi Ueno (nati-ueno) → nobody
Changed in openstack-qa:
assignee: Nachi Ueno (nati-ueno) → nobody
Ken Pepple (ken-pepple) on 2011-12-15
Changed in nova:
assignee: nobody → Ken Pepple (ken-pepple)
Maru Newby (maru) on 2011-12-16
Changed in nova:
assignee: Ken Pepple (ken-pepple) → Maru Newby (maru)
Thierry Carrez (ttx) wrote :

Obviously not in progress, unassigning so that someone else can have a shot at it.

Changed in nova:
assignee: Maru Newby (maru) → nobody
status: In Progress → Confirmed
Maru Newby (maru) on 2012-02-02
Changed in nova:
assignee: nobody → Maru Newby (maru)

Fix proposed to branch: master
Review: https://review.openstack.org/3706

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3706
Committed: http://github.com/openstack/nova/commit/07d74aa916ee2798f717ae5d298f8ca51e883770
Submitter: Jenkins
Branch: master

commit 07d74aa916ee2798f717ae5d298f8ca51e883770
Author: Maru Newby <email address hidden>
Date: Thu Feb 2 12:52:10 2012 -0800

    Raise ApiError in response to InstanceTypeNotFound

     * Updates methods in nova.compute.instance_types to catch
       InstanceTypeNotFound exceptions and re-raise them as ApiError.
       - Previously, the methods in instance_types were raising ApiError in
         response to DBError, but the underlying db calls have since been
         updated to detect empty results and throw more specific exceptions.
     * Updates get_instance_type_by_flavor_id to not try to catch DBError,
       as the underlying db call only ever raises FlavorNotFound.
       get_instance_type_by_flavor_id should not raise ApiError, as callers
       expect the FlavorNotFound exception and know how to handle it.
     * Fixes bug 872618

    Change-Id: I8652f04889adb448017afd253ecdcc840fbb660f

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in nova:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-4 → 2012.1
Nachi Ueno (nati-ueno) on 2013-09-25
Changed in openstack-qa:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers