nova.compute.manager calls methods in nova.volume.manager directly

Reported by Nachi Ueno on 2011-10-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Vish Ishaya
OpenStack Quality Assurance
Fix Released
Medium
Unassigned

Bug Description

nova.compute.manager calls methods in nova.volume.manager directly.
This must be via api module.

146: self.volume_manager = utils.import_object(FLAGS.volume_manager)
1230: dev_path = self.volume_manager.setup_compute_volume(context, volume_id)
1241: dev_path = self.volume_manager.setup_compute_volume(context,
1267: self.volume_manager.remove_compute_volume(context,
1289: self.volume_manager.remove_compute_volume(context, volume_id)
1306: self.volume_manager.remove_compute_volume(context, volume_id)
1401: self.volume_manager.setup_compute_volume(context, v['id'])
1511: self.volume_manager.remove_compute_volume(ctxt, vol['id'])

Nachi Ueno (nati-ueno) on 2011-10-11
Changed in openstack-qa:
milestone: none → essex-1
Nirmal Ranganathan (rnirmal) wrote :

I think this just got merged in by Vishy in one of his volume cleanup branches

>Nirmal Ranganathan
Thanks
I confirmed it is merged to Essex branch.
But I think it is also needed for Diablo Stable Branch.

https://github.com/openstack/nova/blob/2011.3/nova/compute/manager.py

Nirmal Ranganathan (rnirmal) wrote :

Ok cool.. yeah not sure what all was going to get backported to Diablo.

On Wed, Oct 12, 2011 at 3:09 PM, Nachi Ueno <email address hidden>wrote:

> >Nirmal Ranganathan
> Thanks
> I confirmed it is merged to Essex branch.
> But I think it is also needed for Diablo Stable Branch.
>
> https://github.com/openstack/nova/blob/2011.3/nova/compute/manager.py
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/872445
>
> Title:
> nova.compute.manager calls methods in nova.volume.manager directly
>
> Status in OpenStack Compute (Nova):
> New
> Status in OpenStack QA:
> New
>
> Bug description:
> nova.compute.manager calls methods in nova.volume.manager directly.
> This must be via api module.
>
> 146: self.volume_manager =
> utils.import_object(FLAGS.volume_manager)
> 1230: dev_path = self.volume_manager.setup_compute_volume(context,
> volume_id)
> 1241: dev_path = self.volume_manager.setup_compute_volume(context,
> 1267: self.volume_manager.remove_compute_volume(context,
> 1289: self.volume_manager.remove_compute_volume(context, volume_id)
> 1306: self.volume_manager.remove_compute_volume(context, volume_id)
> 1401: self.volume_manager.setup_compute_volume(context,
> v['id'])
> 1511: self.volume_manager.remove_compute_volume(ctxt,
> vol['id'])
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nova/+bug/872445/+subscriptions
>

Thierry Carrez (ttx) on 2011-10-13
Changed in nova:
status: New → Fix Committed
Nachi Ueno (nati-ueno) on 2011-10-20
Changed in openstack-qa:
status: New → In Progress
assignee: nobody → Nachi Ueno (nati-ueno)
importance: Undecided → Low
importance: Low → Medium
Thierry Carrez (ttx) on 2011-11-09
Changed in nova:
milestone: none → essex-1
Thierry Carrez (ttx) on 2011-11-17
Changed in nova:
status: Fix Committed → Fix Released
Nachi Ueno (nati-ueno) on 2011-11-17
Changed in openstack-qa:
assignee: Nachi Ueno (nati-ueno) → nobody
tags: added: diablo-backport
Mark McLoughlin (markmc) on 2012-04-03
Changed in nova:
assignee: nobody → Vish Ishaya (vishvananda)
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-1 → 2012.1
Nachi Ueno (nati-ueno) on 2013-09-25
Changed in openstack-qa:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints