Server error when updating contacts

Bug #1317957 reported by Doug Chivers on 2014-05-09
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
openstack-org
Critical
Jimmy McArthur

Bug Description

I am trying to contribute, but get the following error:
"git review
fatal: ICLA contributor agreement requires current contact information.

Please review your contact information:

  https://review.openstack.org/#/settings/contact"

I have my email address set on both the launchpad and foundation site, with my office address set in the foundation site. When I try and add my office address to the launchpad site, I get the following error in the browser:

"Code Review - Error
Server Error
Cannot store contact information"

See attached.

Doug Chivers (doug-chivers) wrote :
Anita Kuno (anteaya) on 2014-05-09
Changed in openstack-ci:
status: New → Confirmed
Jeremy Stanley (fungi) wrote :

Gerrit is currently unable to submit contact details to the Foundation Member System (it's logging a 403 Forbidden error from the http://www.openstack.org/verify/member/ API endpoint). Assistance from the sysadmins for the Foundation Member System has been requested via E-mail.

Changed in openstack-ci:
importance: Undecided → Critical
milestone: none → icehouse
status: Confirmed → Triaged
assignee: nobody → Jeremy Stanley (fungi)
affects: openstack-ci → openstack-org
Changed in openstack-org:
milestone: icehouse → none
assignee: Jeremy Stanley (fungi) → nobody
status: Triaged → New
Anne Gentle (annegentle) on 2014-05-09
Changed in openstack-org:
status: New → Confirmed
Jeremy Stanley (fungi) wrote :

Following the addition of a new CDN for www.openstack.org (where the Foundation member system is hosted), it became apparent that its security measures inadvertently identified our Gerrit server as a threat and began automatically blocking its access to that API endpont. With the assistance of the admins for that system, whitelist entries for our Gerrit server's IP addresses have been added along with anti-caching rules and some other features which should hopefully mitigate this problem going forward.

Changed in openstack-org:
assignee: nobody → Todd Morey (toddmorey)
status: Confirmed → Fix Released
Stefano Maffulli (smaffulli) wrote :

This problem is still happening. Please check it again, it's urgent. Thanks.

Changed in openstack-org:
status: Fix Released → Confirmed
assignee: Todd Morey (toddmorey) → Jimmy McArthur (jimmy-l)
Jp Maxwell (jpmaxman-o) wrote :

I adjusted the page rule for this URL ( http://www.openstack.org/verify/member/ )to bypass the CDN. If this is insufficient we should either have the server itself go direct to the IP or adjust the DNS back to go direct to the IP: 174.143.194.225

If there is another URL besides the one above that needs to be cleared please let me know.

Attached is a screen cap of the page rule settings.

Stefano Maffulli (smaffulli) wrote :

Jonathan just texted me that he changed DNS record for www.openstack.org to remove cloudflare.

Jp Maxwell (jpmaxman-o) wrote :

Sorry that IP is incorrect should be: 98.129.229.210

I also just checked the DNS and the A record for www.openstack.org was adjusted to go direct to this IP. Let me know if this doesn't solve the problem.

Mohammed Naser (mnaser) wrote :

I work at an CloudFlare optimized hosting partner so I'm very familiar with their infrastructure and worked with them personally. The 403's usually have an HTML page describing the exact issue, so if CloudFlare feels the requests were rogue, it would say something along those lines.

By default, CloudFlare does not cache any HTML pages at all, which means the above rule isn't directly useful unless there are others that force caching of HTML pages.

http://blog.cloudflare.com/cloudflare-threat-control-making-your-website

That feature should be used to whitelist services which have caused problems. In addition, I would make sure that the origin server is configuring with X-Forwarded-IP translation or otherwise it will see requests mostly coming from the same set of IP addresses.

https://support.cloudflare.com/hc/en-us/articles/200170706-Does-CloudFlare-have-an-IP-module-for-Nginx-
https://github.com/cloudflare/mod_cloudflare

CloudFlare does proxy back all type of HTTP responses so the behaviour might have been the web server rate limiting because of large amount of requests coming from the same IP address.

As an optimized hosting partner, we provide the Railgun (https://www.cloudflare.com/railgun) dynamic content acceleration feature for no extra cost to our customers. If you would like, we can provide some servers which will allow you to use Railgun for no cost and extra website speed to the foundation at no cost.

Hmmm I don't know if this is just me but I am getting the same error today. I assume more people is affected too as we are in the middle of OpenStack conference in Atlanta and few people might want to register themselvs.

Lorcan Browne (lorcan-browne) wrote :

I am also seeing this error. Is there any work-around to update contact information without using this process?

Jimmy McArthur (jimmy-l) wrote :

If this is still occurring, it's not because of CloudFlare as we're not currently utilizing the service. Can you provide additional details about what you're seeing?

Lorcan Browne (lorcan-browne) wrote :

When I try and update my contact information, I'm seeing the exact same error that Doug has attached in his comment (#1). There doesn't seem to be any other problems with updating information as I have registered a new email address and added a new ssh public key in the past few hours. Are there any other details in particular that you'd like me to provide that may be helpfull?

Can you confirm that this is the URL where you're updating your contact information: https://review.openstack.org/#/settings/contact

Thank you!

Jimmy McArthur / tipit.net <email address hidden>
o: 512.481.1161
m: 512.965.4846
----- Original Message -----
> From: "Lorcan Browne" <email address hidden>
> To: <email address hidden>
> Sent: Wednesday, May 14, 2014 11:38:30 AM
> Subject: [Bug 1317957] Re: Server error when updating contacts
>
> When I try and update my contact information, I'm seeing the exact same
> error that Doug has attached in his comment (#1). There doesn't seem to
> be any other problems with updating information as I have registered a
> new email address and added a new ssh public key in the past few hours.
> Are there any other details in particular that you'd like me to provide
> that may be helpfull?
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: Openstack dot org
> https://bugs.launchpad.net/bugs/1317957
>
> Title:
> Server error when updating contacts
>
> Status in OpenStack dot org website:
> Confirmed
>
> Bug description:
> I am trying to contribute, but get the following error:
> "git review
> fatal: ICLA contributor agreement requires current contact information.
>
> Please review your contact information:
>
> https://review.openstack.org/#/settings/contact"
>
> I have my email address set on both the launchpad and foundation site,
> with my office address set in the foundation site. When I try and add
> my office address to the launchpad site, I get the following error in
> the browser:
>
> "Code Review - Error
> Server Error
> Cannot store contact information"
>
> See attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openstack-org/+bug/1317957/+subscriptions
>

Lorcan Browne (lorcan-browne) wrote :

Yes - that is the same URL that I am using.

Jimmy McArthur (jimmy-l) wrote :

Radoslaw, can you confirm that you also updated your email address
recently?

Radoslaw Smigielski wrote:
> Hmmm I don't know if this is just me but I am getting the same error
> today. I assume more people is affected too as we are in the middle of
> OpenStack conference in Atlanta and few people might want to register
> themselvs.
>

--
Jimmy McArthur / Tipit.net <http://Tipit.net>< <email address hidden>
<mailto:<email address hidden>>>
m: 512.965.4846
o: 512.481.1161

Stefano Maffulli (smaffulli) wrote :

Are you guys members of the OpenStack Foundation? the error is the same if you have not created an account on https://www.openstack.org/profile/

Also, the same error appears if you have an account on https://www.openstack.org/profile/ *but* you created it to respond to User Survey or as speakers at the Summit.

Jimmy: can you please check that they are registered on openstack.org and their level of membership there?

Jimmy McArthur (jimmy-l) wrote :

Looks like neither are members of the Foundation. However, Lorcan
indicated that he just updated his email address, so I noticed a
secondary issue.

If you change the email address of your OpenStack Foundation Profile
and/or use a different address on Gerrit, it won't see that you're a
Foundation Member. That /verify/member page is returning different
errors. Can we get Launchpad to pass the appropriate error code (or some
friendly version of it) for better tracking in the future?

Like in my instance, I already had an associated account, but simply
changing the email address, which should be a valid action, destroyed
the relationship with my Gerrit account.

I realize we're also taking steps to remedy this via SSO, but would be
good to at least help us track down issues more quickly if we had a bit
more info logged.

Thanks,
Jimmy

Stefano Maffulli wrote:
> Are you guys members of the OpenStack Foundation? the error is the same
> if you have not created an account on https://www.openstack.org/profile/
>
> Also, the same error appears if you have an account on
> https://www.openstack.org/profile/ *but* you created it to respond to
> User Survey or as speakers at the Summit.
>
> Jimmy: can you please check that they are registered on openstack.org
> and their level of membership there?
>

--
Jimmy McArthur / Tipit.net <http://Tipit.net>< <email address hidden>
<mailto:<email address hidden>>>
m: 512.965.4846
o: 512.481.1161

Lorcan Browne (lorcan-browne) wrote :

I registered as a member of the foundation a few minutes ago and retried adding contact information successfully! I'm not sure if this is a result of signing up or if you guys did something in the meantime - either way, thanks very much for the assistance!

So here is the screenshot what I see in my browser and I tried in many different browsers on two different desktops to make sure it's not only issue related to my browser or pc.

I tried register second email address just for testing but looks like I haven't got the confirmation email.

Sorry, I should check the spam folder first. I got the verification email for the second email address but still contact details update fails with the same error I post a screenshot in previus comment.

Stefano Maffulli (smaffulli) wrote :

Radoslaw: hop on IRC #openstack-infra and we'll take care of you. I'm @reed

Lorcan; you have to have an account as OpenStack Foundation Member, storing *the same* email address on gerrit and on openstack.org/profile otherwise gerrit doesn't have a way to match your openid account (launchpad id) and the foundation's.

Jimmy: we're solving this problem with our openid, this problem doesn't happen too often to justify changes now.

Changed in openstack-org:
status: Confirmed → Invalid
status: Invalid → Fix Released
Ramesh Sahu (ramesh-sahu-o) wrote :

Hi Stefano: Is this bug fixed.
Still I am facing the issue.Not able to update the contact information.
Error:
Code Review - Error
Server Error
Cannot store contact information
(screenshot attached)

Stefano Maffulli (smaffulli) wrote :

Ramesh the bug is fixed but you may be experiencing something else. Did you subscribe as a member of OpenStack Foundation on https://www.openstack.org/join/register/? or do you have another sort of account on https://openstack.org/profile, not as an Individual Member of the Foundation?

Jimmy McArthur (jimmy-l) wrote :

Ramesh, I don't currently see you as a member of the Foundation or as a registered user. As Stefano said you should go to https://www.openstack.org/join/register/ and complete the registration form there. Once you complete your registration using the same email address you're using for Gerrit, you should be in good shape.

----- Original Message -----
> From: "Stefano Maffulli" <email address hidden>
> To: <email address hidden>
> Sent: Tuesday, May 27, 2014 1:43:32 PM
> Subject: [Bug 1317957] Re: Server error when updating contacts
>
> Ramesh the bug is fixed but you may be experiencing something else. Did
> you subscribe as a member of OpenStack Foundation on
> https://www.openstack.org/join/register/? or do you have another sort of
> account on https://openstack.org/profile, not as an Individual Member of
> the Foundation?
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: Openstack dot org
> https://bugs.launchpad.net/bugs/1317957
>
> Title:
> Server error when updating contacts
>
> Status in OpenStack dot org website:
> Fix Released
>
> Bug description:
> I am trying to contribute, but get the following error:
> "git review
> fatal: ICLA contributor agreement requires current contact information.
>
> Please review your contact information:
>
> https://review.openstack.org/#/settings/contact"
>
> I have my email address set on both the launchpad and foundation site,
> with my office address set in the foundation site. When I try and add
> my office address to the launchpad site, I get the following error in
> the browser:
>
> "Code Review - Error
> Server Error
> Cannot store contact information"
>
> See attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openstack-org/+bug/1317957/+subscriptions
>

Alexandr (alexandr-alexandrov) wrote :

Hi, I have the same issue. I have signed ICLA, my company has signed CCLA (with my name inside the list) and is a Corporate sponsor of Openstack. Do I still need to fullfil individual membership to proceed?

David Mahony (david-mahony) wrote :

Alexandr, you will still need to agree to the ICLA https://wiki.openstack.org/wiki/How_To_Contribute

Alexandr (alexandr-alexandrov) wrote :

Hi David,
indeed ICLA had been signed by me before the discussed issue was observed.
So, I just wonder do I really need to have additionally individual Openstack Foundation Membership if my company has Corporate sponsorship?

Chris Ricker (chris-ricker) wrote :

Alexandr, you do have to have done the individual also even if your company also has done corporate

Ajaya Agrawal (ajayaa) wrote :

I am signing the ICLA for the first time. Even I am getting such an error.

Tom Fifield (fifieldt) on 2014-05-30
Changed in openstack-org:
status: Fix Released → Confirmed
Jimmy McArthur (jimmy-l) wrote :

Alexandr, Ajaya (and anyone else still getting this error), please email me directly via the address on my launchpad account to make sure you are OpenStack Foundation Members, which is a requirement for Gerrit.

If you know you're not a member, please go here: https://www.openstack.org/join/register/ and complete the registration and then try again.

Ajaya Agrawal (ajayaa) wrote :

Thanks Jimmy.

Changed in openstack-org:
status: Confirmed → Fix Released
Can Zhang (acme-ican) wrote :

The problem still happens when I apply for ICLA

Amit Kumar Das (amit-das-8) wrote :

I get below error while trying to update my contact information.

Code Review - Error
Server Error
Cannot store contact information

Amit Kumar Das (amit-das-8) wrote :

I had to register at https://www.openstack.org/join/register/ site

& then updated my contact details at https://review.openstack.org/#/settings/contact.

The contact info was updated successfully.

Stefano Maffulli (smaffulli) wrote :

@acme-ican: make sure you are following *to the letter* every single step described on https://wiki.openstack.org/wiki/How_To_Contribute#Contributor_License_Agreement. Every single step, you cannot skip one.

If you still have problems please provide your openstack.org ID. Make sure that you are using the same email address as main email address on openstack.org and on review.openstack.org.

Philip Cheong (philip-cheong) wrote :

Looks like this is the same problem I am hitting. First encountered the issue trying update my contact information when signing the ICLA contributor agreement. Thankfully I learned you don't need complete contact details to sign the agreement at least, but this problem is still here.

Stefano Maffulli (smaffulli) wrote :

Philip: most likely your email address of your Foundation Membership Profile is not the same E-mail used as the Preferred Email in your Gerrit contact information.

You have to follow the instructions on https://wiki.openstack.org/wiki/How_To_Contribute#Contributor_License_Agreement *exactly* as they're written or things will break. It's complicated, I know, we're working to make this simpler.

Jun Hong Li (junhongl) wrote :

Stefano: I hit this problem as well.

When I submitted my review, it tells me I need to accept the legal agreement and give me this link:
https://review.openstack.org/#/settings/agreements

I added ICLA, and agreed it. Then I tried to resubmit again, it tells me: ICLA contributor agreement requires current contact information, and give me this link:
https://review.openstack.org/#/settings/contact

I tried to upload my contact, then it fails in the following error:
Code Review - Error
Server Error
Cannot store contact information

I've already registered an account in https://www.openstack.org/join/register/ and make sure the ID in review.openstack.org is identical with the ID in launchpad and openstack org.

BTW, I checked my profile in https://openstack.org/profile, it shows that I didn't have any legal agreement over there. I'm not sure whether that's the cause for my problem. If it is the cause, how can I update it? I didn't find any link to update the legal agreement for openstack profile.

and my id is <email address hidden>, could you please help to take a look? Thank you!

Tom Fifield (fifieldt) wrote :

Is your email address <email address hidden> in both https://openstack.org/profile and
https://review.openstack.org/#/settings/contact ?

Jun Hong Li (junhongl) wrote :

@fifieldt: I double confirm, the email address in both sites are identical, both are <email address hidden>.

Tom Fifield (fifieldt) wrote :

Thanks Jun Hong. This will need to wait for USA colleagues to wake up, I'm afraid.

ICLA had been signed by me, and I faced this problem yesterday. Today still no luck.

Jimmy McArthur (jimmy-l) wrote :

@junhongl - While you do have a Speaker account on OpenStack.org, you are not a full Foundation Member. If you agree in writing, on this ticket, to the legal details outlined here (https://www.openstack.org/join/register/), I can go ahead and upgrade your membership.

@dominik-dobruchowski - I show that you are a Foundation Member with your @intel address. Is that the same address you're using to edit/register your Gerrit account?

More generally, we are working on a smoother upgrade path for users of openstack.org that were registered as Speakers or other groups, and never completed the Foundation Membership. I'll update this ticket once we've completed that task.

Thank you,
Jimmy

Jun Hong Li (junhongl) wrote :

@jimmy-l, I agree to the legal details in https://www.openstack.org/join/register/, thank you for going ahead and upgrade my membership. If there are any additional steps I need to do, please tell me. Thank you!

Jimmy McArthur (jimmy-l) wrote :

@junhongl You are now set as a Foundation Member. Please let me know if you have any additional questions or concerns.

Thank you,
Jimmy

Jun Hong Li (junhongl) wrote :

@jimmy-l, thank you so much for your quick response! I've already submitted my first patch review successfully, great!

Martin Hickey (martin-hickey) wrote :

Hi,

I am trying to commit code for review but get the error also:

"git review
fatal: ICLA contributor agreement requires current contact information.

Please review your contact information:

  https://review.openstack.org/#/settings/contact"

I have my email address set on both the launchpad, foundation and review sites, as the same address.

When I try and set my contact details on review, I get the following error:

"Code Review - Error
Server Error
Cannot store contact information"

Jimmy McArthur (jimmy-l) wrote :

Martin,

I'm showing that while you do have an account on OpenStack.org, you're not set up as a Foundation Member. If you can agree in writing on this ticket to the legal details outlined on https://www.openstack.org/join/register/, I will manually add you to the Foundation Member user group. You should be good to go after that :)

Thanks!
Jimmy

Martin Hickey (martin-hickey) wrote :

@jimmy-l, I agree to the legal details in https://www.openstack.org/join/register/. Go ahead and upgrade my membership. If there are any additional steps I need to do, please tell me. Thank you!

Jimmy McArthur (jimmy-l) wrote :

Martin,

You're good to go now. You should now be able to commit code. Please let us know if you have further problems.

Thanks!
Jimmy

Martin Hickey (martin-hickey) wrote :

@jimmy-l, thanks for sorting this. I am not able to commit my changes for review.

Hi, I am having the same issue while trying to do a git-review. And I already am registry on Foundation, with the same e-mail. My id is aysyd. Can you help me?

Jimmy McArthur (jimmy-l) wrote :

@martin-hickey - I've confirmed you are a Foundation Member. If you're not able to commit changes, one of the other members of the Gerrit/Infra team will have to jump in as I'm not able to see that side.

@aysyd - I've confirmed you are registered in the datbase, but not as a Foundation Member. If you confirm, in writing, that you agree to the terms on this page (https://www.openstack.org/join/register), I can manually complete your membership.

jimmy-l, I agree to the legal details in https://www.openstack.org/join/register/. Please upgrade my membership. Thank you!

Jimmy McArthur (jimmy-l) wrote :

@aysyd - You're now officially a Foundation Member. Let us know if that worked for you.

Thanks!
Jimmy

Martin Hickey (martin-hickey) wrote :

@jimmy-l, sorry it was a typo! It meant to say that I can now commit changes. Thanks.

@jimmy-l, thanks! worked!

Dave Walker (davewalker) wrote :

I agree to the terms stated on https://www.openstack.org/join/register,
I want to register as an Individual Member of the OpenStack Foundation

Stefano Maffulli (smaffulli) wrote :

@davewalker: I made you an individual member of the Foundation. If you login in your profile you'll see new panels and you'll be able to change the contact information in gerrit, if needed.

Patrick Cable (5-pc) wrote :

I am running into this as well.

I agree to the terms stated on https://www.openstack.org/join/register, I want to register as an Individual Member of the OpenStack Foundation

I agree to the terms stated on https://www.openstack.org/join/register, I want to register as an Individual Member of the OpenStack Foundation

Jimmy McArthur (jimmy-l) wrote :

@michaeltchapman - I actually already see three Michael Chapmans in the database, both of whom are already Foundation Members. Do you happen to have an @cisco.com address or an @anu.edu.au address that you might have already created an account under? If not, no problem, I'll get you set up under the address associated with your Launchpad account. If you'd like me to combine one of these accounts, go ahead and email me directly at the address listed with my launchpad account and I'll help you get straightened out.

@5-pc, I'm showing that you're already set as a Foundation Member and your Gerrit ID is associated with your Foundation Account. Can you double check and then paste the exact error you're getting? This might need to be looked at from the Gerrit side.

Thanks to you both!
Jimmy

Tom Fifield (fifieldt) wrote :

Jimmy - I'm aware that Michael Chapman was previously at ANU and CISCO, but has moved on to Aptira

Stefano Maffulli (smaffulli) wrote :

I took care of 5-pc already, thanks Jimmy.

On 11/25/2014 06:09 PM, Jimmy McArthur wrote:
> @michaeltchapman - I actually already see three Michael Chapmans in the
> database, both of whom are already Foundation Members. Do you happen to
> have an @cisco.com address or an @anu.edu.au address that you might have
> already created an account under? If not, no problem, I'll get you set
> up under the address associated with your Launchpad account. If you'd
> like me to combine one of these accounts, go ahead and email me directly
> at the address listed with my launchpad account and I'll help you get
> straightened out.
>
> @5-pc, I'm showing that you're already set as a Foundation Member and
> your Gerrit ID is associated with your Foundation Account. Can you
> double check and then paste the exact error you're getting? This might
> need to be looked at from the Gerrit side.
>
> Thanks to you both!
> Jimmy
>

--
OpenStack Evangelist - Community
Ask and answer questions on https://ask.openstack.org

Jimmy McArthur (jimmy-l) wrote :

Thanks Stef & Tom!

@michaeltchapman - I'm not sure if you recently updated, but I do now see an account using your Gmail address and GerritID that is also a Foundation Member. Let me know if you'd like me to delete the other two accounts.

Thank you,
Jimmy

As I agreed with @smaffulli, I agree to the terms stated on https://www.openstack.org/join/register, I want to register as an Individual Member of the OpenStack Foundation.

Jimmy McArthur (jimmy-l) wrote :

Jesse,

You are already registered as a Foundation member under a different email address. Can you try with the address jesse.pretorius@r********.co.**? If you're able to log into that account, let me know. Otherwise, I'll switch your old primary address with your current and you should be good to go.

Thank you,
Jimmy McArthur

Jimmy McArthur (jimmy-l) wrote :

Hi all. Just wanted to post that we finally have a permanent resolution for this issue. Any user that has an account on the site can now change their membership status to Foundation Member by pushing the button on their user profile (http://www.screencast.com/t/CeM1uCPako) and agreeing to the terms. Thanks for your patience on this, and hopefully this will end some frustration about the process.

Coming soon... the ability to merge duplicate accounts.

Cheers!
Jimmy

Changed in openstack-org:
status: Fix Released → Fix Committed
Abel Lopez (al592b) wrote :

I'm hitting this issue right now, I've verified that I've entered my contact information, address, phone, etc

Abel Lopez (al592b) wrote :

Sorry, my mistake, wrong gerrit remote on my end.

Changed in openstack-org:
status: Fix Committed → Fix Released
lskrocki (lskrocki) wrote :

I'm also running into the same bug. I'd prefer to use my @cisco.com address for both. I used my @gmail.com address for my foundation registration originally.

Brian Bowen (brbowen) wrote :

I am getting the same issue, I am a Current Member Level: Foundation Member.

Please help

Stefano Maffulli (smaffulli) wrote :

@brbowen: please make sure you try to solve this issue by following all the suggestions listed above first. Follow the instructions *as they appear* on the guide: http://docs.openstack.org/infra/manual/developers.html#account-setup, especially where it says "When signing up for Foundation Membership, make sure to give the same email address you’ll use for code contributions, since this will need to match your preferred email address in Gerrit."

If things still fail, please go on IRC, #openstack-infra to get help. https://wiki.openstack.org/wiki/IRC

Brian Bowen (brbowen) wrote :

To resolve my issue I had to add my address to profile

Vk (vickie-c) wrote :

I'm running same issue right now.
And I can not edit profile, system will return message "Code Review - Error Server Error Cannot store contact information"
Any ideas?
-------------------------------------------git ERROR----------------------------------------------------
fatal: ICLA contributor agreement requires current contact information.

Please review your contact information:
  https://review.openstack.org/#/settings/contact

fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
-------------------------------------------------------------------------------------------------------------

Vk (vickie-c) wrote :

This problem have been solved. Thanks.

stasis (rafael-galarza) wrote :

I am currently experiencing the same as Vk(2015-07-15, #76)

Maxime Belanger (mbelanger) wrote :

I am currently experiencing the same as well.....

Jeremy Stanley (fungi) wrote :

To all the "me too"-ers, please see https://ask.openstack.org/question/56720 and also closely review the account setup steps documented at http://docs.openstack.org/infra/manual/developers.html#account-setup since this error almost always indicates you've skipped something during account creation.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers