Not detecting network drivers by default in "Example: Microsoft Windows image" in Virtual Machine Image Guide

Bug #1719815 reported by R on 2017-09-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Onkar Dandekar

Bug Description

This bug tracker is for errors with the documentation, use the following as a template and remove or add fields as you see fit. Convert [ ] into [x] to check boxes:

- [x] This doc is inaccurate in this way: In step 3 "Enable the VirtIO drivers", the document says that the "E:\virtio-win-0.1XX\viostor\w7\amd64" needs to be selected and later the drivers for virtio scsi and network drivers get detected. This makes it seem like by choosing "E:\virtio-win-0.1XX\viostor\w7\amd64" both, the virtio scsi and network drivers will be detected. I have checked with different ISO images of windows (10, 8.1and server 12) and only the virtio scsi driver gets detected, while the network drivers do not appear. To detect the network drivers, first the virtio scsi drivers need to be selected and loaded from "E:\virtio-win-0.1XX\viostor\w7\amd64", and then "E:\NETKVM\win10\amd64" needs to be selected and loaded by again going to "Load drivers" button (The network driver's path given is assuming windows 10 is being loaded). The compute node which I am trying this on was installed as per instructions given here (https://docs.openstack.org/mitaka/install-guide-ubuntu/).

It would help if an additional sub-step is provided describing how to load the network drivers.

- [ ] This is a doc addition request.
- [ ] I have a fix to the document that I can paste below including example: input and output.

If you have a troubleshooting or support issue, use the following resources:

 - Ask OpenStack: http://ask.openstack.org
 - The mailing list: http://lists.openstack.org
 - IRC: 'openstack' channel on Freenode

-----------------------------------
Release: on 2017-09-27 02:20
SHA: 8fad9fe9972355265979528ac472fbe5f686a037
Source: https://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/source/windows-image.rst
URL: https://docs.openstack.org/image-guide/windows-image.html

Changed in openstack-manuals:
status: New → Won't Fix
status: Won't Fix → New

Hi there,

Just to double check, you're referencing step 3 in this document: https://docs.openstack.org/image-guide/windows-image.html ?

And your request is to add an additional sub-step describing how to load network drivers?

Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → Medium
Download full text (3.3 KiB)

Hi,

Yes, I am asking for a sub-step to be added in Step 3 showing how to add
network drivers.

Thanks,
Rakshith

<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Virus-free.
www.avg.com
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

On Tue, Oct 3, 2017 at 5:49 PM, Alexandra Settle <email address hidden>
wrote:

> Hi there,
>
> Just to double check, you're referencing step 3 in this document:
> https://docs.openstack.org/image-guide/windows-image.html ?
>
> And your request is to add an additional sub-step describing how to load
> network drivers?
>
>
> ** Changed in: openstack-manuals
> Status: New => Confirmed
>
> ** Changed in: openstack-manuals
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1719815
>
> Title:
> Not detecting network drivers by default in "Example: Microsoft
> Windows image" in Virtual Machine Image Guide
>
> Status in openstack-manuals:
> Confirmed
>
> Bug description:
>
> This bug tracker is for errors with the documentation, use the
> following as a template and remove or add fields as you see fit.
> Convert [ ] into [x] to check boxes:
>
> - [x] This doc is inaccurate in this way: In step 3 "Enable the VirtIO
> drivers", the document says that the "E:\virtio-
> win-0.1XX\viostor\w7\amd64" needs to be selected and later the drivers
> for virtio scsi and network drivers get detected. This makes it seem
> like by choosing "E:\virtio-win-0.1XX\viostor\w7\amd64" both, the
> virtio scsi and network drivers will be detected. I have checked with
> different ISO images of windows (10, 8.1and server 12) and only the
> virtio scsi driver gets detected, while the network drivers do not
> appear. To detect the network drivers, first the virtio scsi drivers
> need to be selected and loaded from "E:\virtio-
> win-0.1XX\viostor\w7\amd64", and then "E:\NETKVM\win10\amd64" needs to
> be selected and loaded by again going to "Load drivers" button (The
> network driver's path given is assuming windows 10 is being loaded).
> The compute node which I am trying this on was installed as per
> instructions given here (https://docs.openstack.org/mitaka/install-
> guide-ubuntu/).
>
> It would help if an additional sub-step is provided describing how to
> load the network drivers.
>
>
> - [ ] This is a doc addition request.
> - [ ] I have a fix to the document that I can paste below including
> example: input and output.
>
> If you have a troubleshooting or support issue, use the following
> resources:
>
> - Ask OpenStack: http://ask.openstack.org
> - The mailing list: http://lists.openstack.org
> - IRC: 'openstack' channel on Freenode
>
> -----------------------------------
> Release: on 2017-09-27 02:20
> SHA: 8fad9fe9972355265979528ac472fbe5f686a037
> Source: https://git.openstack.org/cgit/openstack/openstack-
> manuals/tree/doc/source/windows-image.rst
> URL: https://docs.ope...

Read more...

Changed in openstack-manuals:
assignee: nobody → Onkar Dandekar (onkardandekar2)

Fix proposed to branch: master
Review: https://review.opendev.org/669579

Changed in openstack-manuals:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers