Support local_id configuration

Bug #1576888 reported by OpenStack Infra on 2016-04-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Trevor McCasland
openstack-manuals
Medium
zhaobo

Bug Description

https://review.openstack.org/310676
Dear bug triager. This bug was created since a commit was marked with DOCIMPACT.

commit 7cf4ef682f83fc08484011454f62c27882064dff
Author: nick.zhuyj <email address hidden>
Date: Wed Apr 27 03:36:02 2016 -0500

    Support local_id configuration

    In some case, we want to specify the local id instead of use the
    external ip. For example, the router is behind NAT, and we don't
    want to expose this IP to peer. This patch will make local_id
    configurable. Most often, local id would be domain name, email
    address etc. But if local id is not configured then external ip
    will still be used as the leftid.

    Note: this change is DocImpact & APIImpact

    Change-Id: I2433d72ba22ce410cbfafb7b8bfb16f51eefdfc1
    Closes-Bug: #1513353

Doug Wiegley (dougwig) wrote :

Looks like a devref

Changed in neutron:
status: New → Confirmed
importance: Undecided → Medium

This looks like a new feature to me and it needs a user as well as API documentation (see commit message).

Changed in openstack-manuals:
status: New → Confirmed
Changed in neutron:
assignee: nobody → Marcellin Fom Tchassem (mf6510)
Changed in neutron:
assignee: Marcellin Fom Tchassem (mf6510) → nobody
Changed in neutron:
assignee: nobody → Trevor McCasland (twm2016)

Fix proposed to branch: master
Review: https://review.openstack.org/378068

Changed in neutron:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/378068
Committed: https://git.openstack.org/cgit/openstack/neutron-lib/commit/?id=5f53e32f46c19afdb0695a0379e8826b1480f297
Submitter: Jenkins
Branch: master

commit 5f53e32f46c19afdb0695a0379e8826b1480f297
Author: Trevor McCasland <email address hidden>
Date: Wed Sep 7 13:12:39 2016 -0500

    api-ref: Update local_id configuration

    Adding local_id configuration support to api-ref with respect to the
    changes made in this commit 7cf4ef682f83fc08484011454f62c27882064dff.

    Change-Id: I2ea43c8cad95cb94529a3f576dced5d306b8da4c
    Closes-Bug: #1576888

Changed in neutron:
status: In Progress → Fix Released

This issue was fixed in the openstack/neutron-lib 1.1.0 release.

Changed in openstack-manuals:
importance: Undecided → Medium

Hi everyone,

Could you please update with where this doc fix is to take place in the user documentation and what that fix is?

Thank you,

Alex

Changed in openstack-manuals:
milestone: none → ocata
tags: added: low-hanging-fruit
removed: doc neutron-vpnaas
Changed in openstack-manuals:
status: Confirmed → Incomplete
zhaobo (zhaobo6) on 2017-02-09
Changed in openstack-manuals:
assignee: nobody → zhaobo (zhaobo6)
Ben Silverman (tersian) on 2017-09-12
Changed in openstack-manuals:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers