Update the Xen+Libvirt section in the Configuration Reference guide to account for new issues, features, developments, ...

Bug #1548403 reported by Lars Kurth
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Fix Released
Undecided
Lars Kurth

Bug Description

I collated review feedback on the existing documentation, and got the following.

Areas which are not yet fully clear:
1) Double check whether Xen+libvirt now works with Neutron and update documentation if necessary

Concrete proposals for Updates:

2) Incorporate into http://docs.openstack.org/liberty/config-reference/content/xen_libvirt.html#xen-libvirt-additional-configuration (note: since this not exactly a problem with most distros, but just something to pay attention to, we need to find a suitable location in the docs)

OpenStack compute nodes can use libguestfs to inject files in an instance's image prior to launching the instance. libguestfs uses libvirt's qemu driver to start a qemu process, which is then used to inject files into the image. When using libguestfs for file injection, the compute node must have the libvirt qemu driver installed, in addition to the Xen driver. In most distributions, the qemu driver is provided by the libvirt-daemon-qemu package.

3) Add to http://docs.openstack.org/liberty/config-reference/content/xen_libvirt.html#xen-libvirt-troubleshoot

On compute nodes running Kilo or later, live migration monitoring relies on libvirt APIs that are only implemented since version 1.3.1. When attempting to live migrate, the migration monitoring thread would crash and leave the instance state as "MIGRATING". If you experience such an issue and you're running on libvirt < 1.3.1 make sure you backport commits ad71665 and b7b4391 from upstream.

4) Add to http://docs.openstack.org/liberty/config-reference/content/xen_libvirt.html#xen-libvirt-troubleshoot

Live migration is supported on libxl libvirt driver since 1.2.5 though it is only fully supported on openstack since 1.3.2, that is without modifying the migration APIs being used by the libvirt client (nova). It is worth mentioning that 1.3.0 addresses most of these issues with respect to libvirt migration protocol compatibility; and 1.3.2 gets support for peer to peer migration mode which nova relies on.

Changed in openstack-manuals:
assignee: nobody → Lars Kurth (lars-kurth-d)
Changed in openstack-manuals:
status: New → Confirmed
Revision history for this message
Jim Fehlig (jfehlig) wrote :

Agreed that we should update the docs to reflect latest developments of Xen+libvirt+OpenStack.

Changed in openstack-manuals:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (master)

Fix proposed to branch: master
Review: https://review.openstack.org/283721

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (master)

Reviewed: https://review.openstack.org/283721
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=3e2a61b65c6e8952f444e643f44dea73af90ebc0
Submitter: Jenkins
Branch: master

commit 3e2a61b65c6e8952f444e643f44dea73af90ebc0
Author: Lars Kurth <email address hidden>
Date: Tue Feb 23 12:37:04 2016 -0500

    [config-ref] Added Config Options and Known Issues for Xen+Libvirt

    In particular I added the following:
    - The recommended libvirt version = 1.3.2 or newer
    - Additional config options:
      New section on libguestfs file injection
    - New Known issues:
      Live migration and live migration monitoring
    - Use sentence-case capitalization in headlines
    - Consistently spell libvirt in lowercase

    Change-Id: Ied485cec8033612b237f2f8e5f19e742b2a6ac7a
    Closes-Bug: #1548403

Changed in openstack-manuals:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/openstack-manuals 15.0.0

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers