OpenStack packages in Installation Guide

Bug #1511462 reported by venkata teja on 2015-10-29
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Liberty
Low
Unassigned
openstack-manuals
Undecided
Unassigned

Bug Description

W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems
-----------------------------------
Release: 0.1 on 2015-10-29 15:35
SHA: dcf1607068eb85d511cb57b7023b71891be383d2
Source: http://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/install-guide/source/environment-packages.rst
URL: http://docs.openstack.org/liberty/install-guide-ubuntu/environment-packages.html

Matt Kassawara (ionosphere80) wrote :

Packaging problem. Please open a bug with Ubuntu.

Changed in openstack-manuals:
status: New → Invalid
James Page (james-page) wrote :

This is a bug that's specific to the UCA for liberty - I think its actually entirely harmless (I've not seen any installability issues due to this) and is related to the use of versioned Provides that are not supported by apt/dpkg in Ubuntu 14.04 (but are OK in Ubuntu 15.10):

 Provides: python-cffi-backend-api-max (= 9983), python-cffi-backend-api-min (= 9729)

James Page (james-page) wrote :

To resolve this issue we'll need to maintain a delta against the 15.10 package for python-cffi

Changed in cloud-archive:
assignee: nobody → Amulya Battu (battu-amulya)
status: New → In Progress
Changed in cloud-archive:
assignee: Amulya Battu (battu-amulya) → nobody
status: In Progress → New
Changed in cloud-archive:
status: New → Triaged
importance: Undecided → Medium
Changed in cloud-archive:
importance: Medium → Low
Raffaele Santone (raffaelesan) wrote :

this issue cannot allow to install nova-compute-lxd , unable to locatee package on ubuntu 14.04.3

James Page (james-page) wrote :

nova-compute-lxd is not available on 14.04 yet due to bug 1443704 preventing it being backported; we're working on that but the warnings generated in the liberty UCA are not service impacting and are not the cause of nova-compute-lxd not being installable.

UBNewbie (hhtjioe) wrote :

Hello.
What is the workaround to solve this?
It preventing me to go further to start with installing the OpenStack packages.

James Page (james-page) on 2015-11-27
Changed in cloud-archive:
status: Triaged → Invalid
importance: Low → Undecided
James Page (james-page) wrote :

New update released which drops the use of versioned provides for the UCA.

Raddah (raddah) wrote :

I just this problem again on server ubuntu 14.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers