Update API version in Compute config for controller

Bug #1505087 reported by Brian Moss on 2015-10-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Undecided
Brian Moss

Bug Description

Tested on Fedora 22 using the Delorean repo.

Step 4 of the Prerequisites procedure has the wrong version of the Nova API. For example:

openstack endpoint create --region RegionOne compute public http://controller:8774/v2/%\(tenant_id\)s

Using "v2" when creating the endpoints causes all nova commands to return::

ERROR (UnsupportedVersion): Server doesn't support microversions

Correct by changing 'v2' to 'v2.1' for each endpoint creation command. For example::

openstack endpoint create --region RegionOne compute publichttp://controller:8774/v2.1/%\(tenant_id\)s

-----------------------------------
Release: 0.1 on 2015-10-11 17:40
SHA: 97c1be9d54c2d39ba411cff21d5faae1e1d52aa5
Source: http://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/install-guide/source/nova-controller-install.rst
URL: http://docs.openstack.org/draft/install-guide-rdo/nova-controller-install.html

Matt Kassawara (ionosphere80) wrote :

Someone needs to explain this observation:

The packages for Fedora in http://beta.rdoproject.org/testday/rdo-test-day-liberty-01/ reference Mitaka versions now.

The packages for Fedora in http://beta.rdoproject.org/testday/rdo-test-day-liberty-02/ don't exist.

What's going on here?

Changed in openstack-manuals:
milestone: none → mitaka
Changed in openstack-manuals:
importance: Undecided → Medium
Atsushi SAKAI (sakaia) wrote :

Matt

As you know , this is compute api version up issue.
So it should fix from v2 to v2.1.
And microversion is coming from v2.1.

Changed in openstack-manuals:
status: New → Confirmed
Matt Kassawara (ionosphere80) wrote :

Given the problems with RDO packages, did this problem occur on Liberty or Mitaka?

Changed in openstack-manuals:
status: Confirmed → Incomplete
importance: Medium → Undecided
Changed in openstack-manuals:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers