Liberty install guide RHEL, Configure NTP: Verification step comes before Configuration step

Bug #1501704 reported by Bernd Bausch on 2015-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
High
Tom Fifield

Bug Description

The NTP configuration section starts with Verification; the next step is Configuration. Should be the other way around.

-----------------------------------
Release: 0.1 on 2015-10-01 09:31
SHA: bded70f26bac3fb9f4a70a05062450061f3c7c79
Source: http://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/install-guide/source/environment-ntp.rst
URL: http://docs.openstack.org/draft/install-guide-rdo/environment-ntp.html

Christian Berendt (berendt) wrote :

Cannot verify this issue. On http://docs.openstack.org/draft/install-guide-rdo/environment-ntp.html first you have to configure the controller node and the other nodes, than you have to verify the functionality on the controller node and on the other nodes.

Maybe the content of the configuration instructions for the "Controller node" and "Other nodes" should be included and not linked?

Tom Fifield (fifieldt) on 2015-10-01
Changed in openstack-manuals:
status: New → Incomplete
Bernd Bausch (berndbausch) wrote :

Misunderstanding on my part. This might mean that it's expressed in a way that is easy to misunderstand. The page referenced by Christian has this structure:

- Paragraph "You should install Chrony..."
- Links to installation of Chrony on controller and other nodes
- Section "Verify Operation"

To me, it would be more natural to describe the installation of Chrony on this page rather than provide links to the description. The Verification section could be on the same page or the next page in the flow.

KATO Tomoyuki (kato-tomoyuki) wrote :

I think the current description is a little confusable, and it is easy to understand that the verify step breaks down into an individual page.

Matt Kassawara (ionosphere80) wrote :

This feels like another "~~~" vs. "---" heading issue.

Tom Fifield (fifieldt) wrote :

This is broken on Ubuntu as well

http://docs.openstack.org/draft/install-guide-ubuntu/environment-ntp.html

The Verify steps appear first, so you end up with

fifieldt@compute:~$ chronyc sources
The program 'chronyc' is currently not installed. You can install it by typing:
sudo apt-get install chrony

Changed in openstack-manuals:
status: Incomplete → Confirmed
milestone: none → liberty
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/230868

Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/230868
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=ec25954df1ee498bf8990f935b0f835bc4d92355
Submitter: Jenkins
Branch: master

commit ec25954df1ee498bf8990f935b0f835bc4d92355
Author: Tom Fifield <email address hidden>
Date: Mon Oct 5 12:18:55 2015 +0800

    Fix NTP verify appearing before install

    Due to the way the toctree was working on this page, the
    steps to verify the NTP installation:
    a) appeared prominently on the initial page, leading to
    people wanting to try them before installing the service
    b) were not available in a logical order when using the
    previous/next buttons

    This patch adds a new file for the verify steps to fix a)
    and b) and includes it from the toctree. It's a solution,
    but may not be the best solution.

    Change-Id: I14b977147e70bf29ea42e40bb337c89426e6b8d5
    Closes-Bug: 1501704

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers