In CentOS 7 the cinder (and instance creation along with it) service fails to start due to insufficient permission to create /var/lock/cinder directory

Bug #1490963 reported by Michal Adamczyk on 2015-09-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Matt Kassawara

Bug Description

The fix - use following path and the cinder service will start normally without changing permissions to /run/lock directory:

[oslo_concurrency]

lock_path = /var/lib/cinder/tmp

-----------------------------------
Built: 2015-08-27T08:48:18 00:00
git SHA: f062eb42bbc512386ac572b5b830fb4e21c72a41
URL: http://docs.openstack.org/kilo/install-guide/install/yum/content/cinder-install-storage-node.html
source File: file:/home/jenkins/workspace/openstack-manuals-tox-doc-publishdocs/doc/install-guide/section_cinder-storage-node.xml
xml:id: cinder-install-storage-node

Tom Fifield (fifieldt) wrote :

@matt, IIRC you did some work on the temp file path in the install guide before. Can you confirm?

Changed in openstack-manuals:
milestone: none → liberty
tags: added: install-guide
Changed in openstack-manuals:
assignee: nobody → Matt Kassawara (ionosphere80)
status: New → Incomplete
Tom Fifield (fifieldt) wrote :

Bernd Bausch noted in the duiplicate bug:

On my Centos 7 system (CentOS Linux release 7.1.1503), the Cinder processes run under the cinder user.

/var/lock/cinder, used for concurrency, can't be created because the cinder user has no write access to /var/lock (which is a symbolic link to /run/lock).
Possible solutions: Adding write permissions for "other" on /run/lock, or setting up an ACL so that just the cinder user can access the lock directory.

Tom Fifield (fifieldt) wrote :

Since two users have experienced this problem, it seems confirmed

Changed in openstack-manuals:
importance: Undecided → Medium
status: Incomplete → Confirmed
Matt Kassawara (ionosphere80) wrote :

Packaging bug, but we know how quickly those get fixed, so we can implement a workaround.

Fix proposed to branch: master
Review: https://review.openstack.org/235373

Changed in openstack-manuals:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/235373
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=96fd3eb174b63e584561108b28e1a20cd4f610fd
Submitter: Jenkins
Branch: master

commit 96fd3eb174b63e584561108b28e1a20cd4f610fd
Author: Matthew Kassawara <email address hidden>
Date: Thu Oct 15 08:06:43 2015 -0600

    [install] Fix cinder lock path

    Fix cinder lock path to work around packaging bug.
    Primarily applies to RDO, but shouldn't negatively
    impact other distributions.

    Change-Id: I06ad6ab1224ceb787b30ec4b2135c062a8b69e8d
    Closes-Bug: #1490963
    backport: kilo

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers