Create the service entity and API endpoint in OpenStack Installation Guide for Red Hat Enterprise Linux 7, CentOS 7, and Fedora 21  - kilo

Bug #1490064 reported by Coekie on 2015-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Undecided
Unassigned

Bug Description

Hi,

This part of the kilo release does not work, in any way. I tried anything, through the hhtpd wsgi way, blocked because the error is is accessing the log file. Or, through the keystone service and the it blocked the database.

Fedora 22, minimal install, guest vm on Windows 7....kilo rdo. Using postgresql, and yes it is reachable on local and ip ports. Also read everything from changing to localhost and just chmod 777 on keystone.log. It ain't working. Destroyed VM and started new. Still no.

So serious bug ;)

PS In this manual maybe security should be included....cause start early....better deployed ;)
-----------------------------------
Built: 2015-08-27T08:48:14 00:00
git SHA: f062eb42bbc512386ac572b5b830fb4e21c72a41
URL: http://docs.openstack.org/kilo/install-guide/install/yum/content/keystone-services.html
source File: file:/home/jenkins/workspace/openstack-manuals-tox-doc-publishdocs/doc/install-guide/section_keystone-services.xml
xml:id: keystone-services

tags: added: install-guide
Coekie (wyhswm) wrote :

Hi,

Sorry, after messing around today, I figured out SElinux permissions for Apache to the keystone log file and postgresql database were not setup properly. Maybe it should be mentioned for people using a distro with SElinux enforced, or maybe a poilcy rpm made and added to the install packages line in the document.

Anyway I fixed it, it is working now through the Apache wsgi scripts.

Thanks ;)

Matt Kassawara (ionosphere80) wrote :

The installation guide does not support Fedora 22 or PostgreSQL.

Changed in openstack-manuals:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers