swiftclient.service.SwiftError: 'Account not found'

Bug #1485278 reported by Udayendu Kar on 2015-08-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Alexandra Settle

Bug Description

-----------------------------------
Built: 2015-08-07T01:59:18 00:00
git SHA: abdedacebf22df1ae7bec8ab27ed498a3fdfc650
URL: http://docs.openstack.org/kilo/install-guide/install/apt/content/swift-install-controller-node.html
source File: file:/home/jenkins/workspace/openstack-manuals-tox-doc-publishdocs/doc/install-guide/section_swift-controller-node.xml
xml:id: swift-install-controller-node

Udayendu Kar (udayendu-kar) wrote :

As per the swift installation documentation on controller node, following need to be there in proxy-server.conf:

In the [pipeline:main] section, enable the appropriate modules:
~~~~
[pipeline:main]
pipeline = catch_errors gatekeeper healthcheck proxy-logging cache container_sync bulk ratelimit authtoken keystoneauth container-quotas account-quotas slo dlo proxy-logging proxy-server
~~~~

Which is causing the below error:

~~~~
# swift stat
Traceback (most recent call last):
  File "/usr/bin/swift", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/dist-packages/swiftclient/shell.py", line 1287, in main
    globals()['st_%s' % args[0]](parser, argv[1:], output)
  File "/usr/lib/python2.7/dist-packages/swiftclient/shell.py", line 492, in st_stat
    stat_result = swift.stat()
  File "/usr/lib/python2.7/dist-packages/swiftclient/service.py", line 443, in stat
    raise SwiftError('Account not found', exc=err)
swiftclient.service.SwiftError: 'Account not found'
~~~~

To overcome this error, need to change the above entry to:

~~~~
 pipeline = catch_errors healthcheck cache authtoken proxy-logging proxy-server
~~~~

willy lin (willy-l) on 2015-08-17
Changed in openstack-manuals:
assignee: nobody → willy lin (willy-l)

Fix proposed to branch: master
Review: https://review.openstack.org/213568

Changed in openstack-manuals:
status: New → In Progress

Change abandoned by willy lin (<email address hidden>) on branch: master
Review: https://review.openstack.org/213568

Vitaly Yevstigneyev (asmaral71) wrote :

The workaround described above did not work for me: I'm still experiencing this error.

Udayendu Kar (udayendu-kar) wrote :

@Vitaly,

Try the below:

  # swift -V 3 stat

Sorry for my typo in the above. I was just testing without '-V 3' but its 100% reproducible in my system with '-V 3' which is the correct way as per the doc. With the default entry as per the doc, I am getting that error but after replacing that with the new entry its working. My new entry is:

    pipeline = catch_errors healthcheck cache authtoken proxy-logging proxy-server

NOTE: After the change you have to restart 'swift-proxy' service and source the file having environmental variables bedore rinning "swift -V 3 stat" command.

Apart from that line, no changes were made in "proxy-server.conf" file. Its just having the change as mentioned in the openstack swift doc.

If you have already tried the above then let me know, I will change the password and will share my proxy-server.conf file for you.

Matt Kassawara (ionosphere80) wrote :

Why are you disabling the 'keystoneauth' pipeline?

Changed in openstack-manuals:
status: In Progress → Incomplete
Udayendu Kar (udayendu-kar) wrote :

Matt,

I dont want to disable but with keystomeauth I am unable to use swift.

Change abandoned by willy lin (<email address hidden>) on branch: master
Review: https://review.openstack.org/213596

Hi Willy Lin,

Were you able to progress on this solution any further? Do you need help triaging this bug?

Thanks.

Changed in openstack-manuals:
importance: Undecided → Medium

@udayendu-kar

More information needs to be provided for this bug to be verified. Have you solved your issue? If so, were you able to replicate it more than once?

Changed in openstack-manuals:
assignee: willy lin (willy-l) → Alexandra Settle (alexandra-settle)

I'm closing this as I cannot triage this bug and replicate it.
If someone can prove that this bug is indeed able to be replicated and a problem within the documentation, please reopen.

Changed in openstack-manuals:
status: Incomplete → Invalid
sfinga (holanova-al) wrote :
Download full text (3.5 KiB)

Hi,

I tried to solve this bug one week ago. Disabling keystoneauth in pipeline helped me, but without authentication with keystone I was able to get any file from any tenant.
So I tried deploy DevStack with Swift and then I compare proxy-server.conf files.

There was some differences in pipeline and in order of filters. I set the proxy-server.conf file same way as in DevStack and it works.

root@prx03:~# vim /etc/swift/proxy-server.conf

[DEFAULT]
bind_ip = 0.0.0.0
bind_port = 8080
swift_dir = /etc/swift
user = swift

log_level = DEBUG

[pipeline:main]
pipeline = catch_errors gatekeeper healthcheck proxy-logging cache container_sync bulk tempurl ratelimit crossdomain authtoken keystoneauth tempauth formpost staticweb container-quotas account-quotas slo dlo proxy-logging proxy-server

[app:proxy-server]
account_autocreate = true
conn_timeout = 20
node_timeout = 120
use = egg:swift#proxy

[filter:tempauth]
user_swifttenanttest1_swiftusertest3 = testing3 .admin
user_swifttenanttest2_swiftusertest2 = testing2 .admin
user_swifttenanttest1_swiftusertest1 = testing .admin
use = egg:swift#tempauth

user_admin_admin = admin .admin .reseller_admin
user_test_tester = testing .admin
user_test2_tester2 = testing2 .admin
user_test_tester3 = testing3
user_test5_tester5 = testing5 service

[filter:healthcheck]
use = egg:swift#healthcheck

[filter:cache]
use = egg:swift#memcache

[filter:ratelimit]
use = egg:swift#ratelimit

[filter:domain_remap]
use = egg:swift#domain_remap

[filter:catch_errors]
use = egg:swift#catch_errors

[filter:cname_lookup]
use = egg:swift#cname_lookup

[filter:staticweb]
use = egg:swift#staticweb

[filter:tempurl]
use = egg:swift#tempurl

[filter:formpost]
use = egg:swift#formpost

[filter:name_check]
use = egg:swift#name_check

[filter:list-endpoints]
use = egg:swift#list_endpoints

[filter:proxy-logging]
reveal_sensitive_prefix = 12
use = egg:swift#proxy_logging

[filter:bulk]
use = egg:swift#bulk

[filter:slo]
use = egg:swift#slo

[filter:dlo]
use = egg:swift#dlo

[filter:container-quotas]
use = egg:swift#container_quotas

[filter:account-quotas]
use = egg:swift#account_quotas

[filter:gatekeeper]
use = egg:swift#gatekeeper

[filter:container_sync]
use = egg:swift#container_sync

[filter:xprofile]
use = egg:swift#xprofile

[filter:versioned_writes]
use = egg:swift#versioned_writes

[filter:crossdomain]
use = egg:swift#crossdomain

[filter:authtoken]
include_service_catalog = False
cache = swift.cache
delay_auth_decision = 1
signing_dir = /var/cache/swift
auth_uri = http://IPADDRESS:5000
project_domain_id = default
project_name = service
user_domain_id = default
password = password
username = swift
auth_url = http://IPADDRESS:35357
auth_plugin = password
paste.filter_factory = keystonemiddleware.auth_token:filter_factory
log_name = swift

[filter:keystoneauth]
operator_roles = Member, admin
use = egg:swift#keystoneauth

After that I restarted proxy server.

root@prx03:~# swift-init proxy-server restart

And check if swift works.

root@ctl01:~# source keystonercv3

root@ctl01:~# swift -V 3 stat

root@ctl01:~# swift -V 3 stat
        Account: AUTH_cd3b21ac433c4ff6aff8e1ae144a196f
     Containers: 0
        Objects: 0
          B...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers