Install and configure in OpenStack Installation Guide for Ubuntu 14.04  - kilo Internal Server Error (HTTP 500) when initializing keystone service

Bug #1482523 reported by Bill Chang on 2015-08-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Undecided
Unassigned

Bug Description

 Following the official instructions to install Openstack Kilo, while having all passwds being the same.
  http://docs.openstack.org/kilo/install-guide/install/apt/content/keystone-install.html

  However, stuck at running openstack service create --name keystone
  --description "OpenStack Identity" identity, returning Internal Server
  Error (HTTP 500).

  Tried chown -R keystone:keystone /etc/keystone && keystone-manage
  db_sync , but didn't work.
  https://bugs.launchpad.net/keystone/+bug/1457747

  The keystone-error.log shows:
  2015-08-05 16:13:23.509213 mod_wsgi (pid=14120, process='keystone-admin', application=''): Loading WSGI script '/var/www/cgi-bin/keystone/admin'.
  2015-08-05 16:13:23.509366 mod_wsgi (pid=14120): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-05 17:28:39.434934 mod_wsgi (pid=14123, process='keystone-admin', application=''): Loading WSGI script '/var/www/cgi-bin/keystone/admin'.
  2015-08-05 17:28:39.435110 mod_wsgi (pid=14123): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-05 17:29:36.039690 mod_wsgi (pid=14121, process='keystone-admin', application=''): Loading WSGI script '/var/www/cgi-bin/keystone/admin'.
  2015-08-05 17:29:36.039844 mod_wsgi (pid=14121): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-05 17:29:47.176358 mod_wsgi (pid=14122, process='keystone-admin', application=''): Loading WSGI script '/var/www/cgi-bin/keystone/admin'.
  2015-08-05 17:29:47.176517 mod_wsgi (pid=14122): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-06 14:04:04.519655 mod_wsgi (pid=14121): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-06 14:21:50.278666 mod_wsgi (pid=14123): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'.
  2015-08-06 14:52:12.285983 mod_wsgi (pid=14121): Target WSGI script '/var/www/cgi-bin/keystone/admin' does not contain WSGI application 'application'

-----------------------------------
Built: 2015-07-17T00:19:20 00:00
git SHA: 4c9835270b01fb1d14533d6741f1455a188768cb
URL: http://docs.openstack.org/kilo/install-guide/install/apt/content/keystone-install.html
source File: file:/home/jenkins/workspace/openstack-manuals-tox-doc-publishdocs/doc/install-guide/section_keystone-install.xml
xml:id: keystone-install

Matt Kassawara (ionosphere80) wrote :

Please verify that you're installing Kilo packages and recheck your configuration... perhaps a typo somewhere?

Changed in openstack-manuals:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for openstack-manuals because there has been no activity for 60 days.]

Changed in openstack-manuals:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers