Comment 2 for bug 1469228

mark (mark-chuman) wrote :

Thanks for checking. I've run over the install again and this is what my admin-openrc.sh looks like per the install doc and some commands that illustrate the issue a bit more.

--

myuserid@servername:~$ cat admin-openrc.sh
export OS_PROJECT_DOMAIN_ID=default
export OS_USER_DOMAIN_ID=default
export OS_PROJECT_NAME=admin
export OS_TENANT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password123
export OS_AUTH_URL=http://servername:35357/v3
export OS_IMAGE_API_VERSION=2

myuserid@servernameN:~$ keystone --os-username=admin --os-password=password123 --os-tenant-name=admin --os-auth-url=http://servername:35357/v3.0 service-list
Authorization Failed: The resource could not be found. (HTTP 404)

myuserid@servername:~$ keystone service-list
Authorization Failed: The resource could not be found. (HTTP 404) (Request-ID: req-dc2d595d-1a74-4ed7-8f5f-3b468a25f26a)

myuserid@servername:~$ keystone --os-username=admin --os-password=password123 --os-tenant-name=admin --os-auth-url=http://servername:35357/v2.0 service-list
+----------------------------------+----------+----------+-------------------------+
| id | name | type | description |
+----------------------------------+----------+----------+-------------------------+
| 34ee75f1e7c549d5b3e9e74b43140fb0 | glance | image | OpenStack Image service |
| 37d19d865f5c45fb996b8fdfcc97ae96 | keystone | identity | OpenStack Identity |
+----------------------------------+----------+----------+-------------------------+